aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libsigcx/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-04-06 15:16:01 +0800
committerijliao <ijliao@FreeBSD.org>2003-04-06 15:16:01 +0800
commit737697d71753db1f86a49184aef32843c3791273 (patch)
tree0bee46519aba47806c17cbf3f7fcffd0278f3f87 /devel/libsigcx/Makefile
parent8ce84bf8ce26d191d096b53c3d62d222a930af72 (diff)
downloadfreebsd-ports-gnome-737697d71753db1f86a49184aef32843c3791273.tar.gz
freebsd-ports-gnome-737697d71753db1f86a49184aef32843c3791273.tar.zst
freebsd-ports-gnome-737697d71753db1f86a49184aef32843c3791273.zip
add libsigcx 0.6.0
libSigC++ Extras
Diffstat (limited to 'devel/libsigcx/Makefile')
-rw-r--r--devel/libsigcx/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/libsigcx/Makefile b/devel/libsigcx/Makefile
new file mode 100644
index 000000000000..a49e55a30b79
--- /dev/null
+++ b/devel/libsigcx/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: libsigcx
+# Date created: Apr 6, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsigcx
+PORTVERSION= 0.6.0
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= libsigcx
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= libSigC++ Extras
+
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12
+
+USE_REINPLACE= yes
+USE_GNOME= gtk20
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
+
+.include <bsd.port.mk>