aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libslang2-devel
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2005-05-17 01:13:02 +0800
committernovel <novel@FreeBSD.org>2005-05-17 01:13:02 +0800
commitcb52e251b35f004079fe23762265a54dfc92450e (patch)
tree91cf65b3d05724c2c1564124c7fcd78d4be06bd3 /devel/libslang2-devel
parent7f977e9e22f0081f091acc954c29c55ee1664175 (diff)
downloadfreebsd-ports-gnome-cb52e251b35f004079fe23762265a54dfc92450e.tar.gz
freebsd-ports-gnome-cb52e251b35f004079fe23762265a54dfc92450e.tar.zst
freebsd-ports-gnome-cb52e251b35f004079fe23762265a54dfc92450e.zip
Add devel/libslang2 - a multi-platform programmer's library designed to
allow a developer to create robust multi-platform software. PR: 81110 Submitted by: Renato Botelho <freebsd@galle.com.br>
Diffstat (limited to 'devel/libslang2-devel')
-rw-r--r--devel/libslang2-devel/Makefile42
-rw-r--r--devel/libslang2-devel/distinfo2
-rw-r--r--devel/libslang2-devel/files/patch-src-slinclud.h11
-rw-r--r--devel/libslang2-devel/pkg-descr12
-rw-r--r--devel/libslang2-devel/pkg-plist63
5 files changed, 130 insertions, 0 deletions
diff --git a/devel/libslang2-devel/Makefile b/devel/libslang2-devel/Makefile
new file mode 100644
index 000000000000..2ea8cb962853
--- /dev/null
+++ b/devel/libslang2-devel/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: libslang2
+# Date created: 2005-05-16
+# Whom: Renato Botelho <freebsd@galle.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libslang2
+PORTVERSION= 2.0.2
+CATEGORIES= devel
+MASTER_SITES= ftp://space.mit.edu/pub/davis/slang/v2.0/
+DISTNAME= slang-${PORTVERSION}
+
+MAINTAINER= freebsd@galle.com.br
+COMMENT= Routines for rapid alpha-numeric terminal applications development
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+CONFLICTS= libslang-1.*
+
+ALL_TARGET= all elf
+INSTALL_TARGET= install install-elf
+
+MAN1= slsh.1
+DOCSDIR= ${PREFIX}/share/doc/slang
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's, install_docs,,g' ${WRKSRC}/src/Makefile.in
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libslang2-devel/distinfo b/devel/libslang2-devel/distinfo
new file mode 100644
index 000000000000..d6bbbd533096
--- /dev/null
+++ b/devel/libslang2-devel/distinfo
@@ -0,0 +1,2 @@
+MD5 (slang-2.0.2.tar.bz2) = 6ef4ae010f17bc1238a978b8dc0ce154
+SIZE (slang-2.0.2.tar.bz2) = 1035709
diff --git a/devel/libslang2-devel/files/patch-src-slinclud.h b/devel/libslang2-devel/files/patch-src-slinclud.h
new file mode 100644
index 000000000000..c939e13dd854
--- /dev/null
+++ b/devel/libslang2-devel/files/patch-src-slinclud.h
@@ -0,0 +1,11 @@
+--- src/slinclud.h.orig Mon May 16 16:11:14 2005
++++ src/slinclud.h Mon May 16 16:11:48 2005
+@@ -20,7 +20,7 @@
+ # include <unistd.h>
+ #endif
+
+-#ifdef HAVE_MALLOC_H
++#if 0
+ # include <malloc.h>
+ #endif
+
diff --git a/devel/libslang2-devel/pkg-descr b/devel/libslang2-devel/pkg-descr
new file mode 100644
index 000000000000..fdbf2a163291
--- /dev/null
+++ b/devel/libslang2-devel/pkg-descr
@@ -0,0 +1,12 @@
+S-Lang is a multi-platform programmer's library designed to
+allow a developer to create robust multi-platform software.
+
+It provides facilities required by interactive applications
+such as display/screen management, keyboard input, keymaps,
+and so on.
+
+The most exciting feature of the library is the slang
+interpreter that may be easily embedded into a program to
+make it extensible.
+
+WWW: http://www.s-lang.org
diff --git a/devel/libslang2-devel/pkg-plist b/devel/libslang2-devel/pkg-plist
new file mode 100644
index 000000000000..d36956fdba79
--- /dev/null
+++ b/devel/libslang2-devel/pkg-plist
@@ -0,0 +1,63 @@
+@comment $FreeBSD$
+bin/slsh
+etc/slsh.rc
+include/slang.h
+include/slcurses.h
+lib/libslang.a
+lib/libslang.so.2
+lib/libslang.so
+lib/slang/v2/modules/slsmg-module.so
+lib/slang/v2/modules/termios-module.so
+lib/slang/v2/modules/select-module.so
+lib/slang/v2/modules/fcntl-module.so
+lib/slang/v2/modules/varray-module.so
+lib/slang/v2/modules/pcre-module.so
+lib/slang/v2/modules/png-module.so
+share/slsh/scripts/jpegsize
+share/slsh/scripts/lsrpm
+share/slsh/scripts/sldb
+share/slsh/scripts/svnsh
+share/slsh/arrayfuns.sl
+share/slsh/autoload.sl
+share/slsh/glob.sl
+share/slsh/print.sl
+share/slsh/require.sl
+share/slsh/sldb.sl
+share/slsh/sldbcore.sl
+share/slsh/slshrl.sl
+share/slsh/stkcheck.sl
+share/slsh/structfuns.sl
+share/slsh/slsmg.sl
+share/slsh/termios.sl
+share/slsh/select.sl
+share/slsh/fcntl.sl
+share/slsh/varray.sl
+share/slsh/pcre.sl
+share/slsh/png.sl
+share/slsh/cmaps/cool.map
+share/slsh/cmaps/copper.map
+share/slsh/cmaps/drywet.map
+share/slsh/cmaps/gebco.map
+share/slsh/cmaps/globe.map
+share/slsh/cmaps/gray.map
+share/slsh/cmaps/haxby.map
+share/slsh/cmaps/hot.map
+share/slsh/cmaps/jet.map
+share/slsh/cmaps/no_green.map
+share/slsh/cmaps/ocean.map
+share/slsh/cmaps/polar.map
+share/slsh/cmaps/rainbow.map
+share/slsh/cmaps/red2green.map
+share/slsh/cmaps/relief.map
+share/slsh/cmaps/sealand.map
+share/slsh/cmaps/seis.map
+share/slsh/cmaps/split.map
+share/slsh/cmaps/topo.map
+share/slsh/cmaps/wysiwyg.map
+share/slsh/help/pcrefuns.hlp
+share/slsh/help/pngfuns.hlp
+@dirrm share/slsh/scripts
+@dirrm share/slsh/help
+@dirrm share/slsh/cmaps
+@unexec rmdir %D/share/slsh/local-packages 2>/dev/null || true
+@dirrm share/slsh