aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libsoup
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2018-09-30 19:58:29 +0800
committerkwm <kwm@FreeBSD.org>2018-09-30 19:58:29 +0800
commit1f45d9eb2b1cd9ba6632b2331526d2dfe4cb17fa (patch)
tree6146e775343aaf339921799078894a48fef9aa15 /devel/libsoup
parentb640e6d0ba34a529816c17d494eb8ca09ca720fd (diff)
downloadfreebsd-ports-gnome-1f45d9eb2b1cd9ba6632b2331526d2dfe4cb17fa.tar.gz
freebsd-ports-gnome-1f45d9eb2b1cd9ba6632b2331526d2dfe4cb17fa.tar.zst
freebsd-ports-gnome-1f45d9eb2b1cd9ba6632b2331526d2dfe4cb17fa.zip
The FreeBSD GNOME team proudly presents GNOME 3.28 for FreeBSD.
The offical GNOME 3.28 release notes can be found at https://help.gnome.org/misc/release-notes/3.28/ Thanks to Antoine Brodin for running the exp-runs. PR: 229761
Diffstat (limited to 'devel/libsoup')
-rw-r--r--devel/libsoup/Makefile21
-rw-r--r--devel/libsoup/distinfo6
-rw-r--r--devel/libsoup/files/patch-libsoup_soup-auth-negotiate.c15
-rw-r--r--devel/libsoup/files/patch-libsoup_soup-filter-input-stream.c49
-rw-r--r--devel/libsoup/pkg-plist4
5 files changed, 22 insertions, 73 deletions
diff --git a/devel/libsoup/Makefile b/devel/libsoup/Makefile
index 4499159db03e..5e10e68eb116 100644
--- a/devel/libsoup/Makefile
+++ b/devel/libsoup/Makefile
@@ -2,34 +2,31 @@
# $FreeBSD$
PORTNAME= libsoup
-PORTVERSION= 2.54.1
-PORTREVISION= 0
+PORTVERSION= 2.62.2
CATEGORIES= devel gnome
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= SOAP (Simple Object Access Protocol) implementation in C
+LICENSE= LGPL20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= glib-networking>=2.29.18:net/glib-networking
LIB_DEPENDS= libgcrypt.so:security/libgcrypt
RUN_DEPENDS= glib-networking>=2.29.18:net/glib-networking
-USES= tar:xz
PORTSCOUT= limitw:1,even
-.if !defined(REFERENCE_PORT)
-
-USES+= gettext gmake gnome libtool pathfix pkgconfig \
- python:build sqlite:3 tar:xz
+USES= gettext gmake gnome libtool localbase pathfix \
+ pkgconfig python:3.6+,build sqlite ssl tar:xz
USE_GNOME= glib20 intlhack introspection:build \
libxml2 referencehack
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-more-warnings \
--disable-vala
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
LIBVERSION= 1.8.0
@@ -46,7 +43,7 @@ CONFIGURE_ARGS+=--without-gnome
post-patch:
@${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|env python|env ${PYTHON_VERSION}|g' \
+ @${REINPLACE_CMD} -e 's|env python3|env ${PYTHON_VERSION}|g' \
${WRKSRC}/libsoup/tld-parser.py
@${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|g' \
${WRKSRC}/configure
@@ -74,5 +71,3 @@ post-install:
.endif
.include <bsd.port.mk>
-
-.endif
diff --git a/devel/libsoup/distinfo b/devel/libsoup/distinfo
index a7c35a9cf0af..0d462d8a2a16 100644
--- a/devel/libsoup/distinfo
+++ b/devel/libsoup/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1508503209
-SHA256 (gnome2/libsoup-2.54.1.tar.xz) = 47b42c232034734d66e5f093025843a5d8cc4b2357c011085a2fd04ef02dd633
-SIZE (gnome2/libsoup-2.54.1.tar.xz) = 1793108
+TIMESTAMP = 1525958761
+SHA256 (gnome/libsoup-2.62.2.tar.xz) = 9e536fe3da60b25d2c63addb84a9d5072d00b0d8b8cbeabc629a6bcd63f879b6
+SIZE (gnome/libsoup-2.62.2.tar.xz) = 1848752
diff --git a/devel/libsoup/files/patch-libsoup_soup-auth-negotiate.c b/devel/libsoup/files/patch-libsoup_soup-auth-negotiate.c
index 3c08db164cbf..c1fed6510cf1 100644
--- a/devel/libsoup/files/patch-libsoup_soup-auth-negotiate.c
+++ b/devel/libsoup/files/patch-libsoup_soup-auth-negotiate.c
@@ -1,10 +1,11 @@
---- libsoup/soup-auth-negotiate.c.orig 2016-03-14 16:19:35 UTC
-+++ libsoup/soup-auth-negotiate.c
-@@ -14,7 +14,6 @@
+--- libsoup/soup-auth-negotiate.c.orig 2016-04-07 16:25:20.853309000 +0200
++++ libsoup/soup-auth-negotiate.c 2016-04-07 16:25:49.465869000 +0200
+@@ -11,6 +11,8 @@
+ #endif
+
+ #include <string.h>
++#include <time.h>
++#include <stdint.h>
#ifdef LIBSOUP_HAVE_GSSAPI
#include <gssapi/gssapi.h>
--#include <gssapi/gssapi_krb5.h>
- #endif /* LIBSOUP_HAVE_GSSAPI */
-
- #include "soup-auth-negotiate.h"
diff --git a/devel/libsoup/files/patch-libsoup_soup-filter-input-stream.c b/devel/libsoup/files/patch-libsoup_soup-filter-input-stream.c
deleted file mode 100644
index 17d2f9043552..000000000000
--- a/devel/libsoup/files/patch-libsoup_soup-filter-input-stream.c
+++ /dev/null
@@ -1,49 +0,0 @@
-From 03c91c76daf70ee227f38304c5e45a155f45073d Mon Sep 17 00:00:00 2001
-From: Dan Winship <danw@gnome.org>
-Date: Thu, 3 Aug 2017 09:56:43 -0400
-Subject: Fix chunked decoding buffer overrun (CVE-2017-2885)
-
-https://bugzilla.gnome.org/show_bug.cgi?id=785774
---- libsoup/soup-filter-input-stream.c.orig 2016-02-05 15:05:33 UTC
-+++ libsoup/soup-filter-input-stream.c
-@@ -201,7 +201,7 @@ soup_filter_input_stream_read_until (SoupFilterInputSt
- GCancellable *cancellable,
- GError **error)
- {
-- gssize nread;
-+ gssize nread, read_length;
- guint8 *p, *buf, *end;
- gboolean eof = FALSE;
- GError *my_error = NULL;
-@@ -254,10 +254,11 @@ soup_filter_input_stream_read_until (SoupFilterInputSt
- } else
- buf = fstream->priv->buf->data;
-
-- /* Scan for the boundary */
-- end = buf + fstream->priv->buf->len;
-- if (!eof)
-- end -= boundary_length;
-+ /* Scan for the boundary within the range we can possibly return. */
-+ if (include_boundary)
-+ end = buf + MIN (fstream->priv->buf->len, length) - boundary_length;
-+ else
-+ end = buf + MIN (fstream->priv->buf->len - boundary_length, length);
- for (p = buf; p <= end; p++) {
- if (*p == *(guint8*)boundary &&
- !memcmp (p, boundary, boundary_length)) {
-@@ -271,10 +272,9 @@ soup_filter_input_stream_read_until (SoupFilterInputSt
- if (!*got_boundary && fstream->priv->buf->len < length && !eof)
- goto fill_buffer;
-
-- /* Return everything up to 'p' (which is either just after the boundary if
-- * include_boundary is TRUE, just before the boundary if include_boundary is
-- * FALSE, @boundary_len - 1 bytes before the end of the buffer, or end-of-
-- * file).
-- */
-- return read_from_buf (fstream, buffer, p - buf);
-+ if (eof && !*got_boundary)
-+ read_length = MIN (fstream->priv->buf->len, length);
-+ else
-+ read_length = p - buf;
-+ return read_from_buf (fstream, buffer, read_length);
- }
diff --git a/devel/libsoup/pkg-plist b/devel/libsoup/pkg-plist
index 46279573fcc6..03d2654a6ca5 100644
--- a/devel/libsoup/pkg-plist
+++ b/devel/libsoup/pkg-plist
@@ -98,7 +98,6 @@ share/gtk-doc/html/libsoup-%%VERSION%%/ch04.html
share/gtk-doc/html/libsoup-%%VERSION%%/ch05.html
share/gtk-doc/html/libsoup-%%VERSION%%/home.png
share/gtk-doc/html/libsoup-%%VERSION%%/index.html
-share/gtk-doc/html/libsoup-%%VERSION%%/index.sgml
share/gtk-doc/html/libsoup-%%VERSION%%/ix01.html
share/gtk-doc/html/libsoup-%%VERSION%%/left-insensitive.png
share/gtk-doc/html/libsoup-%%VERSION%%/left.png
@@ -142,10 +141,12 @@ share/locale/eu/LC_MESSAGES/libsoup.mo
share/locale/fa/LC_MESSAGES/libsoup.mo
share/locale/fr/LC_MESSAGES/libsoup.mo
share/locale/fur/LC_MESSAGES/libsoup.mo
+share/locale/gd/LC_MESSAGES/libsoup.mo
share/locale/gl/LC_MESSAGES/libsoup.mo
share/locale/gu/LC_MESSAGES/libsoup.mo
share/locale/he/LC_MESSAGES/libsoup.mo
share/locale/hi/LC_MESSAGES/libsoup.mo
+share/locale/hr/LC_MESSAGES/libsoup.mo
share/locale/hu/LC_MESSAGES/libsoup.mo
share/locale/id/LC_MESSAGES/libsoup.mo
share/locale/it/LC_MESSAGES/libsoup.mo
@@ -157,6 +158,7 @@ share/locale/lv/LC_MESSAGES/libsoup.mo
share/locale/ml/LC_MESSAGES/libsoup.mo
share/locale/mr/LC_MESSAGES/libsoup.mo
share/locale/nb/LC_MESSAGES/libsoup.mo
+share/locale/ne/LC_MESSAGES/libsoup.mo
share/locale/nl/LC_MESSAGES/libsoup.mo
share/locale/oc/LC_MESSAGES/libsoup.mo
share/locale/or/LC_MESSAGES/libsoup.mo