aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libsoup
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-06-01 08:41:05 +0800
committermarcus <marcus@FreeBSD.org>2003-06-01 08:41:05 +0800
commit2e7cfcaca7e1c2aebb50413f01260be8d7c3e971 (patch)
tree9bb06ece518035ad54a9e364246f78fbe874c3b7 /devel/libsoup
parentefda831420e380bdd2e7d10a78a18e2b5c4092b0 (diff)
downloadfreebsd-ports-gnome-2e7cfcaca7e1c2aebb50413f01260be8d7c3e971.tar.gz
freebsd-ports-gnome-2e7cfcaca7e1c2aebb50413f01260be8d7c3e971.tar.zst
freebsd-ports-gnome-2e7cfcaca7e1c2aebb50413f01260be8d7c3e971.zip
Update to 1.99.22.
Diffstat (limited to 'devel/libsoup')
-rw-r--r--devel/libsoup/Makefile4
-rw-r--r--devel/libsoup/distinfo2
-rw-r--r--devel/libsoup/files/patch-libsoup_soup_message.c20
3 files changed, 3 insertions, 23 deletions
diff --git a/devel/libsoup/Makefile b/devel/libsoup/Makefile
index 9e1b68a67057..b98548b1f9d0 100644
--- a/devel/libsoup/Makefile
+++ b/devel/libsoup/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libsoup
-PORTVERSION= 1.99.20
+PORTVERSION= 1.99.22
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.99
@@ -24,7 +24,7 @@ USE_LIBTOOL= yes
USE_OPENSSL= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/devel/libsoup/distinfo b/devel/libsoup/distinfo
index e66af0c12c1c..bc59aa32bf4f 100644
--- a/devel/libsoup/distinfo
+++ b/devel/libsoup/distinfo
@@ -1 +1 @@
-MD5 (gnome2/libsoup-1.99.20.tar.bz2) = 78b2e1c656d361aa1c8252934ee7ddc1
+MD5 (gnome2/libsoup-1.99.22.tar.bz2) = 6ab7b945fbd8ec79274864433eed4e90
diff --git a/devel/libsoup/files/patch-libsoup_soup_message.c b/devel/libsoup/files/patch-libsoup_soup_message.c
deleted file mode 100644
index 3d1245dfd746..000000000000
--- a/devel/libsoup/files/patch-libsoup_soup_message.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- libsoup/soup-message.c.orig Thu May 8 19:27:40 2003
-+++ libsoup/soup-message.c Thu May 8 19:28:56 2003
-@@ -877,7 +877,7 @@
-
- SoupHandlerKind kind;
- union {
-- guint errorcode;
-+ unsigned long errorcode;
- SoupErrorClass errorclass;
- const gchar *header;
- } data;
-@@ -892,7 +892,7 @@
- redirect_handler,
- NULL,
- RESPONSE_HEADER_HANDLER,
-- { (guint) "Location" }
-+ { (unsigned long) "Location" }
- },
- /*
- * Handle authorization.