aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libstroke
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2006-01-31 23:41:54 +0800
committerdanfe <danfe@FreeBSD.org>2006-01-31 23:41:54 +0800
commit220047a94a54588de7fe413684589cbc5d5cb780 (patch)
tree313a0184bda97629b5b83789cf1b8e82c1af2d5a /devel/libstroke
parenta1ad9bbf24c968a532c635fcc97211eea485d66b (diff)
downloadfreebsd-ports-gnome-220047a94a54588de7fe413684589cbc5d5cb780.tar.gz
freebsd-ports-gnome-220047a94a54588de7fe413684589cbc5d5cb780.tar.zst
freebsd-ports-gnome-220047a94a54588de7fe413684589cbc5d5cb780.zip
Properly handle GTK+ dependency. This should fix packaging issues caused by
previous commit to pkg-plist. Reported by: krismail
Diffstat (limited to 'devel/libstroke')
-rw-r--r--devel/libstroke/Makefile16
-rw-r--r--devel/libstroke/pkg-plist8
2 files changed, 18 insertions, 6 deletions
diff --git a/devel/libstroke/Makefile b/devel/libstroke/Makefile
index 6c4050962a62..69867e16fd1d 100644
--- a/devel/libstroke/Makefile
+++ b/devel/libstroke/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: libstroke
+# New ports collection makefile for: LibStroke
# Date created: 31 December 2001
# Whom: Jerry A! <jerry@thehutt.org>
#
@@ -17,10 +17,22 @@ COMMENT= A stroke translation library
USE_XLIB= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
+WANT_GNOME= yes
INSTALLS_SHLIB= yes
+OPTIONS= GTK "Build with Gtk+/GNOME stroke support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GTK) || ${HAVE_GNOME:Mgtk12}
+USE_GNOME+= gtk12
+PLIST_SUB+= GS=""
+.else
+PLIST_SUB+= GS="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/libstroke/pkg-plist b/devel/libstroke/pkg-plist
index 01b3eb0b19b8..5f52c3e6a41e 100644
--- a/devel/libstroke/pkg-plist
+++ b/devel/libstroke/pkg-plist
@@ -1,8 +1,8 @@
-include/gstroke.h
+%%GS%%include/gstroke.h
include/stroke.h
-lib/libgstroke.a
-lib/libgstroke.so
-lib/libgstroke.so.0
+%%GS%%lib/libgstroke.a
+%%GS%%lib/libgstroke.so
+%%GS%%lib/libgstroke.so.0
lib/libstroke.a
lib/libstroke.so
lib/libstroke.so.0