aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libtai/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-01-29 18:16:28 +0800
committerknu <knu@FreeBSD.org>2002-01-29 18:16:28 +0800
commit683084ba5b0a2fbaac959371c452814420e77ba6 (patch)
tree708e7807b36deea4f04ea6f9464e4e09d8b04ab2 /devel/libtai/Makefile
parent6fd54384344c267d40b400ec310d64528228d10c (diff)
downloadfreebsd-ports-gnome-683084ba5b0a2fbaac959371c452814420e77ba6.tar.gz
freebsd-ports-gnome-683084ba5b0a2fbaac959371c452814420e77ba6.tar.zst
freebsd-ports-gnome-683084ba5b0a2fbaac959371c452814420e77ba6.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command. Use command macros where appropriate.
Diffstat (limited to 'devel/libtai/Makefile')
-rw-r--r--devel/libtai/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/libtai/Makefile b/devel/libtai/Makefile
index 47335f4990b5..bd2489b3468d 100644
--- a/devel/libtai/Makefile
+++ b/devel/libtai/Makefile
@@ -32,9 +32,9 @@ PROGRAM_FILES= easter nowutc leapsecs yearcal
do-configure:
@${PERL} -pi -e "s!%%PREFIX%%!${PREFIX}!g" \
${WRKSRC}/leapsecs.3 ${WRKSRC}/leapsecs_read.c
- @${ECHO} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
- @${ECHO} "${CC} -s" > ${WRKSRC}/conf-ld
- @${ECHO} -fPIC -DPIC > ${WRKSRC}/conf-ccso
+ @${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
+ @${ECHO_CMD} "${CC} -s" > ${WRKSRC}/conf-ld
+ @${ECHO_CMD} -fPIC -DPIC > ${WRKSRC}/conf-ccso
do-install:
${INSTALL} ${COPY} -o ${SHAREOWN} -g ${BINGRP} -m 644 \