aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libtar
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-07-15 07:21:22 +0800
committerahze <ahze@FreeBSD.org>2005-07-15 07:21:22 +0800
commitb044a097577da4ce8cb31f177f3f382a62d40da4 (patch)
tree5b9034ac2707c9af3fffd63f756ff3ee79a2a288 /devel/libtar
parentbbbb1ccffec1c57525df6571e9f8e40548593b06 (diff)
downloadfreebsd-ports-gnome-b044a097577da4ce8cb31f177f3f382a62d40da4.tar.gz
freebsd-ports-gnome-b044a097577da4ce8cb31f177f3f382a62d40da4.tar.zst
freebsd-ports-gnome-b044a097577da4ce8cb31f177f3f382a62d40da4.zip
Add -fPIC to CPPFLAGS on !i386 to fix build
Reported by: kris mail
Diffstat (limited to 'devel/libtar')
-rw-r--r--devel/libtar/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/devel/libtar/Makefile b/devel/libtar/Makefile
index 7de203875e10..77fe76ab04ae 100644
--- a/devel/libtar/Makefile
+++ b/devel/libtar/Makefile
@@ -18,6 +18,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}"
post-install:
${INSTALL_DATA} ${WRKSRC}/lib/libtar.so.0 ${PREFIX}/lib
@@ -25,4 +26,9 @@ post-install:
.include <bsd.port.pre.mk>
.include "files/manpages"
+
+.if ${ARCH}!="i386"
+CPPFLAGS+= -fPIC
+.endif
+
.include <bsd.port.post.mk>