aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libtool15/Makefile
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2003-07-03 02:26:53 +0800
committerade <ade@FreeBSD.org>2003-07-03 02:26:53 +0800
commit9a470bf799a5bd1ed1fb6a740335061a7e618785 (patch)
treea4c9b10e887df9df47c8429047cd6392df17c194 /devel/libtool15/Makefile
parent6f2d5fade839c38b06e7fe1d01d8b3de745d75fc (diff)
downloadfreebsd-ports-gnome-9a470bf799a5bd1ed1fb6a740335061a7e618785.tar.gz
freebsd-ports-gnome-9a470bf799a5bd1ed1fb6a740335061a7e618785.tar.zst
freebsd-ports-gnome-9a470bf799a5bd1ed1fb6a740335061a7e618785.zip
Upgrade to libtool 1.5 after repo-copy.
Diffstat (limited to 'devel/libtool15/Makefile')
-rw-r--r--devel/libtool15/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/devel/libtool15/Makefile b/devel/libtool15/Makefile
index d695e994da67..b6bb08299ae2 100644
--- a/devel/libtool15/Makefile
+++ b/devel/libtool15/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME?= libtool
-PORTVERSION= 1.4.3
-PORTREVISION?= 1
+PORTVERSION= 1.5
+PORTREVISION?= 0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= libtool
@@ -16,14 +16,14 @@ DISTNAME= libtool-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
COMMENT?= Generic shared library support script
-BUILD_VERSION= 14
+BUILD_VERSION= 15
LATEST_LINK?= libtool${BUILD_VERSION}
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
GNU_CONFIGURE= yes
CONFIGURE_ARGS?= --disable-ltdl-install
CONFIGURE_ARGS+= --program-suffix=${BUILD_VERSION}
-INSTALLS_SHLIB= yes
CONFIGURE_ENV= PREFIX=${PREFIX} PACKAGE=libtool${BUILD_VERSION}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_REINPLACE= yes
.if defined(USE_LIBTOOL) || defined(USE_LIBTOOL_VER)
@@ -36,13 +36,15 @@ pre-everything:
@${FALSE}
.endif # defined(USE_LIBTOOL) || defined(USE_LIBTOOL_VER)
-post-extract:
+post-patch:
+ @(cd ${WRKSRC}/doc && \
+ ${RM} -f *.info* && \
+ ${MV} libtool.texi libtool${BUILD_VERSION}.texi && \
+ ${REINPLACE_CMD} -E 's,(libtool|libtoolize)\),\1${BUILDVERSION}\),g' libtool${BUILD_VERSION}.texi)
@${MV} -f ${WRKSRC}/libtool.m4 ${WRKSRC}/libtool${BUILD_VERSION}.m4
@${MV} -f ${WRKSRC}/ltdl.m4 ${WRKSRC}/ltdl${BUILD_VERSION}.m4
@${REINPLACE_CMD} -e 's|libtool.m4|libtool${BUILD_VERSION}.m4|g' \
-e 's|ltdl.m4|ltdl${BUILD_VERSION}.m4|g' ${WRKSRC}/Makefile.in
- @${MV} -f ${WRKSRC}/doc/libtool.info ${WRKSRC}/doc/libtool${BUILD_VERSION}.info
- @${MV} -f ${WRKSRC}/doc/libtool.texi ${WRKSRC}/doc/libtool${BUILD_VERSION}.texi
.if ${PORTNAME} == "libtool"
post-install: