aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libtool15
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2005-12-25 04:15:41 +0800
committerade <ade@FreeBSD.org>2005-12-25 04:15:41 +0800
commit12697ad507417fd5f72c18b5b3d72229a3bb3ba0 (patch)
treea7aa75a95bf20636754c74af1bfdb75dff945404 /devel/libtool15
parent6607b9b320aebeb25f6ea11f6cb29e3f2ae1acaf (diff)
downloadfreebsd-ports-gnome-12697ad507417fd5f72c18b5b3d72229a3bb3ba0.tar.gz
freebsd-ports-gnome-12697ad507417fd5f72c18b5b3d72229a3bb3ba0.tar.zst
freebsd-ports-gnome-12697ad507417fd5f72c18b5b3d72229a3bb3ba0.zip
Fix pthread handling
Submitted by: marcus
Diffstat (limited to 'devel/libtool15')
-rw-r--r--devel/libtool15/Makefile2
-rw-r--r--devel/libtool15/files/patch-ltmain.sh32
2 files changed, 26 insertions, 8 deletions
diff --git a/devel/libtool15/Makefile b/devel/libtool15/Makefile
index ab43b4cc3b64..f4797adffba4 100644
--- a/devel/libtool15/Makefile
+++ b/devel/libtool15/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= libtool
PORTVERSION= 1.5.22
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= libtool
diff --git a/devel/libtool15/files/patch-ltmain.sh b/devel/libtool15/files/patch-ltmain.sh
index 0f2c20b63d7f..c3730b423d3a 100644
--- a/devel/libtool15/files/patch-ltmain.sh
+++ b/devel/libtool15/files/patch-ltmain.sh
@@ -1,10 +1,14 @@
---- ltmain.sh.orig Mon May 16 02:39:29 2005
-+++ ltmain.sh Thu Jun 16 19:42:32 2005
-@@ -1525,2 +1525,3 @@
+--- ltmain.sh.orig Sun Dec 18 17:14:54 2005
++++ ltmain.sh Sat Dec 24 12:22:07 2005
+@@ -1604,11 +1604,18 @@
+ compiler_flags="$compiler_flags $arg"
+ compile_command="$compile_command $arg"
finalize_command="$finalize_command $arg"
+ deplibs="$deplibs $arg"
continue
-@@ -1530,2 +1531,8 @@
+ ;;
+
+ -module)
module=yes
+ case $host in
+ *-*-freebsd*)
@@ -13,7 +17,11 @@
+ ;;
+ esac
continue
-@@ -2015,2 +2022,25 @@
+ ;;
+
+@@ -2101,6 +2108,29 @@
+ else
+ compiler_flags="$compiler_flags $deplib"
fi
+
+ case $linkmode in
@@ -39,13 +47,21 @@
+ esac # linkmode
+
continue
-@@ -4498,2 +4528,5 @@
+ ;;
+ -l*)
+@@ -4705,6 +4735,9 @@
+ ;;
+ esac
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
-@@ -5627,6 +5660,13 @@
+ $echo "$modename: unknown suffix for \`$dlsyms'" 1>&2
+ exit $EXIT_FAILURE
+@@ -5995,10 +6028,17 @@
+ fi
+
# Install the pseudo-library for information purposes.
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
@@ -63,3 +79,5 @@
+ ;;
+ esac
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"