aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libunwind
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2010-05-06 07:20:21 +0800
committerstas <stas@FreeBSD.org>2010-05-06 07:20:21 +0800
commit3f49f6257fcf18b8935505bd09b197cb612c005c (patch)
treef7c9486a9d0915887b1e27a245a50e1c24617709 /devel/libunwind
parent9ab14c5fe09cdb56f9a7d7f96eafc0348515fa7b (diff)
downloadfreebsd-ports-gnome-3f49f6257fcf18b8935505bd09b197cb612c005c.tar.gz
freebsd-ports-gnome-3f49f6257fcf18b8935505bd09b197cb612c005c.tar.zst
freebsd-ports-gnome-3f49f6257fcf18b8935505bd09b197cb612c005c.zip
- Add libunwind, a generic stack unwindig library.
WWW: http://www.nongnu.org/libunwind/
Diffstat (limited to 'devel/libunwind')
-rw-r--r--devel/libunwind/Makefile75
-rw-r--r--devel/libunwind/distinfo3
-rw-r--r--devel/libunwind/files/patch-configure.in11
-rw-r--r--devel/libunwind/pkg-descr24
-rw-r--r--devel/libunwind/pkg-plist15
5 files changed, 128 insertions, 0 deletions
diff --git a/devel/libunwind/Makefile b/devel/libunwind/Makefile
new file mode 100644
index 000000000000..a02f17719c24
--- /dev/null
+++ b/devel/libunwind/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: libunwind
+# Date created: 04/30/2010
+# Whom: stas
+#
+# $FreeBSD$
+#
+
+PORTNAME= libunwind
+PORTVERSION= 20100430
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= A generic stack unwinding library
+
+ONLY_FOR_ARCHS= i386 amd64
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= aclocal:110 autoheader:262 automake:110 autoconf:262 \
+ libtoolize libtool:22
+ACLOCAL_ARGS= -I . -I ${LOCALBASE}/share/aclocal
+AUTOMAKE_ARGS= -c -a
+LIBTOOLFILES= #empty
+
+MAN3= _U_dyn_cancel.3 \
+ _U_dyn_register.3 \
+ libunwind-dynamic.3 \
+ libunwind-ia64.3 \
+ libunwind-ptrace.3 \
+ libunwind-setjmp.3 \
+ libunwind.3 \
+ unw_create_addr_space.3 \
+ unw_destroy_addr_space.3 \
+ unw_flush_cache.3 \
+ unw_get_accessors.3 \
+ unw_get_fpreg.3 \
+ unw_get_proc_info.3 \
+ unw_get_proc_info_by_ip.3 \
+ unw_get_proc_name.3 \
+ unw_get_reg.3 \
+ unw_getcontext.3 \
+ unw_init_local.3 \
+ unw_init_remote.3 \
+ unw_is_fpreg.3 \
+ unw_is_signal_frame.3 \
+ unw_regname.3 \
+ unw_resume.3 \
+ unw_set_caching_policy.3 \
+ unw_set_fpreg.3 \
+ unw_set_reg.3 \
+ unw_step.3 \
+ unw_strerror.3
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 701100 || (${OSVERSION} > 800000 && ${OSVERSION} < 800053)
+IGNORE= your FreeBSD version is not supported
+.endif
+
+#
+# The original ltmain.sh is buggy and hangs sometimes
+#
+pre-configure:
+ @${CP} ${LTMAIN} ${WRKSRC}/aux/
+
+#
+# Get rid of .la and static library files
+#
+post-configure:
+ @${REINPLACE_CMD} -E -e \
+ '/Install the pseudo-library/,/staticlibs=/s,^,#,' ${WRKSRC}/libtool
+
+.include <bsd.port.post.mk>
diff --git a/devel/libunwind/distinfo b/devel/libunwind/distinfo
new file mode 100644
index 000000000000..85285cf10d98
--- /dev/null
+++ b/devel/libunwind/distinfo
@@ -0,0 +1,3 @@
+MD5 (libunwind-20100430.tar.bz2) = 1b2b3230e66c17788b49073402af9191
+SHA256 (libunwind-20100430.tar.bz2) = 026ba4552336f2147c187df96c141098c5b75c2974d5b53f278e41986090ecb8
+SIZE (libunwind-20100430.tar.bz2) = 275521
diff --git a/devel/libunwind/files/patch-configure.in b/devel/libunwind/files/patch-configure.in
new file mode 100644
index 000000000000..93399c47e5f1
--- /dev/null
+++ b/devel/libunwind/files/patch-configure.in
@@ -0,0 +1,11 @@
+--- configure.in.orig 2010-05-01 01:45:55.000000000 -0700
++++ configure.in 2010-05-01 01:46:05.000000000 -0700
+@@ -6,7 +6,7 @@
+ dnl Process this file with autoconf to produce a configure script.
+ AC_INIT(libunwind, mkvers(pkg_major, pkg_minor, pkg_extra), pkg_maintainer)
+ AC_CONFIG_SRCDIR(src/mi/backtrace.c)
+-AC_CONFIG_AUX_DIR(config)
++AC_CONFIG_AUX_DIR(aux)
+ AC_CANONICAL_SYSTEM
+ AM_INIT_AUTOMAKE([1.6 subdir-objects])
+ AM_MAINTAINER_MODE
diff --git a/devel/libunwind/pkg-descr b/devel/libunwind/pkg-descr
new file mode 100644
index 000000000000..f1a0565e8fe3
--- /dev/null
+++ b/devel/libunwind/pkg-descr
@@ -0,0 +1,24 @@
+The primary goal of this project is to define a portable and efficient
+C programming interface (API) to determine the call-chain of a program.
+The API additionally provides the means to manipulate the preserved
+(callee-saved) state of each call-frame and to resume execution at any
+point in the call-chain (non-local goto). The API supports both local
+(same-process) and remote (across-process) operation. As such, the API
+is useful in a number of applications. Some examples include:
+
+o exception handling
+ The libunwind API makes it trivial to implement the stack-manipulation
+ aspects of exception handling.
+o debuggers
+ The libunwind API makes it trivial for debuggers to generate
+ the call-chain (backtrace) of the threads in a running program.
+o introspection
+ It is often useful for a running thread to determine its call-chain.
+ For example, this is useful to display error messages (to show how
+ the error came about) and for performance monitoring/analysis.
+o efficient setjmp()
+ With libunwind, it is possible to implement an extremely efficient
+ version of setjmp(). Effectively, the only context that needs to be
+ saved consists of the stack-pointer(s).
+
+WWW: http://www.nongnu.org/libunwind/
diff --git a/devel/libunwind/pkg-plist b/devel/libunwind/pkg-plist
new file mode 100644
index 000000000000..8397d5104fb2
--- /dev/null
+++ b/devel/libunwind/pkg-plist
@@ -0,0 +1,15 @@
+include/libunwind-common.h
+include/libunwind-dynamic.h
+include/libunwind-ptrace.h
+include/libunwind-x86_64.h
+include/libunwind.h
+include/unwind.h
+lib/libunwind-generic.a
+lib/libunwind-generic.so
+lib/libunwind-ptrace.a
+lib/libunwind-setjmp.so
+lib/libunwind-setjmp.so.0
+lib/libunwind-x86_64.so
+lib/libunwind-x86_64.so.7
+lib/libunwind.so
+lib/libunwind.so.7