aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libx86
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2008-12-06 08:40:05 +0800
committerjkim <jkim@FreeBSD.org>2008-12-06 08:40:05 +0800
commit6211288173ca43e7f359be52e7c5decb38ab63aa (patch)
tree59b7d48a08eb912b37a40830721d40b19cb94d47 /devel/libx86
parentd3847232c61a56c570a5fdd2e9c35b0f42d11c79 (diff)
downloadfreebsd-ports-gnome-6211288173ca43e7f359be52e7c5decb38ab63aa.tar.gz
freebsd-ports-gnome-6211288173ca43e7f359be52e7c5decb38ab63aa.tar.zst
freebsd-ports-gnome-6211288173ca43e7f359be52e7c5decb38ab63aa.zip
It's often useful to be able to make real-mode x86 BIOS calls from userland.
Linux lrmi provides a simple interface to this for i386 machines, but this doesn't help on other platforms. libx86 provides the Linux lrmi interface, but will also run on platforms such as amd64 and alpha. WWW: http://www.codon.org.uk/~mjg59/libx86/
Diffstat (limited to 'devel/libx86')
-rw-r--r--devel/libx86/Makefile32
-rw-r--r--devel/libx86/distinfo3
-rw-r--r--devel/libx86/files/patch-thunk.c12
-rw-r--r--devel/libx86/pkg-descr6
4 files changed, 53 insertions, 0 deletions
diff --git a/devel/libx86/Makefile b/devel/libx86/Makefile
new file mode 100644
index 000000000000..c776174e99e4
--- /dev/null
+++ b/devel/libx86/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: libx86
+# Date created: 2008-12-05
+# Whom: Jung-uk Kim <jkim@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libx86
+PORTVERSION= 1.1
+CATEGORIES= devel
+MASTER_SITES= http://www.codon.org.uk/~mjg59/libx86/downloads/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= jkim@FreeBSD.org
+COMMENT= A hardware-independent library for executing real-mode x86 code
+
+PLIST_FILES= include/libx86.h lib/libx86.a lib/libx86.so.1 lib/libx86.so
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_SUBMAKE= yes
+ALL_TARGET= default
+MAKE_ARGS+= LIBDIR=${PREFIX}/lib
+MAKE_ENV+= BACKEND=x86emu
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/lrmi.h ${PREFIX}/include/libx86.h
+ ${INSTALL_DATA} ${WRKSRC}/libx86.a ${PREFIX}/lib
+ ${INSTALL_PROGRAM} ${WRKSRC}/libx86.so.1 ${PREFIX}/lib
+ ${LN} -sf ${PREFIX}/lib/libx86.so.1 ${PREFIX}/lib/libx86.so
+
+.include <bsd.port.mk>
diff --git a/devel/libx86/distinfo b/devel/libx86/distinfo
new file mode 100644
index 000000000000..b86ef86100c5
--- /dev/null
+++ b/devel/libx86/distinfo
@@ -0,0 +1,3 @@
+MD5 (libx86-1.1.tar.gz) = 41bee1f8e22b82d82b5f7d7ba51abc2a
+SHA256 (libx86-1.1.tar.gz) = 5bf13104cb327472b5cb65643352a9138646becacc06763088d83001d832d048
+SIZE (libx86-1.1.tar.gz) = 87428
diff --git a/devel/libx86/files/patch-thunk.c b/devel/libx86/files/patch-thunk.c
new file mode 100644
index 000000000000..f55155b80473
--- /dev/null
+++ b/devel/libx86/files/patch-thunk.c
@@ -0,0 +1,12 @@
+--- thunk.c 2008-04-02 20:48:00.000000000 -0400
++++ thunk.c 2008-12-03 19:19:25.000000000 -0500
+@@ -11,7 +11,9 @@
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <sys/mman.h>
++#if 0
+ #include <sys/io.h>
++#endif
+ #include <string.h>
+ #include <sys/ipc.h>
+ #include <sys/shm.h>
diff --git a/devel/libx86/pkg-descr b/devel/libx86/pkg-descr
new file mode 100644
index 000000000000..3a2806f14131
--- /dev/null
+++ b/devel/libx86/pkg-descr
@@ -0,0 +1,6 @@
+It's often useful to be able to make real-mode x86 BIOS calls from userland.
+Linux lrmi provides a simple interface to this for i386 machines, but this
+doesn't help on other platforms. libx86 provides the Linux lrmi interface,
+but will also run on platforms such as amd64 and alpha.
+
+WWW: http://www.codon.org.uk/~mjg59/libx86/