aboutsummaryrefslogtreecommitdiffstats
path: root/devel/linguist/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-10-31 22:50:43 +0800
committersobomax <sobomax@FreeBSD.org>2000-10-31 22:50:43 +0800
commit24e1cc63b2547fbc9ea93b0084402dce903ad26b (patch)
treec0af77e19a36d5b916807f7542c2c67e022a132b /devel/linguist/Makefile
parente766bfcef8fa835feed78b53ff327987e9576557 (diff)
downloadfreebsd-ports-gnome-24e1cc63b2547fbc9ea93b0084402dce903ad26b.tar.gz
freebsd-ports-gnome-24e1cc63b2547fbc9ea93b0084402dce903ad26b.tar.zst
freebsd-ports-gnome-24e1cc63b2547fbc9ea93b0084402dce903ad26b.zip
Add QT Linguist - a tool for generating translations of various strings
used in internationalized Qt programs. This is pre-release version.
Diffstat (limited to 'devel/linguist/Makefile')
-rw-r--r--devel/linguist/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/devel/linguist/Makefile b/devel/linguist/Makefile
new file mode 100644
index 000000000000..31ca24140449
--- /dev/null
+++ b/devel/linguist/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: linguist
+# Date created: 31 October 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= linguist
+PORTVERSION= 0.0
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.trolltech.com/qt/pre-releases/
+DISTNAME= ${PORTNAME}-pre
+
+MAINTAINER= sobomax@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_QT2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ENV= TMAKEPATH="${LOCALBASE}/share/tmake/freebsd-g++" \
+ QTDIR="${X11BASE}"
+MAKE_ENV= TMAKEPATH="${LOCALBASE}/share/tmake/freebsd-g++" \
+ QTDIR="${X11BASE}" \
+ MOC="${X11BASE}/bin/moc2"
+MAKE_ARGS= -e
+
+post-configure:
+ @${PERL} -pi -e 's|\$\(SUBDIRS\):.*tmake_all|\$\(SUBDIRS\):|' \
+ ${WRKSRC}/Makefile
+ @find ${WRKSRC} -name "Makefile" -type f | xargs ${PERL} -pi -e \
+ 's|TARGET.*=.*\$\(QTDIR\)/bin/|TARGET=|'
+
+do-install:
+.for file in linguist lrelease lupdate qm2ts
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file}/${file} ${PREFIX}/bin
+.endfor
+ ${MKDIR} ${PREFIX}/share/doc/linguist
+ ${INSTALL_MAN} ${WRKSRC}/linguist/tutorial/doc/html/* ${PREFIX}/share/doc/linguist
+
+.include <bsd.port.mk>