aboutsummaryrefslogtreecommitdiffstats
path: root/devel/linguist
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-04-03 16:14:43 +0800
committerwill <will@FreeBSD.org>2001-04-03 16:14:43 +0800
commite282c995211fa7d389e4d3b437d0ff892d4d929b (patch)
treec8e1217a1b00314713ec60f3c0d07c11dc242116 /devel/linguist
parenta4c43b9975be01621916750b073e7125e629feba (diff)
downloadfreebsd-ports-gnome-e282c995211fa7d389e4d3b437d0ff892d4d929b.tar.gz
freebsd-ports-gnome-e282c995211fa7d389e4d3b437d0ff892d4d929b.tar.zst
freebsd-ports-gnome-e282c995211fa7d389e4d3b437d0ff892d4d929b.zip
Overhaul QT/KDE support:
- bsd.port.mk update to use bsd.kde.mk for USE_{QT,KDE}* - Cleanup corresponding ports for bsd.kde.mk update. - Fix bsd.kde.mk: use correct kdelibs dependency, put qt at the bottom, introduce QT_NONSTANDARD variable for nonstandard configure setup. - Update KDE2 to 2.1.1. Two patches included in x11/kdelibs2 to fix the proxy authentication that was broken for 2.1.1. Remove old patches. - Potentially fix kdelibs build for alpha. - Fix qt-designer 2.3.0 build. - Ruby stuff left alone since it looks like black magic to me. Should still work w/ compat shims for older USE_QT[,2] style. Some others were also left alone for the same reason. Reviewed by: portmgr, ports (bsd.kde.mk+bsd.port.mk) Submitted by: David Faure <faure@kde.org> (proxy auth patches) Alex Zepeda <garbanzo@kde.org> (old patches removal)
Diffstat (limited to 'devel/linguist')
-rw-r--r--devel/linguist/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/devel/linguist/Makefile b/devel/linguist/Makefile
index 6115102291c8..028dc1f64ac9 100644
--- a/devel/linguist/Makefile
+++ b/devel/linguist/Makefile
@@ -17,15 +17,14 @@ BUILD_DEPENDS= tmake:${PORTSDIR}/devel/tmake
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_QT2= yes
+USE_QT_VER= 2
USE_X_PREFIX= yes
USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ENV= TMAKEPATH="${LOCALBASE}/share/tmake/freebsd-g++" \
QTDIR="${X11BASE}"
MAKE_ENV= TMAKEPATH="${LOCALBASE}/share/tmake/freebsd-g++" \
- QTDIR="${X11BASE}" \
- MOC="${X11BASE}/bin/moc2"
+ QTDIR="${X11BASE}"
MAKE_ARGS= -e
.include <bsd.port.pre.mk>