aboutsummaryrefslogtreecommitdiffstats
path: root/devel/linux-f8-allegro/Makefile
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2009-04-01 23:25:39 +0800
committerbsam <bsam@FreeBSD.org>2009-04-01 23:25:39 +0800
commit390e9ab8d0b8356749f73adea8e07815b03f03c2 (patch)
tree54ceec35ba484ca3945a6bdef50f107e8f18a974 /devel/linux-f8-allegro/Makefile
parent273376aa17299d37f9f66a1050b393a9701b5c88 (diff)
downloadfreebsd-ports-gnome-390e9ab8d0b8356749f73adea8e07815b03f03c2.tar.gz
freebsd-ports-gnome-390e9ab8d0b8356749f73adea8e07815b03f03c2.tar.zst
freebsd-ports-gnome-390e9ab8d0b8356749f73adea8e07815b03f03c2.zip
Here are new Linux Fedora 8 infrastructure ports.
The recommended version of FreeBSD to use them is 8-CURRENT. FreeBSD-7.x is not fully compatible with compat.linux.osrelease 2.6.16. Some syscalls cannot be MFCed due to native FreeBSD ABI breakage. Usage (and package building): 1. define compat.linux.osrelease=2.6.16; 2. add following variables to /etc/make.conf: . OVERRIDE_LINUX_BASE_PORT=f8; . OVERRIDE_LINUX_NONBASE_PORTS=f8. Approved by: bsam (me) ;-)
Diffstat (limited to 'devel/linux-f8-allegro/Makefile')
-rw-r--r--devel/linux-f8-allegro/Makefile25
1 files changed, 10 insertions, 15 deletions
diff --git a/devel/linux-f8-allegro/Makefile b/devel/linux-f8-allegro/Makefile
index b855c36a7ad4..64d9036ab867 100644
--- a/devel/linux-f8-allegro/Makefile
+++ b/devel/linux-f8-allegro/Makefile
@@ -1,31 +1,26 @@
-# New ports collection makefile for: linux-allegro
-# Date created: 18 Nov 2003
-# Whom: Pav Lucistnik <pav@FreeBSD.org>
+# New ports collection makefile for: devel/linux-f8-allegro
+# Date created: 2008-04-03
+# Whom: bsam
#
# $FreeBSD$
#
PORTNAME= allegro
-PORTVERSION= 4.0.3
-PORTREVISION= 2
+PORTVERSION= 4.2.2
CATEGORIES= devel linux
-MASTER_SITES= http://membres.lycos.fr/ebotcazou/allegro/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-1
+PKGNAMEPREFIX= linux-f8-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
MAINTAINER= freebsd-emulation@FreeBSD.org
-COMMENT= Cross-platform game programming library (linux version)
+COMMENT= Cross-platform game programming library (Linux Fedora 8)
USE_LINUX_RPM= yes
USE_LINUX_APPS= xorglibs
ONLY_FOR_ARCHS= i386 amd64
-DIST_SUBDIR= rpm
+LINUX_DIST_VER= 8
+RPMVERSION= 10.fc8
USE_LDCONFIG= yes
-SRC_DISTFILES=
-MD5_FILE= ${MASTERDIR}/distinfo
-
-post-extract:
- @cd ${WRKSRC}/usr/lib; \
- ${LN} -s liballeg-4.0.3.so liballeg.so.4.0
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
.include <bsd.port.mk>