aboutsummaryrefslogtreecommitdiffstats
path: root/devel/linux-glib2
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-11-19 22:32:11 +0800
committertrevor <trevor@FreeBSD.org>2003-11-19 22:32:11 +0800
commitf13dadada149f0e2a7a936acc295105cf7c11a33 (patch)
treeb79210496edb19f5ea9a3cc35deb64af127487f6 /devel/linux-glib2
parent1c38996e5c1504e1db42b4ab134af9f2e190a5c1 (diff)
downloadfreebsd-ports-gnome-f13dadada149f0e2a7a936acc295105cf7c11a33.tar.gz
freebsd-ports-gnome-f13dadada149f0e2a7a936acc295105cf7c11a33.tar.zst
freebsd-ports-gnome-f13dadada149f0e2a7a936acc295105cf7c11a33.zip
new Linux/i386 binary port of GLib version 2.X
Diffstat (limited to 'devel/linux-glib2')
-rw-r--r--devel/linux-glib2/Makefile31
-rw-r--r--devel/linux-glib2/distinfo.i3862
-rw-r--r--devel/linux-glib2/pkg-descr11
3 files changed, 44 insertions, 0 deletions
diff --git a/devel/linux-glib2/Makefile b/devel/linux-glib2/Makefile
new file mode 100644
index 000000000000..fb0199155350
--- /dev/null
+++ b/devel/linux-glib2/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: linux-glib2
+# Date created: 2003-07-05
+# Whom: trevor
+#
+# $FreeBSD$
+#
+
+PORTNAME= glib2
+PORTVERSION= 2.2.1
+CATEGORIES= devel linux
+
+MAINTAINER= trevor@FreeBSD.org
+COMMENT= Version 2.X Linux/i386 binary port of GLib
+
+BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm2cpio
+
+BASEVERSION= 9
+ONLY_FOR_ARCHS= i386
+PLIST= ${WRKDIR}/plist
+RESTRICTED= "binary under GNU LGPL without accompanying source"
+RPM_SET= glib2-2.2.1-1.i386.rpm
+
+pre-install:
+ ${RM} -rf ${WRKSRC}/tmp
+ ${MKDIR} ${WRKSRC}/tmp
+ cd ${WRKSRC}/tmp; \
+ rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${RPM_SET} | cpio -id; \
+ ${FIND} * -type f -o -type l > ${PLIST}; \
+ ${FIND} -d * -type d | ${SED} -e 's:^:@dirrm :' >> ${PLIST}
+
+.include "../../x11-toolkits/linux-gtk/Makefile"
diff --git a/devel/linux-glib2/distinfo.i386 b/devel/linux-glib2/distinfo.i386
new file mode 100644
index 000000000000..b7fe9058b92c
--- /dev/null
+++ b/devel/linux-glib2/distinfo.i386
@@ -0,0 +1,2 @@
+$FreeBSD$
+MD5 (rpm/glib2-2.2.1-1.i386.rpm) = 5b123279a54b3eba75c494e91d61f998
diff --git a/devel/linux-glib2/pkg-descr b/devel/linux-glib2/pkg-descr
new file mode 100644
index 000000000000..cd9f5c4bf507
--- /dev/null
+++ b/devel/linux-glib2/pkg-descr
@@ -0,0 +1,11 @@
+This is a Linux/i386 binary port of GLib, version 2.X.
+
+from the home page:
+
+ GLib is the low-level core library that forms the basis of
+ GTK+ and GNOME. It provides data structure handling for C,
+ portability wrappers, and interfaces for such runtime
+ functionality as an event loop, threads, dynamic loading,
+ and an object system.
+
+WWW: http://gtk.org