aboutsummaryrefslogtreecommitdiffstats
path: root/devel/linux-libglade/Makefile
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2006-05-02 01:28:17 +0800
committernetchild <netchild@FreeBSD.org>2006-05-02 01:28:17 +0800
commit3faa8845b28c901780a3a4b7488d6236a8282a12 (patch)
tree749f4f39c0633a1d8ddffe3ef1917d396b853f43 /devel/linux-libglade/Makefile
parent1cbb1cc4f74650df31523d50cb04de767fd857f7 (diff)
downloadfreebsd-ports-gnome-3faa8845b28c901780a3a4b7488d6236a8282a12.tar.gz
freebsd-ports-gnome-3faa8845b28c901780a3a4b7488d6236a8282a12.tar.zst
freebsd-ports-gnome-3faa8845b28c901780a3a4b7488d6236a8282a12.zip
- convert to use bsd.linux-rpm.mk (get rid of include of linux-gtk/Makefile) [1]
- use fixed plists [1] - category "linux" added to those ports without it [1] - update some ports to a recent FC3 one [1] - remove plists/... for Alpha (there's no support since linux_base-8 for Alpha anymore) - don't hardcode version numbers in some plists, use PLIST_SUB instead (any errors are mine, don't keep them, send them to me) Regarding linux-ungif I declare a maintainer timeout (one month, Boris tried to contact the maintainer) and also pull the "sweeping commit"-card (the port which it uses as some kind of master port can not be used for this anymore). Besides this, I don't think he will be upset when other people do the work instead of adding an entry to his TODO list. :-) This commit brings us just before the switch of the default linux base port to the fc3 one, modulo some bugs which may appear. So: Beta testers wanted! To test: sed -i.old -e 's:linux-XFree86-libs:linux-xorg-libs:' /usr/ports/Mk/bsd.port.mk echo OVERRIDE_LINUX_BASE_PORT=fc3 >> /etc/make.conf portupgrade -f -o emulators/linux_base-fc3 -f linux_base-8 portupgrade -o x11/linux-xorg-libs linux-XFree86-libs portupgrade linux-\* The first two steps are necessary to switch to fc3 as the new default linux base port, the last 3 steps to upgrade to fc3. And feel free to send a big "Thank you!" to Boris, he did a lot of the work! I just provided some hints and answered some questions (besides from committing all the necessary changes for FC3 and doing some minor changes+comments/improvements to/of his work), even when he tries to tell you something else. ;-) Submitted by: Boris Samorodov <bsam@ipt.ru> [1]
Diffstat (limited to 'devel/linux-libglade/Makefile')
-rw-r--r--devel/linux-libglade/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/devel/linux-libglade/Makefile b/devel/linux-libglade/Makefile
index 3b2d4549be63..b9d8402ebe5c 100644
--- a/devel/linux-libglade/Makefile
+++ b/devel/linux-libglade/Makefile
@@ -6,13 +6,17 @@
#
PORTNAME= libglade
-PORTVERSION= 0.14
-PORTREVISION= 3
+PORTVERSION= 0.17
CATEGORIES= devel linux
+DISTNAME= ${PORTNAME}-${PORTVERSION}-15
MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of libglade
-RPM_SET= libglade-${PORTVERSION}-3.${ARCH}.rpm
+USE_LINUX_RPM= yes
+LINUX_DIST_VER= 3
+INSTALLS_SHLIB= yes
+PLIST= pkg-plist.${LINUX_RPM_ARCH}
+PLIST_SUB= LIBVERSION="0.4.2" PORTVERSION="${PORTVERSION}"
-.include "../../x11-toolkits/linux-gtk/Makefile"
+.include <bsd.port.mk>