aboutsummaryrefslogtreecommitdiffstats
path: root/devel/linux_devtools
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-06-18 06:59:29 +0800
committernetchild <netchild@FreeBSD.org>2005-06-18 06:59:29 +0800
commit8d63fa8ce3e1cb7a464d405732fcf971c5848297 (patch)
treebef012ab5e448ce5c144b7bb40139ba1dfd902a6 /devel/linux_devtools
parent5f5845bb3ad1db90d601456aaaea7343c4dabfc6 (diff)
downloadfreebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.tar.gz
freebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.tar.zst
freebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.zip
Mega-patch to cleanup the ports infrastructure regarding our linux bits:
- USE_LINUX now implies NO_FILTER_SHLIBS=yes. It also doesn't use FreeBSD tools to strip binaries anymore, so it's not neccesary anymore to override STRIP and STRIP_CMD. - USE_LINUX_PREFIX implies NO_MTREE now. - In the USE_LINUX case, USE_XLIB now depends upon the linux X11 libraries instead upon the native FreeBSD libraries. - The variable LINUX_BASE_PORT contains a string which is suitable as an item in *_DEPENDS, so if a port BATCH_DEPENDS or FETCH_DEPENDS upon the default (or overriden) linux base, ${LINUX_BASE_PORT} should be used instead of a hardcoded reference. - Change all ports to comply to the "new world order". - The Ports Collection now allows to override the default linux_base port. Specify e.g. OVERRIDE_LINUX_BASE_PORT=rh-9 in /etc/make.conf to use ${PORTSDIR}/emulators/linux_base-rh-9 (the logic is to use ${PORTSDIR}/emulators/linux_base-${OVERRIDE_LINUX_BASE_PORT}). - If USE_LINUX or OVERRIDE_LINUX_BASE doesn't point to an existing linux_base port and if USE_LINUX isn't set to "yes" (case insensitive), the port will be marked as IGNORE. [1] - Readd USE_LINUX knobs into several ports and make several uses of a conditional dependency ("USE_LINUX?=") into an unconditional one ("USE_LINUX=") which where removed/changed by Trevor to allow the use of alternative linux_base ports. While this is a nice goal, the implementation resulted in missing dependencies. The OVERRIDE_LINUX_BASE_PORT knob in this commit is supposed to fix the problem while keeping the feature. Basicaly this includes a backout of Trevor's commit, to prevent confusion I mention it here explicitely. - Use the correct prefix (X11- instead of LOCAL- or LINUX-) for some ports. Chase dependencies for this. - Changes to make linux_devtools installable on amd64, remove some stray device nodes (they don't work on recent OS versions and aren't really needed). - Make linux_base-8 PREFIX clean and remove some stray device nodes. Additionally tell a little bit more about how to setup NIS/YP [2]. - Update the PGSQL dependency in the linux-opengroupware port to a recent version (the old one isn't available anymore), I don't know if this works (at least it isn't more broken than before). - Use PREFIX/usr/share/doc instead of PREFIX/usr/doc in the divx4linux ports, the former path exists already and gets populated by other packages too (PREFIX=LINUXPREFIX!). - Fix some obvious (non-linuxolator) bugs in some linux ports while being there. - Bump PORTREVISION where neccesary. Requested by: portmgr (linimon) [1] Submittted by: Gerrit Kuehn <gerrit_huehn@gruft.fido.de [2] Approved by: portmgr (kris, linimon), maintainers (or maintainer timeout) Tested on: ports cluster (kris) Reviewed by: silence on emulation@ Superseedes PR: 69997 Maintainer approval from: chris@chrisburkert.de cracauer@cons.org des girgen jamie@bishopston.net mezz mi nivit@users.sf.net pat simond@irrelevant.org riggs@rrr.de Udo.Schweigert@Siemens.com
Diffstat (limited to 'devel/linux_devtools')
-rw-r--r--devel/linux_devtools/Makefile30
1 files changed, 12 insertions, 18 deletions
diff --git a/devel/linux_devtools/Makefile b/devel/linux_devtools/Makefile
index 9b10874b4598..c9ba027775f2 100644
--- a/devel/linux_devtools/Makefile
+++ b/devel/linux_devtools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= linux_devtools
PORTVERSION= 8.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel emulators linux
MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
MASTER_SITE_SUBDIR= ${PORTVERSION}/${LANG}/os/${ARCH}/RedHat/RPMS
@@ -35,17 +35,12 @@ COMMENT= Packages needed for doing development in Linux mode
BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
-RESTRICTED= "binaries under GNU GPL without accompanying source"
-
-USE_LINUX?= yes
-NO_LATEST_LINK= yes
+USE_LINUX= 8
+USE_LINUX_PREFIX= yes
ONLY_FOR_ARCHS= i386 amd64
CONFLICTS= linux_devtools-*
DIST_SUBDIR= rpm/${ARCH}/${PORTVERSION}
-PREFIX= ${LINUXBASE}
NO_BUILD= yes
-NO_FILTER_SHLIBS= yes
-NO_MTREE= yes
PLIST= ${WRKDIR}/pkg-plist
# Let's avoid hardcoding 'en' as the language.
@@ -57,7 +52,7 @@ UPDATES= XFree86-devel-4.2.1-23.i386.rpm
DBPATH= /var/lib/rpm
RPM= LC_ALL=C rpm
-RPMFLAGS= --root ${LINUXBASE} --dbpath ${DBPATH} --nodeps \
+RPMFLAGS= --root ${PREFIX} --dbpath ${DBPATH} --nodeps \
--replacepkgs --ignoreos
RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
@@ -82,17 +77,16 @@ pre-install:
cd ${WRKSRC}/tmp; ${FIND} * -type f -o -type l > ${PLIST}; \
${FIND} -d * -type d | \
${GREP} -vwE "(bin$$|X11R6/include$$|lib$$|man$$|src$$)" | \
- ${SED} -e 's:^:@dirrm :'>> ${PLIST}
+ ${SED} -e 's:^:@dirrm :' >> ${PLIST}
+.for dir in lib/gcc-lib src X11R6/bin X11R6/include X11R6/lib X11R6/man X11R6
+ ${ECHO_CMD} "@unexec rmdir %D/usr/${dir} >/dev/null 2>&1 || true" >> ${PLIST}
+.endfor
${RM} -rf ${WRKSRC}/tmp
do-install:
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
- @${MKDIR} ${LINUXBASE}/tmp
- @${MKDIR} ${LINUXBASE}/var/tmp
- @${MKDIR} ${LINUXBASE}/dev
- @${RM} -f ${LINUXBASE}/dev/null
- @mknod ${LINUXBASE}/dev/null c 2 2
- @${CHMOD} 666 ${LINUXBASE}/dev/null
+ @${MKDIR} ${PREFIX}/tmp
+ @${MKDIR} ${PREFIX}/var/tmp
#
# Install all packages.
@for R in ${DISTFILES}; do \
@@ -108,10 +102,10 @@ do-install:
#
# Finish
@for D in ${REMOVE_DIRS}; do \
- ${RM} -rf ${LINUXBASE}/$$D; \
+ ${RM} -rf ${PREFIX}/$$D; \
done
@for F in ${REMOVE_FILES}; do \
- ${RM} ${LINUXBASE}/$$F; \
+ ${RM} ${PREFIX}/$$F; \
done
.include <bsd.port.post.mk>