aboutsummaryrefslogtreecommitdiffstats
path: root/devel/llvm-devel
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2010-04-22 09:53:39 +0800
committerbrooks <brooks@FreeBSD.org>2010-04-22 09:53:39 +0800
commit59bf7dd8a6b2d7ffe6c4041ae7c16be0998f3922 (patch)
tree3ba8121ddac47d101d95df4a91155362aa42a15b /devel/llvm-devel
parent7057963dbf36c244189163c431f4ce0abd3ad9c3 (diff)
downloadfreebsd-ports-gnome-59bf7dd8a6b2d7ffe6c4041ae7c16be0998f3922.tar.gz
freebsd-ports-gnome-59bf7dd8a6b2d7ffe6c4041ae7c16be0998f3922.tar.zst
freebsd-ports-gnome-59bf7dd8a6b2d7ffe6c4041ae7c16be0998f3922.zip
Update to r102038.
On i386, force compliation with -O2 to avoid a -O3 bug in the base gcc.
Diffstat (limited to 'devel/llvm-devel')
-rw-r--r--devel/llvm-devel/Makefile4
-rw-r--r--devel/llvm-devel/Makefile.svn_rev2
-rw-r--r--devel/llvm-devel/distinfo6
-rw-r--r--devel/llvm-devel/pkg-plist12
4 files changed, 18 insertions, 6 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index a3797c5f6e89..eddb9e52cb16 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -74,6 +74,10 @@ BROKEN= Does not compile on sparc64
CONFIGURE_ARGS+= --enable-pic --with-pic
.endif
+.if ${ARCH} == "i386"
+CONFIGURE_ARGS+= --with-optimize-option=-O2
+.endif
+
.ifdef(WITH_NO_ASSERTS)
CONFIGURE_ARGS+= --disable-assertions
.else
diff --git a/devel/llvm-devel/Makefile.svn_rev b/devel/llvm-devel/Makefile.svn_rev
index 64be46864467..8e6647efa53d 100644
--- a/devel/llvm-devel/Makefile.svn_rev
+++ b/devel/llvm-devel/Makefile.svn_rev
@@ -1 +1 @@
-SVN_REV= 100430
+SVN_REV= 102038
diff --git a/devel/llvm-devel/distinfo b/devel/llvm-devel/distinfo
index 858e2ec48eb5..71ce9a223c36 100644
--- a/devel/llvm-devel/distinfo
+++ b/devel/llvm-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (llvm-2.7.r100430.tar.bz2) = ab73db3fc7fbbdffda032131e31b91bf
-SHA256 (llvm-2.7.r100430.tar.bz2) = f5933ed2e873fd65eae7ffd8a5f9077f1e42d33db573f2395f2bf56427f00e91
-SIZE (llvm-2.7.r100430.tar.bz2) = 10785591
+MD5 (llvm-2.7.r102038.tar.bz2) = d1689bc83ec7d0a2ac836cb51351d257
+SHA256 (llvm-2.7.r102038.tar.bz2) = 3f42998334bca65371b47718d7a7334d79530073cf621de3c99cb037508ce9d0
+SIZE (llvm-2.7.r102038.tar.bz2) = 10898923
diff --git a/devel/llvm-devel/pkg-plist b/devel/llvm-devel/pkg-plist
index 8674b006b9d8..7ec9704f638d 100644
--- a/devel/llvm-devel/pkg-plist
+++ b/devel/llvm-devel/pkg-plist
@@ -27,11 +27,13 @@ include/clang/AST/ASTConsumer.h
include/clang/AST/ASTContext.h
include/clang/AST/ASTDiagnostic.h
include/clang/AST/ASTImporter.h
+include/clang/AST/ASTVector.h
include/clang/AST/Attr.h
include/clang/AST/CXXInheritance.h
include/clang/AST/CanonicalType.h
include/clang/AST/CharUnits.h
include/clang/AST/Decl.h
+include/clang/AST/DeclAccessPair.h
include/clang/AST/DeclBase.h
include/clang/AST/DeclCXX.h
include/clang/AST/DeclContextInternals.h
@@ -83,7 +85,6 @@ include/clang/Analysis/FlowSensitive/DataflowValues.h
include/clang/Analysis/ProgramPoint.h
include/clang/Analysis/Support/BlkExprDeclBitVector.h
include/clang/Analysis/Support/BumpVector.h
-include/clang/Analysis/Support/Optional.h
include/clang/Analysis/Support/SaveAndRestore.h
include/clang/Analysis/Visitors/CFGRecStmtDeclVisitor.h
include/clang/Analysis/Visitors/CFGRecStmtVisitor.h
@@ -311,6 +312,7 @@ include/llvm/ADT/ImmutableMap.h
include/llvm/ADT/ImmutableSet.h
include/llvm/ADT/IndexedMap.h
include/llvm/ADT/IntrusiveRefCntPtr.h
+include/llvm/ADT/Optional.h
include/llvm/ADT/OwningPtr.h
include/llvm/ADT/PointerIntPair.h
include/llvm/ADT/PointerUnion.h
@@ -364,6 +366,7 @@ include/llvm/Analysis/IntervalPartition.h
include/llvm/Analysis/LazyValueInfo.h
include/llvm/Analysis/LibCallAliasAnalysis.h
include/llvm/Analysis/LibCallSemantics.h
+include/llvm/Analysis/Lint.h
include/llvm/Analysis/LiveValues.h
include/llvm/Analysis/LoopDependenceAnalysis.h
include/llvm/Analysis/LoopInfo.h
@@ -380,6 +383,7 @@ include/llvm/Analysis/ProfileInfoTypes.h
include/llvm/Analysis/ScalarEvolution.h
include/llvm/Analysis/ScalarEvolutionExpander.h
include/llvm/Analysis/ScalarEvolutionExpressions.h
+include/llvm/Analysis/ScalarEvolutionNormalization.h
include/llvm/Analysis/SparsePropagation.h
include/llvm/Analysis/Trace.h
include/llvm/Analysis/ValueTracking.h
@@ -401,6 +405,7 @@ include/llvm/Bitcode/ReaderWriter.h
include/llvm/CMakeLists.txt
include/llvm/CallGraphSCCPass.h
include/llvm/CallingConv.h
+include/llvm/CodeGen/Analysis.h
include/llvm/CodeGen/AsmPrinter.h
include/llvm/CodeGen/BinaryObject.h
include/llvm/CodeGen/CalcSpillWeights.h
@@ -411,6 +416,7 @@ include/llvm/CodeGen/GCMetadata.h
include/llvm/CodeGen/GCMetadataPrinter.h
include/llvm/CodeGen/GCStrategy.h
include/llvm/CodeGen/GCs.h
+include/llvm/CodeGen/ISDOpcodes.h
include/llvm/CodeGen/IntrinsicLowering.h
include/llvm/CodeGen/JITCodeEmitter.h
include/llvm/CodeGen/LatencyPriorityQueue.h
@@ -510,6 +516,7 @@ include/llvm/LLVMContext.h
include/llvm/LinkAllPasses.h
include/llvm/LinkAllVMCore.h
include/llvm/Linker.h
+include/llvm/MC/EDInstInfo.h
include/llvm/MC/MCAsmInfo.h
include/llvm/MC/MCAsmInfoCOFF.h
include/llvm/MC/MCAsmInfoDarwin.h
@@ -657,6 +664,7 @@ include/llvm/Target/TargetRegistry.h
include/llvm/Target/TargetSchedule.td
include/llvm/Target/TargetSelect.h
include/llvm/Target/TargetSelectionDAG.td
+include/llvm/Target/TargetSelectionDAGInfo.h
include/llvm/Target/TargetSubtarget.h
include/llvm/Transforms/IPO.h
include/llvm/Transforms/IPO/InlinerPass.h
@@ -675,7 +683,6 @@ include/llvm/Transforms/Utils/SSAUpdater.h
include/llvm/Transforms/Utils/SSI.h
include/llvm/Transforms/Utils/UnifyFunctionExitNodes.h
include/llvm/Transforms/Utils/UnrollLoop.h
-include/llvm/Transforms/Utils/ValueMapper.h
include/llvm/Type.h
include/llvm/TypeSymbolTable.h
include/llvm/Use.h
@@ -699,6 +706,7 @@ lib/libEnhancedDisassembly.so
lib/libLLVMARMAsmParser.a
lib/libLLVMARMAsmPrinter.a
lib/libLLVMARMCodeGen.a
+lib/libLLVMARMDisassembler.a
lib/libLLVMARMInfo.a
lib/libLLVMAlphaAsmPrinter.a
lib/libLLVMAlphaCodeGen.a