aboutsummaryrefslogtreecommitdiffstats
path: root/devel/llvm38
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-02-12 03:21:28 +0800
committerantoine <antoine@FreeBSD.org>2017-02-12 03:21:28 +0800
commit24ff2eb684b3a4ef1c4d0aa5e4ceda7258e4002c (patch)
tree5625933c6a16908b22edcd27f5421ad53c94ea0a /devel/llvm38
parentb808f84a73b37255e58568c1741c3852b0691c3c (diff)
downloadfreebsd-ports-gnome-24ff2eb684b3a4ef1c4d0aa5e4ceda7258e4002c.tar.gz
freebsd-ports-gnome-24ff2eb684b3a4ef1c4d0aa5e4ceda7258e4002c.tar.zst
freebsd-ports-gnome-24ff2eb684b3a4ef1c4d0aa5e4ceda7258e4002c.zip
Apply upstream r294806, remove struct_rtentry_sz on FreeBSD
This should fix build on head after _WANT_RTENTRY removal
Diffstat (limited to 'devel/llvm38')
-rw-r--r--devel/llvm38/Makefile1
-rw-r--r--devel/llvm38/files/compiler-rt-patch-svn-29480630
2 files changed, 31 insertions, 0 deletions
diff --git a/devel/llvm38/Makefile b/devel/llvm38/Makefile
index 04124634e1e0..4f2f47005474 100644
--- a/devel/llvm38/Makefile
+++ b/devel/llvm38/Makefile
@@ -304,6 +304,7 @@ post-patch:
post-patch-COMPILER_RT-on:
cd ${WRKSRC_compiler_rt} && patch < ${PATCHDIR}/compiler-rt-patch-svn-261229
+ cd ${WRKSRC_compiler_rt} && patch < ${PATCHDIR}/compiler-rt-patch-svn-294806
.if ${ARCH} == "amd64"
cd ${WRKSRC_compiler_rt} && patch < ${PATCHDIR}/compiler-rt-patch-no-m32
.endif
diff --git a/devel/llvm38/files/compiler-rt-patch-svn-294806 b/devel/llvm38/files/compiler-rt-patch-svn-294806
new file mode 100644
index 000000000000..5cffb26d6ed4
--- /dev/null
+++ b/devel/llvm38/files/compiler-rt-patch-svn-294806
@@ -0,0 +1,30 @@
+--- lib/sanitizer_common/sanitizer_platform_limits_posix.cc.orig 2016-06-01 08:17:03 UTC
++++ lib/sanitizer_common/sanitizer_platform_limits_posix.cc
+@@ -23,11 +23,6 @@
+ #ifdef _FILE_OFFSET_BITS
+ #undef _FILE_OFFSET_BITS
+ #endif
+-#if SANITIZER_FREEBSD
+-#define _WANT_RTENTRY
+-#include <sys/param.h>
+-#include <sys/socketvar.h>
+-#endif
+ #include <arpa/inet.h>
+ #include <dirent.h>
+ #include <errno.h>
+@@ -417,6 +412,7 @@ unsigned struct_ElfW_Phdr_sz = sizeof(El
+ unsigned struct_input_absinfo_sz = sizeof(struct input_absinfo);
+ unsigned struct_input_id_sz = sizeof(struct input_id);
+ unsigned struct_mtpos_sz = sizeof(struct mtpos);
++ unsigned struct_rtentry_sz = sizeof(struct rtentry);
+ unsigned struct_termio_sz = sizeof(struct termio);
+ unsigned struct_vt_consize_sz = sizeof(struct vt_consize);
+ unsigned struct_vt_sizes_sz = sizeof(struct vt_sizes);
+@@ -436,7 +432,6 @@ unsigned struct_ElfW_Phdr_sz = sizeof(El
+ unsigned struct_midi_info_sz = sizeof(struct midi_info);
+ unsigned struct_mtget_sz = sizeof(struct mtget);
+ unsigned struct_mtop_sz = sizeof(struct mtop);
+- unsigned struct_rtentry_sz = sizeof(struct rtentry);
+ unsigned struct_sbi_instrument_sz = sizeof(struct sbi_instrument);
+ unsigned struct_seq_event_rec_sz = sizeof(struct seq_event_rec);
+ unsigned struct_synth_info_sz = sizeof(struct synth_info);