aboutsummaryrefslogtreecommitdiffstats
path: root/devel/llvm
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2009-12-08 03:03:42 +0800
committerbrooks <brooks@FreeBSD.org>2009-12-08 03:03:42 +0800
commit294db390e2fe26880a45d5ccb5fe19376f582ca4 (patch)
tree44140aba7919bb8a253f85808196348aaf36ba5b /devel/llvm
parent004d2346d0eb9c6f65f549a82850612bd488f0a2 (diff)
downloadfreebsd-ports-gnome-294db390e2fe26880a45d5ccb5fe19376f582ca4.tar.gz
freebsd-ports-gnome-294db390e2fe26880a45d5ccb5fe19376f582ca4.tar.zst
freebsd-ports-gnome-294db390e2fe26880a45d5ccb5fe19376f582ca4.zip
Compile with -fPIC on amd64 and ia64.
Add an option to disable assertions which is required for a future opengtl port. PR: ports/127718, ports/139207
Diffstat (limited to 'devel/llvm')
-rw-r--r--devel/llvm/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/devel/llvm/Makefile b/devel/llvm/Makefile
index ca86a0c0889f..ec31b636c60c 100644
--- a/devel/llvm/Makefile
+++ b/devel/llvm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= llvm
PORTVERSION= 2.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
@@ -37,6 +37,8 @@ CONFIGURE_ARGS+= --enable-optimized
CONFIGURE_ARGS+= --enable-bindings=none
+OPTIONS= NO_ASSERTS "Disable assertions (needed by graphics/opengtl)" off
+
.if defined(NOPORTDOCS)
DOCSRCDIR=
.else
@@ -57,6 +59,16 @@ MAN1= bugpoint.1 llc.1 lli.1 llvm-ar.1 \
BROKEN= Does not compile on sparc64
.endif
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CONFIGURE_ARGS+= --enable-pic --with-pic
+.endif
+
+.ifdef(WITH_NO_ASSERTS)
+CONFIGURE_ARGS+= --disable-assertions
+.else
+CONFIGURE_ARGS+= --enable-assertions
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's|\(PROJ_docsdir.*:=\).*$$|\1${DOCSDIR}|g' \
${WRKSRC}/Makefile.config.in