aboutsummaryrefslogtreecommitdiffstats
path: root/devel/log4cxx
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2012-10-24 04:53:48 +0800
committerrene <rene@FreeBSD.org>2012-10-24 04:53:48 +0800
commit1fbfd3df88e9bb70b828ae5c535aaf3138a1d86d (patch)
treebc01035d4bec44a1c97d13ad60299392c39cbfc6 /devel/log4cxx
parent52de5038e87688e3342b94700142f687b1da9c1c (diff)
downloadfreebsd-ports-gnome-1fbfd3df88e9bb70b828ae5c535aaf3138a1d86d.tar.gz
freebsd-ports-gnome-1fbfd3df88e9bb70b828ae5c535aaf3138a1d86d.tar.zst
freebsd-ports-gnome-1fbfd3df88e9bb70b828ae5c535aaf3138a1d86d.zip
- convert an implicit dependency on doxygen into an explicit option
- explicitly use optionsNG - bump PORTREVISION Feature safe: yes
Diffstat (limited to 'devel/log4cxx')
-rw-r--r--devel/log4cxx/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/devel/log4cxx/Makefile b/devel/log4cxx/Makefile
index ccdb847c4c34..6507ef3c3713 100644
--- a/devel/log4cxx/Makefile
+++ b/devel/log4cxx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= log4cxx
PORTVERSION= 0.10.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= logging/${PORTNAME}/${PORTVERSION}
@@ -16,17 +16,18 @@ LICENSE= AL2
LIB_DEPENDS= apr-1:${PORTSDIR}/devel/apr1
-.if !defined(NOPORTDOCS) && defined(WITH_DOXYGEN)
+OPTIONS_DEFINE= BOOST DOXYGEN
+OPTIONS_DEFAULT=
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MDOXYGEN}
BUILD_DEPENDS+= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
.else
CONFIGURE_ARGS+= --disable-doxygen
.endif
-.if exists(${LOCALBASE}/lib/libboost_regex.so)
-WITH_BOOST= yes
-.endif
-
-.if defined(WITH_BOOST)
+.if ${PORT_OPTIONS:MBOOST}
BUILD_DEPENDS+= ${LOCALBASE}/include/boost/regex.hpp:${PORTSDIR}/devel/boost-libs
.endif
@@ -37,7 +38,7 @@ MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
-.if !defined(NOPORTDOCS) && defined(WITH_DOXYGEN)
+.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MDOXYGEN}
PORTDOCS= *
.endif
@@ -48,7 +49,7 @@ pre-configure:
@${REINPLACE_CMD} -e 's|GREP "\\-L"|GREP "conftest\\.$$objext"|g' ${WRKSRC}/configure
post-install:
-.if !defined(NOPORTDOCS) && defined(WITH_DOXYGEN)
+.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MDOXYGEN}
${MKDIR} ${DOCSDIR}
for f in ${PORTDOCS}; do \
${INSTALL_DATA} ${WRKSRC}/$$f ${DOCSDIR}; \