aboutsummaryrefslogtreecommitdiffstats
path: root/devel/lua-lpeg
diff options
context:
space:
mode:
authorbofh <bofh@FreeBSD.org>2015-03-16 22:10:24 +0800
committerbofh <bofh@FreeBSD.org>2015-03-16 22:10:24 +0800
commitf8531f860aedd17c0db34268d9c90c281d4321db (patch)
tree3116b04480cb89ccfc22fbef32bf394021b28210 /devel/lua-lpeg
parentdc33f9892d21fce803087700a7036de6f16c681d (diff)
downloadfreebsd-ports-gnome-f8531f860aedd17c0db34268d9c90c281d4321db.tar.gz
freebsd-ports-gnome-f8531f860aedd17c0db34268d9c90c281d4321db.tar.zst
freebsd-ports-gnome-f8531f860aedd17c0db34268d9c90c281d4321db.zip
[NEW] devel/lua-lpeg: Parsing Expression Grammars For Lua
- Additional SLAVE PORT for building with lua 5.1 LPeg is a new pattern-matching library for Lua, based on Parsing Expression Grammars (PEGs). WWW: http://www.inf.puc-rio.br/~roberto/lpeg/ PR: 196825 Submitted by: olevole@olevole.ru Approved by: bapt marino (implicit)
Diffstat (limited to 'devel/lua-lpeg')
-rw-r--r--devel/lua-lpeg/Makefile31
-rw-r--r--devel/lua-lpeg/distinfo2
-rw-r--r--devel/lua-lpeg/files/patch-makefile18
-rw-r--r--devel/lua-lpeg/pkg-descr4
4 files changed, 55 insertions, 0 deletions
diff --git a/devel/lua-lpeg/Makefile b/devel/lua-lpeg/Makefile
new file mode 100644
index 000000000000..187ad6fa2ef1
--- /dev/null
+++ b/devel/lua-lpeg/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= lpeg
+PORTVERSION= 0.12
+CATEGORIES= devel
+MASTER_SITES= http://www.inf.puc-rio.br/~roberto/lpeg/
+PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
+
+MAINTAINER= olevole@olevole.ru
+COMMENT= Parsing Expression Grammars For Lua
+
+LICENSE= MIT
+
+USES?= lua
+
+ALL_TARGET= linux
+MAKEFILE= ${WRKSRC}/makefile
+
+PLIST_FILES= %%LUA_MODLIBDIR%%/lpeg.so
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e \
+ "s|%%INCDIR%%|${LUA_INCDIR}|" ${WRKSRC}/makefile
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${LUA_MODLIBDIR}
+ ${INSTALL_LIB} ${WRKSRC}/${PORTNAME}.so ${STAGEDIR}/${LUA_MODLIBDIR}
+
+.include <bsd.port.post.mk>
diff --git a/devel/lua-lpeg/distinfo b/devel/lua-lpeg/distinfo
new file mode 100644
index 000000000000..6bc6fb76910a
--- /dev/null
+++ b/devel/lua-lpeg/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lpeg-0.12.tar.gz) = efa545144cd219eee823af7624d90f78c2230677ba740b7151c5d0c303778b76
+SIZE (lpeg-0.12.tar.gz) = 66649
diff --git a/devel/lua-lpeg/files/patch-makefile b/devel/lua-lpeg/files/patch-makefile
new file mode 100644
index 000000000000..a518daf58ac5
--- /dev/null
+++ b/devel/lua-lpeg/files/patch-makefile
@@ -0,0 +1,18 @@
+--- makefile.orig 2015-01-17 20:16:06.330635290 +0300
++++ makefile 2015-01-17 20:16:18.745634849 +0300
+@@ -1,5 +1,5 @@
+ LIBNAME = lpeg
+-LUADIR = /usr/include/lua5.1/
++LUADIR = %%INCDIR%%
+
+ COPT = -O2
+ # COPT = -DLPEG_DEBUG -g
+@@ -23,7 +23,7 @@
+
+
+ CFLAGS = $(CWARNS) $(COPT) -ansi -I$(LUADIR) -fPIC
+-CC = gcc
++CC? = gcc
+
+ FILES = lpvm.o lpcap.o lptree.o lpcode.o lpprint.o
+
diff --git a/devel/lua-lpeg/pkg-descr b/devel/lua-lpeg/pkg-descr
new file mode 100644
index 000000000000..d15df292c345
--- /dev/null
+++ b/devel/lua-lpeg/pkg-descr
@@ -0,0 +1,4 @@
+LPeg is a new pattern-matching library for Lua,
+based on Parsing Expression Grammars (PEGs).
+
+WWW: http://www.inf.puc-rio.br/~roberto/lpeg/