aboutsummaryrefslogtreecommitdiffstats
path: root/devel/lua-pty/Makefile
diff options
context:
space:
mode:
authorphilip <philip@FreeBSD.org>2006-12-06 06:51:12 +0800
committerphilip <philip@FreeBSD.org>2006-12-06 06:51:12 +0800
commit1e89c94016632646aa31bceab4b8e085ff6ec4ce (patch)
treea8aad89ff24af4ffe27a734c49480b783401f811 /devel/lua-pty/Makefile
parente1edf10d6c6f91963554d9a941a5c317474913bf (diff)
downloadfreebsd-ports-gnome-1e89c94016632646aa31bceab4b8e085ff6ec4ce.tar.gz
freebsd-ports-gnome-1e89c94016632646aa31bceab4b8e085ff6ec4ce.tar.zst
freebsd-ports-gnome-1e89c94016632646aa31bceab4b8e085ff6ec4ce.zip
Add devel/lua-pty to work with Lua 5.0 and Lua 5.1 and turn devel/lua50-pty
into a slave port of it. PR: ports/106347 Submitted by: Andrew Turner <andrew+ports@fubar.geek.nz> (maintainer) Repocopy by: marcus
Diffstat (limited to 'devel/lua-pty/Makefile')
-rw-r--r--devel/lua-pty/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/devel/lua-pty/Makefile b/devel/lua-pty/Makefile
index 0ee1db962e74..9ae1cd8e746f 100644
--- a/devel/lua-pty/Makefile
+++ b/devel/lua-pty/Makefile
@@ -14,15 +14,16 @@ PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
DISTFILES= pty.lua?rev=1.2 pty.c?rev=1.25
MAINTAINER= andrew+ports@fubar.geek.nz
-COMMENT= Pty (pseudo-terminal) bindings for Lua 5.0.x
+COMMENT= Pty (pseudo-terminal) bindings for Lua 5
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:extract
-
-USE_LUA= 5.0
-LUA_COMPS= lua compat51
+USE_LUA?= 5.1
+.if ${USE_LUA} == 5.0
+LUA_COMPS= compat51 lua
+BUILD_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:extract
COMPAT_SRC= `(cd ${PORTSDIR}/devel/lua50-compat51 && ${MAKE} -V WRKSRC)`
MAKE_ENV= COMPATDIR="${COMPAT_SRC}"
+.endif
PLIST_FILES= %%LUA_MODSHAREDIR%%/pty.lua \
%%LUA_MODLIBDIR%%/lpty.so