aboutsummaryrefslogtreecommitdiffstats
path: root/devel/lua50-app
diff options
context:
space:
mode:
authorphilip <philip@FreeBSD.org>2006-04-18 06:15:27 +0800
committerphilip <philip@FreeBSD.org>2006-04-18 06:15:27 +0800
commit5dc9bcca7a173857bc5034d5c93eb9e257419c06 (patch)
tree568710cb31f6546b3514be36a7c27735aae0e65e /devel/lua50-app
parentb6c43697f7f67b7f4ce03bf7b6e399a8338dfb21 (diff)
downloadfreebsd-ports-gnome-5dc9bcca7a173857bc5034d5c93eb9e257419c06.tar.gz
freebsd-ports-gnome-5dc9bcca7a173857bc5034d5c93eb9e257419c06.tar.zst
freebsd-ports-gnome-5dc9bcca7a173857bc5034d5c93eb9e257419c06.zip
Add lua50-app 1.70, app framework for Lua 5.0.x.
PR: ports/95968 Submitted by: Andrew Turner <andrew+ports -at- fubar.geek.nz>
Diffstat (limited to 'devel/lua50-app')
-rw-r--r--devel/lua50-app/Makefile32
-rw-r--r--devel/lua50-app/distinfo3
-rw-r--r--devel/lua50-app/pkg-descr2
-rw-r--r--devel/lua50-app/pkg-plist3
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/lua50-app/Makefile b/devel/lua50-app/Makefile
new file mode 100644
index 000000000000..1407900a2665
--- /dev/null
+++ b/devel/lua50-app/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: lua50-app
+# Date created: 17 April 2006
+# Whom: Andrew Turner <andrew+ports@fubar.geek.nz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= app
+PORTVERSION= 1.70
+CATEGORIES= devel
+MASTER_SITES= http://cvs.bsdinstaller.org/cgi-bin/cvsweb.cgi/installer/src/lib/lua/app/
+PKGNAMEPREFIX= lua50-
+DISTFILES= app.lua?rev=${PORTVERSION}
+EXTRACT_ONLY=
+
+MAINTAINER= andrew+ports@fubar.geek.nz
+COMMENT= App framework for Lua 5.0.x
+
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua
+RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+ ${LOCALBASE}/share/lua/5.0/posix.lua:${PORTSDIR}/devel/lua50-posix \
+ ${LOCALBASE}/share/lua/5.0/filename.lua:${PORTSDIR}/devel/lua50-filename \
+ ${LOCALBASE}/share/lua/5.0/pty.lua:${PORTSDIR}/devel/lua50-pty
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/lua/5.0
+ ${INSTALL_DATA} ${DISTDIR}/${DISTFILES} ${PREFIX}/share/lua/5.0/${DISTFILES:C/\?.*$//}
+
+.include <bsd.port.mk>
diff --git a/devel/lua50-app/distinfo b/devel/lua50-app/distinfo
new file mode 100644
index 000000000000..aaad8fbd6e5c
--- /dev/null
+++ b/devel/lua50-app/distinfo
@@ -0,0 +1,3 @@
+MD5 (app.lua?rev=1.70) = 6502b9a053fb48a5990b74b919e0e97e
+SHA256 (app.lua?rev=1.70) = fc64c6e8f159def4dedfa8d3ff8af0aa16d178f43f2d33d51bb65425d400656e
+SIZE (app.lua?rev=1.70) = 22208
diff --git a/devel/lua50-app/pkg-descr b/devel/lua50-app/pkg-descr
new file mode 100644
index 000000000000..07e71eb0381c
--- /dev/null
+++ b/devel/lua50-app/pkg-descr
@@ -0,0 +1,2 @@
+App framework for Lua, inspired by several sources, primarily the
+Erlang app module.
diff --git a/devel/lua50-app/pkg-plist b/devel/lua50-app/pkg-plist
new file mode 100644
index 000000000000..b99520e61d1b
--- /dev/null
+++ b/devel/lua50-app/pkg-plist
@@ -0,0 +1,3 @@
+share/lua/5.0/app.lua
+@dirrmtry share/lua/5.0
+@dirrmtry share/lua