aboutsummaryrefslogtreecommitdiffstats
path: root/devel/m6811-gcc
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-08-26 01:06:03 +0800
committerdinoex <dinoex@FreeBSD.org>2003-08-26 01:06:03 +0800
commit2bf38f20a02af4b90a33a3d4235847565c684751 (patch)
tree24a42fd44f4eb0a1fcef24a584fdb308c41230c0 /devel/m6811-gcc
parent45385889729094da182540c520c7a55de4316634 (diff)
downloadfreebsd-ports-gnome-2bf38f20a02af4b90a33a3d4235847565c684751.tar.gz
freebsd-ports-gnome-2bf38f20a02af4b90a33a3d4235847565c684751.tar.zst
freebsd-ports-gnome-2bf38f20a02af4b90a33a3d4235847565c684751.zip
- Fix gcc33 problems within comments
Diffstat (limited to 'devel/m6811-gcc')
-rw-r--r--devel/m6811-gcc/Makefile1
-rw-r--r--devel/m6811-gcc/files/patch-gcc-ch-loop.c13
2 files changed, 14 insertions, 0 deletions
diff --git a/devel/m6811-gcc/Makefile b/devel/m6811-gcc/Makefile
index dc54f8578b49..958771d83691 100644
--- a/devel/m6811-gcc/Makefile
+++ b/devel/m6811-gcc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gcc
PORTVERSION= 2.95.3
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gcc
diff --git a/devel/m6811-gcc/files/patch-gcc-ch-loop.c b/devel/m6811-gcc/files/patch-gcc-ch-loop.c
new file mode 100644
index 000000000000..e44619746abb
--- /dev/null
+++ b/devel/m6811-gcc/files/patch-gcc-ch-loop.c
@@ -0,0 +1,13 @@
+--- gcc/ch/loop.c.orig Mon Jan 11 14:17:29 1999
++++ gcc/ch/loop.c Mon Aug 25 18:56:36 2003
+@@ -318,8 +318,8 @@
+ (associated with all iterators).
+
+ NOTE: Z.200, section 10.1 says that a block is ...
+- "the actions statement list in a do action, including any
+- loop counter and while control". This means that an exp-
++ ;the actions statement list in a do action, including any
++ loop counter and while control;. This means that an exp-
+ ression in a WHILE control can include references to the
+ loop counters created for the loop''s exclusive use.
+ Example: