aboutsummaryrefslogtreecommitdiffstats
path: root/devel/m6811-gcc
diff options
context:
space:
mode:
authortmm <tmm@FreeBSD.org>2003-01-11 07:37:16 +0800
committertmm <tmm@FreeBSD.org>2003-01-11 07:37:16 +0800
commitc5440b5492fba46628ad53ce61d0de3382b0ad1a (patch)
tree8ffc77cafd8145c85cba7572ff80982263cb7625 /devel/m6811-gcc
parent09e5ad61fc3cda52932deca3e02bd08a0404cf8d (diff)
downloadfreebsd-ports-gnome-c5440b5492fba46628ad53ce61d0de3382b0ad1a.tar.gz
freebsd-ports-gnome-c5440b5492fba46628ad53ce61d0de3382b0ad1a.tar.zst
freebsd-ports-gnome-c5440b5492fba46628ad53ce61d0de3382b0ad1a.zip
Do not try to S/${_CPUCFLAGS}//g when _CPUCFLAGS is not defined or empty
(like on ia64); S///g is too much for make's little mind. Approved by: kris
Diffstat (limited to 'devel/m6811-gcc')
-rw-r--r--devel/m6811-gcc/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/m6811-gcc/Makefile b/devel/m6811-gcc/Makefile
index aaa2d5425c89..be264b5f75f7 100644
--- a/devel/m6811-gcc/Makefile
+++ b/devel/m6811-gcc/Makefile
@@ -28,7 +28,9 @@ ONLY_FOR_ARCHS= i386
USE_GMAKE= yes
HAS_CONFIGURE= yes
+.if defined(_CPUCFLAGS) && !empty(_CPUCFLAGS)
CFLAGS:= ${CFLAGS:S/${_CPUCFLAGS}//g}
+.endif
PLIST_SUB= GCC_VER=${PORTVERSION}
CONFIGURE_ARGS= --prefix=${PREFIX} --target=m6811-elf \
--program-prefix=m6811-elf-