aboutsummaryrefslogtreecommitdiffstats
path: root/devel/matreshka
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-02-13 03:20:24 +0800
committermarino <marino@FreeBSD.org>2014-02-13 03:20:24 +0800
commit6abdd0348db35c60df415f91fe371cd916819ad6 (patch)
treed483090b792d07795050fceb2feef45c55c5e5b2 /devel/matreshka
parent88ca4628904d5e3bde4c2472d3f9890bf612da1b (diff)
downloadfreebsd-ports-gnome-6abdd0348db35c60df415f91fe371cd916819ad6.tar.gz
freebsd-ports-gnome-6abdd0348db35c60df415f91fe371cd916819ad6.tar.zst
freebsd-ports-gnome-6abdd0348db35c60df415f91fe371cd916819ad6.zip
devel/matreshka: Upgrade from version 0.5.0 to 0.6.0
One caveat: Firebird driver has been disabled. It doesn't build using GNAT 4.7. It will be reenabled by either a patch from the developer or when GNAT is rebased on GCC 4.9
Diffstat (limited to 'devel/matreshka')
-rw-r--r--devel/matreshka/Makefile36
-rw-r--r--devel/matreshka/distinfo4
-rw-r--r--devel/matreshka/files/patch-Makefile.build15
-rw-r--r--devel/matreshka/files/patch-Makefile.install8
4 files changed, 28 insertions, 35 deletions
diff --git a/devel/matreshka/Makefile b/devel/matreshka/Makefile
index e10aefc86122..682024d1946b 100644
--- a/devel/matreshka/Makefile
+++ b/devel/matreshka/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= matreshka
-PORTVERSION= 0.5.0
-PORTREVISION= 1
+PORTVERSION= 0.6.0
CATEGORIES= devel
MASTER_SITES= http://forge.ada-ru.org/matreshka/downloads/
@@ -14,14 +13,27 @@ LICENSE= BSD
BUILD_DEPENDS= gprbuild>=20120510:${PORTSDIR}/devel/gprbuild
-USES= ada gmake
+USES= ada gmake pkgconfig
+HAS_CONFIGURE= yes
NO_MTREE= yes
OPTIONS_DEFINE= SQLITE3 FIREBIRD PGSQL MYSQL ORACLE AMF
OPTIONS_DEFAULT=SQLITE3 FIREBIRD PGSQL MYSQL
+#FIREBIRD option requires Ada-2012; disable until new compiler arrives
+#Excluding option breaks X_CONFIGURE_ENABLE, so manually set that too
+OPTIONS_EXCLUDE=FIREBIRD
+CONFIGURE_ARGS+= --disable-firebird
+
AMF_DESC= Build Ada Modeling Framework
+SQLITE3_CONFIGURE_ENABLE= sqlite3
+FIREBIRD_CONFIGURE_ENABLE= firebird
+PGSQL_CONFIGURE_ENABLE= postgresql
+MYSQL_CONFIGURE_ENABLE= mysql
+ORACLE_CONFIGURE_ENABLE= oracle
+AMF_CONFIGURE_ENABLE= amf
+
MAKE_JOBS_UNSAFE= yes
NO_LICENSES_INSTALL= yes
@@ -30,28 +42,24 @@ MAKE_ENV+= SMP_MFLAGS=-j${MAKE_JOBS_NUMBER}
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MFIREBIRD}
-MAKE_ENV+= HAS_FIREBIRD=yes
+CONFIGURE_ARGS+= --with-firebird-libdir=${LOCALBASE}/lib
+USE_FIREBIRD= yes
.endif
.if ${PORT_OPTIONS:MMYSQL}
-MAKE_ENV+= HAS_MYSQL=yes
-.endif
-
-.if ${PORT_OPTIONS:MORACLE}
-MAKE_ENV+= HAS_OCI=yes
+USE_MYSQL= yes
.endif
.if ${PORT_OPTIONS:MPGSQL}
-MAKE_ENV+= HAS_POSTGRESQL=yes
+USE_PGSQL= yes
.endif
.if ${PORT_OPTIONS:MSQLITE3}
-MAKE_ENV+= HAS_SQLITE3=yes
+USE_SQLITE= yes
.endif
-.if ${PORT_OPTIONS:MAMF}
-MAKE_ENV+= WANT_AMF=yes
-.endif
+pre-configure:
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${GMAKE} config
post-install:
@cd ${STAGEDIR}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
diff --git a/devel/matreshka/distinfo b/devel/matreshka/distinfo
index 2b65d99e0765..ce5b981f0126 100644
--- a/devel/matreshka/distinfo
+++ b/devel/matreshka/distinfo
@@ -1,2 +1,2 @@
-SHA256 (matreshka-0.5.0.tar.gz) = 09b7fd82f47d0e64ceaa1b538ed7f4e96351759ca10c0f307d0d20fec3bafe98
-SIZE (matreshka-0.5.0.tar.gz) = 32055197
+SHA256 (matreshka-0.6.0.tar.gz) = 0a84b7292c08f824c516fa4f7810dad5b0c585849c8993708a7cd3a44889e351
+SIZE (matreshka-0.6.0.tar.gz) = 32573172
diff --git a/devel/matreshka/files/patch-Makefile.build b/devel/matreshka/files/patch-Makefile.build
deleted file mode 100644
index f1b63f8168cd..000000000000
--- a/devel/matreshka/files/patch-Makefile.build
+++ /dev/null
@@ -1,15 +0,0 @@
---- Makefile.build.orig 2013-03-26 10:11:24.640151000 +0000
-+++ Makefile.build
-@@ -2,7 +2,11 @@ include Makefile.config
-
- GPRBUILD_FLAGS = -p $(SMP_MFLAGS)
-
--ALL_TARGETS = league xml fastcgi soap wsse wsdl2ada sql amf dd uml mofext ocl utp
-+ALL_TARGETS = league xml fastcgi soap wsse wsdl2ada sql
-+
-+ifdef WANT_AMF
-+ALL_TARGETS += amf dd uml mofext ocl utp
-+endif
-
- ifdef HAS_FIREBIRD
- ALL_TARGETS += firebird
diff --git a/devel/matreshka/files/patch-Makefile.install b/devel/matreshka/files/patch-Makefile.install
index 6eafba588a5f..1a6f0f605056 100644
--- a/devel/matreshka/files/patch-Makefile.install
+++ b/devel/matreshka/files/patch-Makefile.install
@@ -1,13 +1,13 @@
---- Makefile.install.orig 2012-12-05 19:49:10.977713000 +0000
+--- Makefile.install.orig 2013-12-20 08:40:13.447414000 -0500
+++ Makefile.install
-@@ -22,7 +22,11 @@ LIBEXT = dll
+@@ -24,7 +24,11 @@ LIBEXT = dll
EXEEXT = .exe
endif
-INSTALL_TARGETS = league xml fastcgi soap wsse wsdl2ada sql amf dd uml mofext ocl utp
-+INSTALL_TARGETS = league xml fastcgi soap wsse wsdl2ada sql
++INSTALL_TARGETS = league xml fastcgi soap wsse wsdl2ada sql
+
-+ifdef WANT_AMF
++ifdef ENABLE_AMF
+INSTALL_TARGETS += amf dd uml mofext ocl utp
+endif