aboutsummaryrefslogtreecommitdiffstats
path: root/devel/mdds
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-09-09 18:08:55 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-09-09 18:08:55 +0800
commit1872e751524321b9681c7c34146e9b7dac4cb78c (patch)
tree88ddbf80b8298431ea6b18a6bd7fdd71d2b98d8a /devel/mdds
parentbefd61f21a9a1eac8ad9db4c83e75573ff0abbe1 (diff)
downloadfreebsd-ports-gnome-1872e751524321b9681c7c34146e9b7dac4cb78c.tar.gz
freebsd-ports-gnome-1872e751524321b9681c7c34146e9b7dac4cb78c.tar.zst
freebsd-ports-gnome-1872e751524321b9681c7c34146e9b7dac4cb78c.zip
- Update to 0.9.0
- Fix Makefile header - Sort PLIST - Use single space after WWW: Changes: https://code.google.com/p/multidimalgorithm/source/browse/NEWS
Diffstat (limited to 'devel/mdds')
-rw-r--r--devel/mdds/Makefile5
-rw-r--r--devel/mdds/distinfo4
-rw-r--r--devel/mdds/pkg-descr5
-rw-r--r--devel/mdds/pkg-plist5
4 files changed, 10 insertions, 9 deletions
diff --git a/devel/mdds/Makefile b/devel/mdds/Makefile
index dec4fa523f8d..d4053ead2a6b 100644
--- a/devel/mdds/Makefile
+++ b/devel/mdds/Makefile
@@ -1,9 +1,8 @@
-# Created by: Baptiste Daroussin <bapt@FreeBSD.org>
+# Created by: Baptiste Daroussin <bapt@FreeBSD.org>
# $FreeBSD$
PORTNAME= mdds
-PORTVERSION= 0.8.1
-PORTREVISION= 1
+PORTVERSION= 0.9.0
CATEGORIES= devel
MASTER_SITES= GOOGLE_CODE
DISTNAME= ${PORTNAME}_${PORTVERSION}
diff --git a/devel/mdds/distinfo b/devel/mdds/distinfo
index cac5a35faf50..2aea7bba87a3 100644
--- a/devel/mdds/distinfo
+++ b/devel/mdds/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mdds_0.8.1.tar.bz2) = f605da2300c826b6f7c987fd36efb5f711bfa5c3e701ae9b75cea33591ce888b
-SIZE (mdds_0.8.1.tar.bz2) = 138431
+SHA256 (mdds_0.9.0.tar.bz2) = 77a6934923621f7f2106794c76d5b1fcc01bf646e8908f10ce7be6fd32aa1993
+SIZE (mdds_0.9.0.tar.bz2) = 144681
diff --git a/devel/mdds/pkg-descr b/devel/mdds/pkg-descr
index 30ad61076ad9..13300dbdb83b 100644
--- a/devel/mdds/pkg-descr
+++ b/devel/mdds/pkg-descr
@@ -1,3 +1,4 @@
-A collection of multi-dimensional data structure and indexing algorithm.
+Multi-Dimensional Data Structure (mdds) is a collection of multi-dimensional
+data structure and indexing algorithm.
-WWW: http://code.google.com/p/multidimalgorithm/
+WWW: http://code.google.com/p/multidimalgorithm/
diff --git a/devel/mdds/pkg-plist b/devel/mdds/pkg-plist
index 2f8538b819c5..90360dfaeb80 100644
--- a/devel/mdds/pkg-plist
+++ b/devel/mdds/pkg-plist
@@ -1,8 +1,10 @@
+include/mdds/compat/unique_ptr.hpp
include/mdds/default_deleter.hpp
include/mdds/flat_segment_tree.hpp
include/mdds/flat_segment_tree_def.inl
include/mdds/flat_segment_tree_itr.hpp
include/mdds/global.hpp
+include/mdds/hash_container/map.hpp
include/mdds/mixed_type_matrix.hpp
include/mdds/mixed_type_matrix_def.inl
include/mdds/mixed_type_matrix_element.hpp
@@ -15,6 +17,7 @@ include/mdds/multi_type_matrix_def.inl
include/mdds/multi_type_vector.hpp
include/mdds/multi_type_vector_custom_func1.hpp
include/mdds/multi_type_vector_custom_func2.hpp
+include/mdds/multi_type_vector_custom_func3.hpp
include/mdds/multi_type_vector_def.inl
include/mdds/multi_type_vector_itr.hpp
include/mdds/multi_type_vector_macro.hpp
@@ -26,8 +29,6 @@ include/mdds/quad_node.hpp
include/mdds/rectangle_set.hpp
include/mdds/rectangle_set_def.inl
include/mdds/segment_tree.hpp
-include/mdds/compat/unique_ptr.hpp
-include/mdds/hash_container/map.hpp
libdata/pkgconfig/mdds.pc
@dirrm include/mdds/hash_container
@dirrm include/mdds/compat