aboutsummaryrefslogtreecommitdiffstats
path: root/devel/mingw-gcc/files
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-08-24 22:07:29 +0800
committerknu <knu@FreeBSD.org>2000-08-24 22:07:29 +0800
commit7f845bc8201410d71138af05c18b11dde83af40c (patch)
treebd9fce917347bbbbffc392f89549f3da146c742d /devel/mingw-gcc/files
parentbbc5dbccde6baf652008ed74ce79903c6e40dc15 (diff)
downloadfreebsd-ports-gnome-7f845bc8201410d71138af05c18b11dde83af40c.tar.gz
freebsd-ports-gnome-7f845bc8201410d71138af05c18b11dde83af40c.tar.zst
freebsd-ports-gnome-7f845bc8201410d71138af05c18b11dde83af40c.zip
Fix extras.
Do not write outside the working directory during the build process. PR: ports/20740 Submitted by: Toshihiro Inoue <tino@pa2.so-net.ne.jp> (MAINTAINER)
Diffstat (limited to 'devel/mingw-gcc/files')
-rw-r--r--devel/mingw-gcc/files/patch-aa29
-rw-r--r--devel/mingw-gcc/files/patch-ab53
2 files changed, 82 insertions, 0 deletions
diff --git a/devel/mingw-gcc/files/patch-aa b/devel/mingw-gcc/files/patch-aa
new file mode 100644
index 000000000000..29cdf81e1bb9
--- /dev/null
+++ b/devel/mingw-gcc/files/patch-aa
@@ -0,0 +1,29 @@
+--- gcc/configure.orig Thu Aug 24 19:33:08 2000
++++ gcc/configure Thu Aug 24 19:52:57 2000
+@@ -763,7 +763,7 @@
+ gcc_gxx_include_dir='${libsubdir}/include/g++'
+ else
+ topsrcdir=${srcdir}/.. . ${srcdir}/../config.if
+- gcc_gxx_include_dir="\$(libsubdir)/\$(unlibsubdir)/..\`echo \$(exec_prefix) | sed -e 's|^\$(prefix)||' -e 's|/[^/]*|/..|g'\`/include/g++"-${libstdcxx_interface}
++ gcc_gxx_include_dir="\$(local_prefix)\`echo \$(exec_prefix) | sed -e 's|^\$(prefix)||' -e 's|/[^/]*|/..|g'\`/include/g++"-${libstdcxx_interface}
+ fi
+ fi
+
+@@ -8530,7 +8530,7 @@
+ # make and thus we'd get different behavior depending on where we built the
+ # sources.
+ if test x$exec_prefix = xNONE -o x$exec_prefix = x$prefix; then
+- gcc_tooldir='$(libsubdir)/$(unlibsubdir)/../$(target_alias)'
++ gcc_tooldir='$(local_prefix)/$(target_alias)'
+ else
+ # An explanation of the sed strings:
+ # -e 's|^\$(prefix)||' matches and eliminates 'prefix' from 'exec_prefix'
+@@ -8554,7 +8554,7 @@
+ # /foo /foo/bar/ugg ../../
+ #
+ dollar='$$'
+- gcc_tooldir="\$(libsubdir)/\$(unlibsubdir)/\`echo \$(exec_prefix) | sed -e 's|^\$(prefix)||' -e 's|/\$(dollar)||' -e 's|^[^/]|/|' -e 's|/[^/]*|../|g'\`\$(target_alias)"
++ gcc_tooldir="\$(libdir)/\`echo \$(exec_prefix) | sed -e 's|^\$(prefix)||' -e 's|/\$(dollar)||' -e 's|^[^/]|/|' -e 's|/[^/]*|../|g'\`\$(target_alias)"
+ fi
+
+
diff --git a/devel/mingw-gcc/files/patch-ab b/devel/mingw-gcc/files/patch-ab
new file mode 100644
index 000000000000..55c611144673
--- /dev/null
+++ b/devel/mingw-gcc/files/patch-ab
@@ -0,0 +1,53 @@
+--- gcc/Makefile.in.orig Thu Aug 24 19:46:43 2000
++++ gcc/Makefile.in Thu Aug 24 19:50:43 2000
+@@ -1407,12 +1407,12 @@
+ # Language-independent files.
+
+ DRIVER_DEFINES = \
+- -DSTANDARD_STARTFILE_PREFIX=\"$(unlibsubdir)/\" \
++ -DSTANDARD_STARTFILE_PREFIX=\"$(libdir)/\" \
+ -DSTANDARD_EXEC_PREFIX=\"$(libdir)/gcc-lib/\" \
+ -DDEFAULT_TARGET_VERSION=\"$(version)\" \
+ -DDEFAULT_TARGET_MACHINE=\"$(target_alias)\" \
+ -DSTANDARD_BINDIR_PREFIX=\"$(bindir)/\" \
+- -DTOOLDIR_BASE_PREFIX=\"$(unlibsubdir)/../\"
++ -DTOOLDIR_BASE_PREFIX=\"$(local_prefix)/\"
+ gcc.o: gcc.c $(CONFIG_H) system.h intl.h multilib.h \
+ Makefile $(lang_specs_files) prefix.h
+ $(CC) $(ALL_CFLAGS) $(ALL_CPPFLAGS) $(INCLUDES) \
+@@ -1972,7 +1972,7 @@
+ $(CC) $(ALL_CFLAGS) $(ALL_CPPFLAGS) $(INCLUDES) \
+ -DGCC_INCLUDE_DIR=\"$(libsubdir)/include\" \
+ -DGPLUSPLUS_INCLUDE_DIR=\"$(gcc_gxx_include_dir)\" \
+- -DLOCAL_INCLUDE_DIR=\"$(libsubdir)/$(unlibsubdir)/..`echo $(exec_prefix) | sed -e 's|^$(prefix)||' -e 's|/[^/]*|/..|g'`/include\" \
++ -DLOCAL_INCLUDE_DIR=\"$(local_prefix)`echo $(exec_prefix) | sed -e 's|^$(prefix)||' -e 's|/[^/]*|/..|g'`/include\" \
+ -DCROSS_INCLUDE_DIR=\"$(gcc_tooldir)/sys-include\" \
+ -DTOOL_INCLUDE_DIR=\"$(gcc_tooldir)/include\" \
+ -c `echo $(srcdir)/cccp.c | sed 's,^\./,,'`
+@@ -2006,7 +2006,7 @@
+ $(CC) $(ALL_CFLAGS) $(ALL_CPPFLAGS) $(INCLUDES) \
+ -DGCC_INCLUDE_DIR=\"$(libsubdir)/include\" \
+ -DGPLUSPLUS_INCLUDE_DIR=\"$(gcc_gxx_include_dir)\" \
+- -DLOCAL_INCLUDE_DIR=\"$(libsubdir)/$(unlibsubdir)/..`echo $(exec_prefix) | sed -e 's|^$(prefix)||' -e 's|/[^/]*|/..|g'`/include\" \
++ -DLOCAL_INCLUDE_DIR=\"$(local_prefix)`echo $(exec_prefix) | sed -e 's|^$(prefix)||' -e 's|/[^/]*|/..|g'`/include\" \
+ -DCROSS_INCLUDE_DIR=\"$(gcc_tooldir)/sys-include\" \
+ -DTOOL_INCLUDE_DIR=\"$(gcc_tooldir)/include\" \
+ -c `echo $(srcdir)/cppinit.c | sed 's,^\./,,'`
+@@ -2031,7 +2031,7 @@
+ -DGPLUSPLUS_INCLUDE_DIR=\"$(gcc_gxx_include_dir)\" \
+ -DCROSS_INCLUDE_DIR=\"$(gcc_tooldir)/sys-include\" \
+ -DTOOL_INCLUDE_DIR=\"$(gcc_tooldir)/include\" \
+- -DLOCAL_INCLUDE_DIR=\"$(libsubdir)/$(unlibsubdir)/..`echo $(exec_prefix) | sed -e 's|^$(prefix)||' -e 's|/[^/]*|/..|g'`/include\" \
++ -DLOCAL_INCLUDE_DIR=\"$(local_prefix)`echo $(exec_prefix) | sed -e 's|^$(prefix)||' -e 's|/[^/]*|/..|g'`/include\" \
+ -DSTD_PROTO_DIR=\"$(libsubdir)\" \
+ $(srcdir)/protoize.c
+
+@@ -2042,7 +2042,7 @@
+ -DGPLUSPLUS_INCLUDE_DIR=\"$(gcc_gxx_include_dir)\" \
+ -DCROSS_INCLUDE_DIR=\"$(gcc_tooldir)/sys-include\" \
+ -DTOOL_INCLUDE_DIR=\"$(gcc_tooldir)/include\" \
+- -DLOCAL_INCLUDE_DIR=\"$(libsubdir)/$(unlibsubdir)/..`echo $(exec_prefix) | sed -e 's|^$(prefix)||' -e 's|/[^/]*|/..|g'`/include\" \
++ -DLOCAL_INCLUDE_DIR=\"$(local_prefix)`echo $(exec_prefix) | sed -e 's|^$(prefix)||' -e 's|/[^/]*|/..|g'`/include\" \
+ -DSTD_PROTO_DIR=\"$(libsubdir)\" \
+ $(srcdir)/unprotoize.c
+