aboutsummaryrefslogtreecommitdiffstats
path: root/devel/mingw32-gcc
diff options
context:
space:
mode:
authorlev <lev@FreeBSD.org>2003-08-17 01:11:10 +0800
committerlev <lev@FreeBSD.org>2003-08-17 01:11:10 +0800
commit6bda8fcc856b8383cfc24ad9c7b8c9638fe838f2 (patch)
treea58b290bac058c1fb7e94d9b70ef3ee24acd0043 /devel/mingw32-gcc
parentb2dd03d6644acea225cdfc7c28998270392d92d4 (diff)
downloadfreebsd-ports-gnome-6bda8fcc856b8383cfc24ad9c7b8c9638fe838f2.tar.gz
freebsd-ports-gnome-6bda8fcc856b8383cfc24ad9c7b8c9638fe838f2.tar.zst
freebsd-ports-gnome-6bda8fcc856b8383cfc24ad9c7b8c9638fe838f2.zip
Add all libraries to build.
Now libobjc, libf2c, libstdc++ are builded and installed with headers, etc.
Diffstat (limited to 'devel/mingw32-gcc')
-rw-r--r--devel/mingw32-gcc/Makefile8
-rw-r--r--devel/mingw32-gcc/pkg-plist219
2 files changed, 222 insertions, 5 deletions
diff --git a/devel/mingw32-gcc/Makefile b/devel/mingw32-gcc/Makefile
index ef7d6c33898d..91f82b706610 100644
--- a/devel/mingw32-gcc/Makefile
+++ b/devel/mingw32-gcc/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= ${GCCVERSION}.${PATCHVERSION}
PORTEPOCH= 1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTNAME}-${GCCVERSION}
@@ -42,10 +43,11 @@ USE_PERL5_BUILD=yes
USE_GMAKE= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS= --target=${PKGNAMEPREFIX:S/-$//} \
- --enable-languages=c,c++,ada,f77,objc \
+ --enable-languages=c,c++,f77,objc \
--with-gcc --with-gnu-ld --with-gnu-as \
--enable-threads --disable-nls \
- --disable-win32-registry --disable-shared
+ --disable-win32-registry --disable-shared \
+ --enable-sjlj-exceptions
MAKE_ENV= PATH=${PREFIX}/bin:${PATH}
LIBTOOLFILES= configure gcc/configure
MAN1= ${PKGNAMEPREFIX}gcc.1 ${PKGNAMEPREFIX}g++.1 ${PKGNAMEPREFIX}g77.1 \
@@ -58,7 +60,7 @@ PLIST_SUB+= PORTVERSION=${PORTVERSION} GCC_TARG=${PKGNAMEPREFIX:S/-$//} \
BINARIES= gcc cpp g++ g77 gcov
post-configure:
- @${PERL} -pi.bak -e 's,^(TARGET_CONFIGDIRS\s*=).+$$,\1,' ${WRKSRC}/Makefile
+ @${PERL} -pi.bak -e 's,^(TARGET_CONFIGDIRS\s*=\s*).+$$,\1libstdc++-v3 libf2c libobjc mingw,' ${WRKSRC}/Makefile
@${PERL} -pi.bak -e 's,^(install-info:),\1\ndonot-\1,' ${WRKSRC}/gcc/Makefile
post-install:
diff --git a/devel/mingw32-gcc/pkg-plist b/devel/mingw32-gcc/pkg-plist
index 3fe5a8b63394..677a877d4f33 100644
--- a/devel/mingw32-gcc/pkg-plist
+++ b/devel/mingw32-gcc/pkg-plist
@@ -4,6 +4,15 @@
%%GCC_TARG%%/bin/g77
%%GCC_TARG%%/bin/gcc
%%GCC_TARG%%/bin/gcov
+%%GCC_TARG%%/lib/libfrtbegin.a
+%%GCC_TARG%%/lib/libg2c.a
+%%GCC_TARG%%/lib/libg2c.la
+%%GCC_TARG%%/lib/libobjc.a
+%%GCC_TARG%%/lib/libobjc.la
+%%GCC_TARG%%/lib/libstdc++.a
+%%GCC_TARG%%/lib/libstdc++.la
+%%GCC_TARG%%/lib/libsupc++.a
+%%GCC_TARG%%/lib/libsupc++.la
bin/%%GCC_TARG%%-c++
bin/%%GCC_TARG%%-cpp
bin/%%GCC_TARG%%-g++
@@ -11,6 +20,192 @@ bin/%%GCC_TARG%%-g77
bin/%%GCC_TARG%%-gcc
bin/%%GCC_TARG%%-gccbug
bin/%%GCC_TARG%%-gcov
+include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits/atomicity.h
+include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits/basic_file.h
+include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits/c++config.h
+include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits/c++io.h
+include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits/c++locale.h
+include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits/codecvt_specializations.h
+include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits/cpu_limits.h
+include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits/ctype_base.h
+include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits/ctype_inline.h
+include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits/ctype_noninline.h
+include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits/gthr-default.h
+include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits/gthr-posix.h
+include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits/gthr-single.h
+include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits/gthr.h
+include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits/messages_members.h
+include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits/os_defines.h
+include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits/time_members.h
+include/c++/%%GCC_REV%%/algorithm
+include/c++/%%GCC_REV%%/backward/algo.h
+include/c++/%%GCC_REV%%/backward/algobase.h
+include/c++/%%GCC_REV%%/backward/alloc.h
+include/c++/%%GCC_REV%%/backward/backward_warning.h
+include/c++/%%GCC_REV%%/backward/bvector.h
+include/c++/%%GCC_REV%%/backward/complex.h
+include/c++/%%GCC_REV%%/backward/defalloc.h
+include/c++/%%GCC_REV%%/backward/deque.h
+include/c++/%%GCC_REV%%/backward/fstream.h
+include/c++/%%GCC_REV%%/backward/function.h
+include/c++/%%GCC_REV%%/backward/hash_map.h
+include/c++/%%GCC_REV%%/backward/hash_set.h
+include/c++/%%GCC_REV%%/backward/hashtable.h
+include/c++/%%GCC_REV%%/backward/heap.h
+include/c++/%%GCC_REV%%/backward/iomanip.h
+include/c++/%%GCC_REV%%/backward/iostream.h
+include/c++/%%GCC_REV%%/backward/istream.h
+include/c++/%%GCC_REV%%/backward/iterator.h
+include/c++/%%GCC_REV%%/backward/list.h
+include/c++/%%GCC_REV%%/backward/map.h
+include/c++/%%GCC_REV%%/backward/multimap.h
+include/c++/%%GCC_REV%%/backward/multiset.h
+include/c++/%%GCC_REV%%/backward/new.h
+include/c++/%%GCC_REV%%/backward/ostream.h
+include/c++/%%GCC_REV%%/backward/pair.h
+include/c++/%%GCC_REV%%/backward/queue.h
+include/c++/%%GCC_REV%%/backward/rope.h
+include/c++/%%GCC_REV%%/backward/set.h
+include/c++/%%GCC_REV%%/backward/slist.h
+include/c++/%%GCC_REV%%/backward/stack.h
+include/c++/%%GCC_REV%%/backward/stream.h
+include/c++/%%GCC_REV%%/backward/streambuf.h
+include/c++/%%GCC_REV%%/backward/strstream
+include/c++/%%GCC_REV%%/backward/strstream.h
+include/c++/%%GCC_REV%%/backward/tempbuf.h
+include/c++/%%GCC_REV%%/backward/tree.h
+include/c++/%%GCC_REV%%/backward/vector.h
+include/c++/%%GCC_REV%%/bits/basic_ios.h
+include/c++/%%GCC_REV%%/bits/basic_ios.tcc
+include/c++/%%GCC_REV%%/bits/basic_string.h
+include/c++/%%GCC_REV%%/bits/basic_string.tcc
+include/c++/%%GCC_REV%%/bits/boost_concept_check.h
+include/c++/%%GCC_REV%%/bits/char_traits.h
+include/c++/%%GCC_REV%%/bits/cmath.tcc
+include/c++/%%GCC_REV%%/bits/codecvt.h
+include/c++/%%GCC_REV%%/bits/concept_check.h
+include/c++/%%GCC_REV%%/bits/cpp_type_traits.h
+include/c++/%%GCC_REV%%/bits/fpos.h
+include/c++/%%GCC_REV%%/bits/fstream.tcc
+include/c++/%%GCC_REV%%/bits/functexcept.h
+include/c++/%%GCC_REV%%/bits/generic_shadow.h
+include/c++/%%GCC_REV%%/bits/gslice.h
+include/c++/%%GCC_REV%%/bits/gslice_array.h
+include/c++/%%GCC_REV%%/bits/indirect_array.h
+include/c++/%%GCC_REV%%/bits/ios_base.h
+include/c++/%%GCC_REV%%/bits/istream.tcc
+include/c++/%%GCC_REV%%/bits/locale_facets.h
+include/c++/%%GCC_REV%%/bits/locale_facets.tcc
+include/c++/%%GCC_REV%%/bits/localefwd.h
+include/c++/%%GCC_REV%%/bits/mask_array.h
+include/c++/%%GCC_REV%%/bits/ostream.tcc
+include/c++/%%GCC_REV%%/bits/pthread_allocimpl.h
+include/c++/%%GCC_REV%%/bits/slice.h
+include/c++/%%GCC_REV%%/bits/slice_array.h
+include/c++/%%GCC_REV%%/bits/sstream.tcc
+include/c++/%%GCC_REV%%/bits/stl_algo.h
+include/c++/%%GCC_REV%%/bits/stl_algobase.h
+include/c++/%%GCC_REV%%/bits/stl_alloc.h
+include/c++/%%GCC_REV%%/bits/stl_bvector.h
+include/c++/%%GCC_REV%%/bits/stl_construct.h
+include/c++/%%GCC_REV%%/bits/stl_deque.h
+include/c++/%%GCC_REV%%/bits/stl_function.h
+include/c++/%%GCC_REV%%/bits/stl_heap.h
+include/c++/%%GCC_REV%%/bits/stl_iterator.h
+include/c++/%%GCC_REV%%/bits/stl_iterator_base_funcs.h
+include/c++/%%GCC_REV%%/bits/stl_iterator_base_types.h
+include/c++/%%GCC_REV%%/bits/stl_list.h
+include/c++/%%GCC_REV%%/bits/stl_map.h
+include/c++/%%GCC_REV%%/bits/stl_multimap.h
+include/c++/%%GCC_REV%%/bits/stl_multiset.h
+include/c++/%%GCC_REV%%/bits/stl_numeric.h
+include/c++/%%GCC_REV%%/bits/stl_pair.h
+include/c++/%%GCC_REV%%/bits/stl_pthread_alloc.h
+include/c++/%%GCC_REV%%/bits/stl_queue.h
+include/c++/%%GCC_REV%%/bits/stl_raw_storage_iter.h
+include/c++/%%GCC_REV%%/bits/stl_relops.h
+include/c++/%%GCC_REV%%/bits/stl_set.h
+include/c++/%%GCC_REV%%/bits/stl_stack.h
+include/c++/%%GCC_REV%%/bits/stl_tempbuf.h
+include/c++/%%GCC_REV%%/bits/stl_threads.h
+include/c++/%%GCC_REV%%/bits/stl_tree.h
+include/c++/%%GCC_REV%%/bits/stl_uninitialized.h
+include/c++/%%GCC_REV%%/bits/stl_vector.h
+include/c++/%%GCC_REV%%/bits/stream_iterator.h
+include/c++/%%GCC_REV%%/bits/streambuf.tcc
+include/c++/%%GCC_REV%%/bits/streambuf_iterator.h
+include/c++/%%GCC_REV%%/bits/stringfwd.h
+include/c++/%%GCC_REV%%/bits/type_traits.h
+include/c++/%%GCC_REV%%/bits/valarray_array.h
+include/c++/%%GCC_REV%%/bits/valarray_array.tcc
+include/c++/%%GCC_REV%%/bits/valarray_meta.h
+include/c++/%%GCC_REV%%/bitset
+include/c++/%%GCC_REV%%/cassert
+include/c++/%%GCC_REV%%/cctype
+include/c++/%%GCC_REV%%/cerrno
+include/c++/%%GCC_REV%%/cfloat
+include/c++/%%GCC_REV%%/ciso646
+include/c++/%%GCC_REV%%/climits
+include/c++/%%GCC_REV%%/clocale
+include/c++/%%GCC_REV%%/cmath
+include/c++/%%GCC_REV%%/complex
+include/c++/%%GCC_REV%%/csetjmp
+include/c++/%%GCC_REV%%/csignal
+include/c++/%%GCC_REV%%/cstdarg
+include/c++/%%GCC_REV%%/cstddef
+include/c++/%%GCC_REV%%/cstdio
+include/c++/%%GCC_REV%%/cstdlib
+include/c++/%%GCC_REV%%/cstring
+include/c++/%%GCC_REV%%/ctime
+include/c++/%%GCC_REV%%/cwchar
+include/c++/%%GCC_REV%%/cwctype
+include/c++/%%GCC_REV%%/cxxabi.h
+include/c++/%%GCC_REV%%/deque
+include/c++/%%GCC_REV%%/exception
+include/c++/%%GCC_REV%%/exception_defines.h
+include/c++/%%GCC_REV%%/ext/algorithm
+include/c++/%%GCC_REV%%/ext/enc_filebuf.h
+include/c++/%%GCC_REV%%/ext/functional
+include/c++/%%GCC_REV%%/ext/hash_map
+include/c++/%%GCC_REV%%/ext/hash_set
+include/c++/%%GCC_REV%%/ext/iterator
+include/c++/%%GCC_REV%%/ext/memory
+include/c++/%%GCC_REV%%/ext/numeric
+include/c++/%%GCC_REV%%/ext/rb_tree
+include/c++/%%GCC_REV%%/ext/rope
+include/c++/%%GCC_REV%%/ext/ropeimpl.h
+include/c++/%%GCC_REV%%/ext/slist
+include/c++/%%GCC_REV%%/ext/stdio_filebuf.h
+include/c++/%%GCC_REV%%/ext/stl_hash_fun.h
+include/c++/%%GCC_REV%%/ext/stl_hashtable.h
+include/c++/%%GCC_REV%%/ext/stl_rope.h
+include/c++/%%GCC_REV%%/fstream
+include/c++/%%GCC_REV%%/functional
+include/c++/%%GCC_REV%%/iomanip
+include/c++/%%GCC_REV%%/ios
+include/c++/%%GCC_REV%%/iosfwd
+include/c++/%%GCC_REV%%/iostream
+include/c++/%%GCC_REV%%/istream
+include/c++/%%GCC_REV%%/iterator
+include/c++/%%GCC_REV%%/limits
+include/c++/%%GCC_REV%%/list
+include/c++/%%GCC_REV%%/locale
+include/c++/%%GCC_REV%%/map
+include/c++/%%GCC_REV%%/memory
+include/c++/%%GCC_REV%%/new
+include/c++/%%GCC_REV%%/numeric
+include/c++/%%GCC_REV%%/ostream
+include/c++/%%GCC_REV%%/queue
+include/c++/%%GCC_REV%%/set
+include/c++/%%GCC_REV%%/sstream
+include/c++/%%GCC_REV%%/stack
+include/c++/%%GCC_REV%%/stdexcept
+include/c++/%%GCC_REV%%/streambuf
+include/c++/%%GCC_REV%%/string
+include/c++/%%GCC_REV%%/typeinfo
+include/c++/%%GCC_REV%%/utility
+include/c++/%%GCC_REV%%/valarray
+include/c++/%%GCC_REV%%/vector
lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/cc1
lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/cc1obj
lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/cc1plus
@@ -18,11 +213,23 @@ lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/cpp0
lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/crtbegin.o
lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/crtend.o
lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/f771
-lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/README
lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/float.h
+lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/g2c.h
lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/iso646.h
lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/limits.h
lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/mmintrin.h
+lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/objc/encoding.h
+lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/objc/hash.h
+lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/objc/NXConstStr.h
+lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/objc/objc-api.h
+lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/objc/objc-list.h
+lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/objc/objc.h
+lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/objc/Object.h
+lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/objc/Protocol.h
+lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/objc/sarray.h
+lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/objc/thr.h
+lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/objc/typedstream.h
+lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/README
lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/stdarg.h
lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/stdbool.h
lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/stddef.h
@@ -32,7 +239,15 @@ lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/xmmintrin.h
lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/libgcc.a
lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/specs
lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/tradcpp0
+@dirrm include/c++/%%GCC_REV%%/%%GCC_TARG%%/bits
+@dirrm include/c++/%%GCC_REV%%/%%GCC_TARG%%
+@dirrm include/c++/%%GCC_REV%%/backward
+@dirrm include/c++/%%GCC_REV%%/bits
+@dirrm include/c++/%%GCC_REV%%/ext
+@dirrm include/c++/%%GCC_REV%%
+@dirrm lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include/objc
@dirrm lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%/include
@dirrm lib/gcc-lib/%%GCC_TARG%%/%%GCC_REV%%
@dirrm lib/gcc-lib/%%GCC_TARG%%
-@unexec rmdir %D/lib/gcc-lib 2> /dev/null || true
+@unexec rmdir %D/include/c++ 2> /dev/null || true
+@unexec rmdir %D/lib/gcc-lib 2> /dev/null || true \ No newline at end of file