aboutsummaryrefslogtreecommitdiffstats
path: root/devel/moonshine
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-16 04:37:04 +0800
committermarcus <marcus@FreeBSD.org>2003-11-16 04:37:04 +0800
commit71ad4933995cc892d62e378ee5be6ac15c6e62ef (patch)
tree610711606eefa728d01e4e333cc0119ea924f1f6 /devel/moonshine
parent8918e3de46086cf18a356130171394cc05affdc3 (diff)
downloadfreebsd-ports-gnome-71ad4933995cc892d62e378ee5be6ac15c6e62ef.tar.gz
freebsd-ports-gnome-71ad4933995cc892d62e378ee5be6ac15c6e62ef.tar.zst
freebsd-ports-gnome-71ad4933995cc892d62e378ee5be6ac15c6e62ef.zip
unPERLify, and use ${FIND} and ${XARGS} where appropriate.
PR: 48253 Submitted by: Simon 'portlint' Schubert <corecode@corecode.ath.cx>
Diffstat (limited to 'devel/moonshine')
-rw-r--r--devel/moonshine/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/devel/moonshine/Makefile b/devel/moonshine/Makefile
index b13ff7e925c7..75d413ae22d2 100644
--- a/devel/moonshine/Makefile
+++ b/devel/moonshine/Makefile
@@ -17,6 +17,7 @@ COMMENT= A customizable IDE that supports a wide variety of languages
USE_QT_VER= 2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_XLIB= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= QTDIR="${X11BASE}"
QTCPPFLAGS+= -I${X11BASE}/include
@@ -32,10 +33,10 @@ CFLAGS+= -O0
.endif
pre-configure:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
- 's|\$$\{prefix\}/moonshine|\$$\{prefix\}/share/moonshine| ; \
- s|\@INSTBIN\@|${PREFIX}/bin| ; s|moc -o|\$$\(MOC\) -o|'
- @${PERL} -pi -e 's|/usr/share/moonshine|${PREFIX}/share/moonshine|' \
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|\$${prefix}/moonshine|$${prefix}/share/moonshine| ; \
+ s|@INSTBIN@|${PREFIX}/bin| ; s|moc -o|$$(MOC) -o|'
+ @${REINPLACE_CMD} -e 's|/usr/share/moonshine|${PREFIX}/share/moonshine|' \
${WRKSRC}/include/tags.h
.include <bsd.port.post.mk>