aboutsummaryrefslogtreecommitdiffstats
path: root/devel/mpatrol
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2006-11-03 11:51:40 +0800
committersobomax <sobomax@FreeBSD.org>2006-11-03 11:51:40 +0800
commit9f22979131df7b80caaa4a44c615abead847e186 (patch)
tree76a5e93fc56356d3cf6af8da86b883f0a08ac2ee /devel/mpatrol
parentae60a0e5590268aa7b9f3214c43293ca0917b213 (diff)
downloadfreebsd-ports-gnome-9f22979131df7b80caaa4a44c615abead847e186.tar.gz
freebsd-ports-gnome-9f22979131df7b80caaa4a44c615abead847e186.tar.zst
freebsd-ports-gnome-9f22979131df7b80caaa4a44c615abead847e186.zip
Unbreak on amd64.
Obtained from: debian (mptrace.c patch) Sponsored by: Sippy Software, Inc.
Diffstat (limited to 'devel/mpatrol')
-rw-r--r--devel/mpatrol/Makefile10
-rw-r--r--devel/mpatrol/files/patch-..::..::src::mptrace.c44
2 files changed, 52 insertions, 2 deletions
diff --git a/devel/mpatrol/Makefile b/devel/mpatrol/Makefile
index 203f54603bf4..57a5b80fb9bd 100644
--- a/devel/mpatrol/Makefile
+++ b/devel/mpatrol/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= elf.0:${PORTSDIR}/devel/libelf
WRKSRC= ${WRKDIR}/${PORTNAME}/build/unix
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
INSTALLS_SHLIB= yes
USE_GMAKE= yes
@@ -42,6 +42,12 @@ DOCSIMG= cc1.eps cc1.jpg cc1.pdf \
test.eps test.jpg test.pdf \
trace.eps trace.jpg trace.pdf
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+CFLAGS+= -DENVIRON=\"ENVIRON_64\" -DMP_INIT_SUPPORT=0
+.endif
+
do-install:
.for file in hexwords mpedit mpsym mupdate
${INSTALL_SCRIPT} ${WRKSRC}/../../bin/${file} ${PREFIX}/bin
@@ -77,4 +83,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/mpatrol/files/patch-..::..::src::mptrace.c b/devel/mpatrol/files/patch-..::..::src::mptrace.c
new file mode 100644
index 000000000000..81272824cd51
--- /dev/null
+++ b/devel/mpatrol/files/patch-..::..::src::mptrace.c
@@ -0,0 +1,44 @@
+
+$FreeBSD$
+
+--- ../../src/mptrace.c
++++ ../../src/mptrace.c
+@@ -268,27 +268,27 @@
+ static XtResource resources[] =
+ {
+ {"alloc", XmCColor, XmRPixel, sizeof(Pixel),
+- (Cardinal) &alcol, XmRString, (XtPointer) "black"},
++ (long) &alcol, XmRString, (XtPointer) "black"},
+ {"base", "Base", XmRInt, sizeof(void *),
+- (Cardinal) &addrbase, XmRImmediate, (XtPointer) NULL},
++ (long) &addrbase, XmRImmediate, (XtPointer) NULL},
+ {"delay", "Delay", XmRInt, sizeof(unsigned long),
+- (Cardinal) &delay, XmRImmediate, (XtPointer) 0},
++ (long) &delay, XmRImmediate, (XtPointer) 0},
+ {"free", XmCColor, XmRPixel, sizeof(Pixel),
+- (Cardinal) &frcol, XmRString, (XtPointer) "white"},
++ (long) &frcol, XmRString, (XtPointer) "white"},
+ {"height", XmCHeight, XmRShort, sizeof(Dimension),
+- (Cardinal) &height, XmRImmediate, (XtPointer) 512},
++ (long) &height, XmRImmediate, (XtPointer) 512},
+ {"internal", XmCColor, XmRPixel, sizeof(Pixel),
+- (Cardinal) &incol, XmRString, (XtPointer) "red"},
++ (long) &incol, XmRString, (XtPointer) "red"},
+ {"space", "Space", XmRInt, sizeof(unsigned long),
+- (Cardinal) &addrspace, XmRImmediate, (XtPointer) 4},
++ (long) &addrspace, XmRImmediate, (XtPointer) 4},
+ {"unalloc", XmCColor, XmRPixel, sizeof(Pixel),
+- (Cardinal) &uncol, XmRString, (XtPointer) "blue"},
++ (long) &uncol, XmRString, (XtPointer) "blue"},
+ {"view-height", XmCHeight, XmRShort, sizeof(Dimension),
+- (Cardinal) &vheight, XmRImmediate, (XtPointer) 256},
++ (long) &vheight, XmRImmediate, (XtPointer) 256},
+ {"view-width", XmCWidth, XmRShort, sizeof(Dimension),
+- (Cardinal) &vwidth, XmRImmediate, (XtPointer) 256},
++ (long) &vwidth, XmRImmediate, (XtPointer) 256},
+ {"width", XmCWidth, XmRShort, sizeof(Dimension),
+- (Cardinal) &width, XmRImmediate, (XtPointer) 512}
++ (long) &width, XmRImmediate, (XtPointer) 512}
+ };
+
+