aboutsummaryrefslogtreecommitdiffstats
path: root/devel/mprof
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2007-06-19 03:48:01 +0800
committerdanfe <danfe@FreeBSD.org>2007-06-19 03:48:01 +0800
commitc8f80257dfcbde47d77927e3d0717da31d6bfa60 (patch)
treed64b263e83b4068c5e65fed6b0a70a128a7c06b7 /devel/mprof
parent1643683c5172447709f11abe0a134397bdbce979 (diff)
downloadfreebsd-ports-gnome-c8f80257dfcbde47d77927e3d0717da31d6bfa60.tar.gz
freebsd-ports-gnome-c8f80257dfcbde47d77927e3d0717da31d6bfa60.tar.zst
freebsd-ports-gnome-c8f80257dfcbde47d77927e3d0717da31d6bfa60.zip
Fix the build with GCC 4.2 and thus unbreak.
Reported by: pointyhat (logs)
Diffstat (limited to 'devel/mprof')
-rw-r--r--devel/mprof/Makefile8
-rw-r--r--devel/mprof/files/patch-malloc.c11
2 files changed, 12 insertions, 7 deletions
diff --git a/devel/mprof/Makefile b/devel/mprof/Makefile
index 0334dd91bf24..0b65d63e49e5 100644
--- a/devel/mprof/Makefile
+++ b/devel/mprof/Makefile
@@ -21,15 +21,9 @@ MAKEFILE= Makefile.i386
MAN1= mprof.1
PLIST_FILES= bin/mprof lib/libc_mp.a
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mprof ${PREFIX}/bin
${INSTALL} ${COPY} -m 555 ${WRKSRC}/libc_mp.a ${PREFIX}/lib
${INSTALL_MAN} ${WRKSRC}/mprof.1 ${PREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/mprof/files/patch-malloc.c b/devel/mprof/files/patch-malloc.c
new file mode 100644
index 000000000000..5dc8171ff646
--- /dev/null
+++ b/devel/mprof/files/patch-malloc.c
@@ -0,0 +1,11 @@
+--- malloc.c.orig Wed Apr 21 04:36:17 1993
++++ malloc.c Tue Jun 19 02:43:44 2007
+@@ -261,6 +261,8 @@
+ */
+ int realloc_srchlen = 4; /* 4 should be plenty, -1 =>'s whole list */
+
++static findbucket(union overhead *, int srchlen);
++
+ char *
+ realloc(cp, nbytes)
+ char *cp;