aboutsummaryrefslogtreecommitdiffstats
path: root/devel/mq4cpp
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2007-01-04 17:17:03 +0800
committervanilla <vanilla@FreeBSD.org>2007-01-04 17:17:03 +0800
commit337ae3e17f8397fd7c919b7bc179cf70395b34d2 (patch)
treeb47020f514bd588cffef3436ac1077471c0fd2f6 /devel/mq4cpp
parentc7ea2a50c56977125d652d75ced7f1b82519ec44 (diff)
downloadfreebsd-ports-gnome-337ae3e17f8397fd7c919b7bc179cf70395b34d2.tar.gz
freebsd-ports-gnome-337ae3e17f8397fd7c919b7bc179cf70395b34d2.tar.zst
freebsd-ports-gnome-337ae3e17f8397fd7c919b7bc179cf70395b34d2.zip
Add mq4cpp, it's Message queue for c++.
Diffstat (limited to 'devel/mq4cpp')
-rw-r--r--devel/mq4cpp/Makefile23
-rw-r--r--devel/mq4cpp/distinfo3
-rw-r--r--devel/mq4cpp/files/patch-Makefile.in11
-rw-r--r--devel/mq4cpp/files/patch-include_MessageProxy.h11
-rw-r--r--devel/mq4cpp/files/patch-include_Socket.h10
-rw-r--r--devel/mq4cpp/files/patch-include_Thread.h11
-rw-r--r--devel/mq4cpp/files/patch-include_rijndael.h17
-rw-r--r--devel/mq4cpp/files/patch-src_FileSystem.cpp37
-rw-r--r--devel/mq4cpp/files/patch-src_Thread.cpp11
-rw-r--r--devel/mq4cpp/pkg-descr5
-rw-r--r--devel/mq4cpp/pkg-plist41
11 files changed, 180 insertions, 0 deletions
diff --git a/devel/mq4cpp/Makefile b/devel/mq4cpp/Makefile
new file mode 100644
index 000000000000..c224fb9eaa8a
--- /dev/null
+++ b/devel/mq4cpp/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: mp4cpp
+# Date created: Jan 4 2007
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= mq4cpp
+PORTVERSION= 1.14
+CATEGORIES= devel
+MASTER_SITES= http://www.sixtyfourbit.org/Download/
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= Message Queuing for C++
+
+USE_LDCONFIG= yes
+USE_GCC= 3.4+
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= gnomehack gnometarget pkgconfig ltverhack
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/mq4cpp/distinfo b/devel/mq4cpp/distinfo
new file mode 100644
index 000000000000..718e68f4185e
--- /dev/null
+++ b/devel/mq4cpp/distinfo
@@ -0,0 +1,3 @@
+MD5 (mq4cpp-1.14.tar.bz2) = a41fadd676a163700072a261125277fa
+SHA256 (mq4cpp-1.14.tar.bz2) = 032634e679d6a9b1eb742c14aacd510a29388207202d9e3ee21afc3f1e061845
+SIZE (mq4cpp-1.14.tar.bz2) = 1731994
diff --git a/devel/mq4cpp/files/patch-Makefile.in b/devel/mq4cpp/files/patch-Makefile.in
new file mode 100644
index 000000000000..0713fbf938b0
--- /dev/null
+++ b/devel/mq4cpp/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Thu Jan 4 15:55:59 2007
++++ Makefile.in Thu Jan 4 15:56:07 2007
+@@ -213,7 +213,7 @@
+ pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = $(GENERIC_LIBRARY_NAME).pc
+ doc_DATA = AUTHORS ChangeLog COPYING INSTALL NEWS README LICENSE TODO
+-docdir = $(datadir)/doc
++docdir = $(datadir)/doc/mq4cpp
+ all: config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-recursive
+
diff --git a/devel/mq4cpp/files/patch-include_MessageProxy.h b/devel/mq4cpp/files/patch-include_MessageProxy.h
new file mode 100644
index 000000000000..c24c871b4a7b
--- /dev/null
+++ b/devel/mq4cpp/files/patch-include_MessageProxy.h
@@ -0,0 +1,11 @@
+--- include/MessageProxy.h.orig Thu Jan 4 12:28:14 2007
++++ include/MessageProxy.h Thu Jan 4 12:28:19 2007
+@@ -32,7 +32,7 @@
+ #include <windows.h>
+ #else
+ #include <pthread.h>
+-#include <asm/errno.h>
++#include <sys/errno.h>
+ #endif
+
+ #include <vector>
diff --git a/devel/mq4cpp/files/patch-include_Socket.h b/devel/mq4cpp/files/patch-include_Socket.h
new file mode 100644
index 000000000000..18a6939b4cf4
--- /dev/null
+++ b/devel/mq4cpp/files/patch-include_Socket.h
@@ -0,0 +1,10 @@
+--- include/Socket.h.orig Mon Dec 18 02:57:52 2006
++++ include/Socket.h Thu Jan 4 12:26:33 2007
+@@ -29,6 +29,7 @@
+ #include <WinSock2.h>
+ #else
+ #include <netinet/in.h>
++#include <sys/socket.h>
+ typedef int SOCKET;
+ #endif
+
diff --git a/devel/mq4cpp/files/patch-include_Thread.h b/devel/mq4cpp/files/patch-include_Thread.h
new file mode 100644
index 000000000000..16d2890104ae
--- /dev/null
+++ b/devel/mq4cpp/files/patch-include_Thread.h
@@ -0,0 +1,11 @@
+--- include/Thread.h.orig Mon Dec 18 02:57:52 2006
++++ include/Thread.h Thu Jan 4 12:26:18 2007
+@@ -27,7 +27,7 @@
+ #include <windows.h>
+ #else
+ #include <pthread.h>
+-#include <asm/errno.h>
++#include <sys/errno.h>
+ #endif
+
+ class ThreadException : public Exception
diff --git a/devel/mq4cpp/files/patch-include_rijndael.h b/devel/mq4cpp/files/patch-include_rijndael.h
new file mode 100644
index 000000000000..6356ba19e8be
--- /dev/null
+++ b/devel/mq4cpp/files/patch-include_rijndael.h
@@ -0,0 +1,17 @@
+--- include/rijndael.h.orig Thu Jan 4 12:26:53 2007
++++ include/rijndael.h Thu Jan 4 12:27:11 2007
+@@ -23,11 +23,11 @@
+ typedef unsigned short word16;
+ typedef unsigned char byte;
+ #else
+-#include <asm/types.h>
++#include <sys/types.h>
+ #include <stdlib.h>
+ #include <string.h>
+-typedef __u32 word32;
+-typedef __s32 sword32;
++typedef uint32_t word32;
++typedef int32_t sword32;
+ typedef unsigned short word16;
+ typedef unsigned char byte;
+ #endif
diff --git a/devel/mq4cpp/files/patch-src_FileSystem.cpp b/devel/mq4cpp/files/patch-src_FileSystem.cpp
new file mode 100644
index 000000000000..9d592d6d9549
--- /dev/null
+++ b/devel/mq4cpp/files/patch-src_FileSystem.cpp
@@ -0,0 +1,37 @@
+--- src/FileSystem.cpp.orig Wed Jan 3 21:57:08 2007
++++ src/FileSystem.cpp Thu Jan 4 16:43:02 2007
+@@ -28,7 +28,9 @@
+ #ifndef WIN32
+ #include <stdlib.h>
+ #include <stdio.h>
+-#include <sys/sendfile.h>
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <sys/uio.h>
+ #include <fcntl.h>
+ #include <regex.h>
+ #include <errno.h>
+@@ -258,7 +260,11 @@
+ int out_fd = ::open(theDestFullName, O_WRONLY|O_CREAT|O_TRUNC, statbuf.st_mode);
+ if(out_fd<0)
+ throw FileSystemException();
++#ifdef __FreeBSD__
++ sendfile(in_fd, out_fd, 0, statbuf.st_size, NULL, NULL, 0);
++#else
+ sendfile(out_fd, in_fd, 0, statbuf.st_size);
++#endif
+ ::close(out_fd);
+ ::close(in_fd);
+ #endif
+@@ -321,7 +327,11 @@
+ Directory* ret=new Directory(path);
+ ret->search();
+ #else
++#ifdef __FreeBSD__
++ char* ptr = getcwd (NULL, PATH_MAX);
++#else
+ char* ptr=get_current_dir_name();
++#endif
+ TRACE("Current directory=" << ptr)
+ Directory* ret=new Directory(ptr);
+ ret->search();
diff --git a/devel/mq4cpp/files/patch-src_Thread.cpp b/devel/mq4cpp/files/patch-src_Thread.cpp
new file mode 100644
index 000000000000..3c845af68499
--- /dev/null
+++ b/devel/mq4cpp/files/patch-src_Thread.cpp
@@ -0,0 +1,11 @@
+--- src/Thread.cpp.orig Thu Jan 4 12:31:04 2007
++++ src/Thread.cpp Thu Jan 4 12:31:22 2007
+@@ -76,7 +76,7 @@
+ #ifdef WIN32
+ return GetCurrentThreadId();
+ #else
+- return pthread_self();
++ return (unsigned long)pthread_self();
+ #endif
+ }
+
diff --git a/devel/mq4cpp/pkg-descr b/devel/mq4cpp/pkg-descr
new file mode 100644
index 000000000000..824416af3818
--- /dev/null
+++ b/devel/mq4cpp/pkg-descr
@@ -0,0 +1,5 @@
+MQ4CPP, or "Message Queuing for C++", is an open source implementation of
+enterprise messaging system, also referred to as message-oriented
+middleware (MOM).
+
+WWW: http://www.sixtyfourbit.org/mq4cpp.htm
diff --git a/devel/mq4cpp/pkg-plist b/devel/mq4cpp/pkg-plist
new file mode 100644
index 000000000000..4ee268def86c
--- /dev/null
+++ b/devel/mq4cpp/pkg-plist
@@ -0,0 +1,41 @@
+include/mq4cpp/Compression.h
+include/mq4cpp/Encription.h
+include/mq4cpp/Exception.h
+include/mq4cpp/FileSystem.h
+include/mq4cpp/FileTransfer.h
+include/mq4cpp/GarbageCollector.h
+include/mq4cpp/GeneralHashFunctions.h
+include/mq4cpp/LinkedList.h
+include/mq4cpp/LockManager.h
+include/mq4cpp/Logger.h
+include/mq4cpp/MemoryChannel.h
+include/mq4cpp/MergeSort.h
+include/mq4cpp/MessageProxy.h
+include/mq4cpp/MessageQueue.h
+include/mq4cpp/Properties.h
+include/mq4cpp/Registry.h
+include/mq4cpp/RequestReply.h
+include/mq4cpp/Router.h
+include/mq4cpp/Session.h
+include/mq4cpp/Socket.h
+include/mq4cpp/StoreForward.h
+include/mq4cpp/Thread.h
+include/mq4cpp/Timer.h
+include/mq4cpp/Trace.h
+include/mq4cpp/Vector.h
+include/mq4cpp/rijndael.h
+lib/libmq4cpp.a
+lib/libmq4cpp.la
+lib/libmq4cpp.so
+lib/libmq4cpp.so.1
+libdata/pkgconfig/mq4cpp.pc
+%%DOCSDIR%%/AUTHORS
+%%DOCSDIR%%/ChangeLog
+%%DOCSDIR%%/COPYING
+%%DOCSDIR%%/INSTALL
+%%DOCSDIR%%/NEWS
+%%DOCSDIR%%/README
+%%DOCSDIR%%/LICENSE
+%%DOCSDIR%%/TODO
+@dirrm %%DOCSDIR%%
+@dirrm include/mq4cpp