aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ndesk-dbus
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-03-24 11:52:36 +0800
committermarcus <marcus@FreeBSD.org>2008-03-24 11:52:36 +0800
commit7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3 (patch)
tree862f96db414616c771eb64412d27d795591004f0 /devel/ndesk-dbus
parent6c3349d5db64bb9ea320c30d23ba353e2f013754 (diff)
downloadfreebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.tar.gz
freebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.tar.zst
freebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.zip
The FreeBSD GNOME team is proud to annunce the release of GNOME 2.22.0 for
FreeBSD. The official GNOME 2.22 release notes can be found at http://library.gnome.org/misc/release-notes/2.22/ . On the FreeBSD front, this release features an updated hal port with support for video4linux devices, DRM (Direct Rendering), and better support of removable media. Work is also underway to tie webkit more closely into GNOME. As part of the GNOME 2.22 upgrade, GStreamer received a rather large upgrade as well. Be sure to consult UPDATING on the proper steps to upgrade all of your GNOME ports. This release would not have been possible without the contributions and testing efforts of the following people: Pawel Worach kan edwin Peter Ulrich Kruppa J. W. Ballantine Yasuda Keisuke Andriy Gapon
Diffstat (limited to 'devel/ndesk-dbus')
-rw-r--r--devel/ndesk-dbus/Makefile35
-rw-r--r--devel/ndesk-dbus/distinfo3
-rw-r--r--devel/ndesk-dbus/pkg-descr8
-rw-r--r--devel/ndesk-dbus/pkg-plist11
4 files changed, 57 insertions, 0 deletions
diff --git a/devel/ndesk-dbus/Makefile b/devel/ndesk-dbus/Makefile
new file mode 100644
index 000000000000..0b5b085c7466
--- /dev/null
+++ b/devel/ndesk-dbus/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ndesk-dbus
+# Date created: 14 January 2008
+# Whom: FreeBSD GNOME Team <gnome@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/devel/ndesk-dbus/Makefile,v 1.2 2008/01/14 22:35:41 mezz Exp $
+#
+
+PORTNAME= ndesk-dbus
+PORTVERSION= 0.6.0
+CATEGORIES= devel
+MASTER_SITES= http://www.ndesk.org/archive/ndesk-dbus/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A C\# implementation of D-Bus
+
+BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
+RUN_DEPENDS= mono:${PORTSDIR}/lang/mono
+
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnometarget
+GNU_CONFIGURE= yes
+
+DOCS= AUTHORS COPYING README
+
+.ifndef (NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
+.include <bsd.port.mk>
diff --git a/devel/ndesk-dbus/distinfo b/devel/ndesk-dbus/distinfo
new file mode 100644
index 000000000000..fe9c62ff8519
--- /dev/null
+++ b/devel/ndesk-dbus/distinfo
@@ -0,0 +1,3 @@
+MD5 (ndesk-dbus-0.6.0.tar.gz) = 5157ba105c9ac491f6e900bc78d1791f
+SHA256 (ndesk-dbus-0.6.0.tar.gz) = 252322f18e906ba7e64cecd0baec08d1a0109206777a5507a713e12def126424
+SIZE (ndesk-dbus-0.6.0.tar.gz) = 122303
diff --git a/devel/ndesk-dbus/pkg-descr b/devel/ndesk-dbus/pkg-descr
new file mode 100644
index 000000000000..dbc41441dacd
--- /dev/null
+++ b/devel/ndesk-dbus/pkg-descr
@@ -0,0 +1,8 @@
+This is a C# implementation of D-Bus. It's often referred to as "managed
+D-Bus" to avoid confusion with existing bindings (which wrap libdbus).
+
+D-Bus is an inter-process communication framework that lets applications
+interface with the system event bus as well as allowing them to talk to
+one another in a peer-to-peer configuration.
+
+WWW: http://www.ndesk.org/DBusSharp
diff --git a/devel/ndesk-dbus/pkg-plist b/devel/ndesk-dbus/pkg-plist
new file mode 100644
index 000000000000..43615a4a2abf
--- /dev/null
+++ b/devel/ndesk-dbus/pkg-plist
@@ -0,0 +1,11 @@
+lib/mono/gac/NDesk.DBus/1.0.0.0__f6716e4f9b2ed099/NDesk.DBus.dll
+lib/mono/gac/NDesk.DBus/1.0.0.0__f6716e4f9b2ed099/NDesk.DBus.dll.mdb
+lib/mono/ndesk-dbus-1.0/NDesk.DBus.dll
+libdata/pkgconfig/ndesk-dbus-1.0.pc
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm lib/mono/ndesk-dbus-1.0
+@dirrm lib/mono/gac/NDesk.DBus/1.0.0.0__f6716e4f9b2ed099
+@dirrm lib/mono/gac/NDesk.DBus