aboutsummaryrefslogtreecommitdiffstats
path: root/devel/newt/Makefile
diff options
context:
space:
mode:
authorimura <imura@FreeBSD.org>2000-02-13 09:57:46 +0800
committerimura <imura@FreeBSD.org>2000-02-13 09:57:46 +0800
commitf02825a0b6b1292b8ddc62bdae2d48189bf3958e (patch)
treedd19448435c4d0d64a4506ae24414c9619566abb /devel/newt/Makefile
parent25ec55d2776d166d69c1865c2b9b195ff7db1468 (diff)
downloadfreebsd-ports-gnome-f02825a0b6b1292b8ddc62bdae2d48189bf3958e.tar.gz
freebsd-ports-gnome-f02825a0b6b1292b8ddc62bdae2d48189bf3958e.tar.zst
freebsd-ports-gnome-f02825a0b6b1292b8ddc62bdae2d48189bf3958e.zip
Initial import of newt-0.50-13.
It is a Console I/O handling library from Redhat similar to ncurses. PR: 16526 Submitted by: Will Andrews <andrews@technologist.com>
Diffstat (limited to 'devel/newt/Makefile')
-rw-r--r--devel/newt/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/devel/newt/Makefile b/devel/newt/Makefile
new file mode 100644
index 000000000000..68f1a8d45e72
--- /dev/null
+++ b/devel/newt/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: newt
+# Version required: 0.50-13
+# Date created: 08 Jan 2000
+# Whom: Will Andrews <andrews@technologist.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= newt-0.50-13
+PKGNAME= newt-0.50.13
+CATEGORIES= devel
+MASTER_SITES= \
+ ftp://ftp.cdrom.com/pub/linux/redhat/redhat-6.1/SRPMS/SRPMS/ \
+ ftp://ftp.redhat.com/pub/redhat/redhat-6.1/SRPMS/SRPMS/ \
+ ftp://ftp.infomagic.com/pub/mirrors/linux/RedHat/redhat-6.1/SRPMS/SRPMS/
+EXTRACT_SUFX= .src.rpm
+
+MAINTAINER= andrews@technologist.com
+
+LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang
+BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/misc/rpm \
+ python:${PORTSDIR}/lang/python \
+ ${LOCALBASE}/include/popt.h:${PORTSDIR}/devel/popt
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/newt-0.50
+VERSION= 0
+MAKE_ENV+= prefix=${PREFIX} VERSION=${VERSION} CC=${CC} PCFLAGS="${CFLAGS}"
+PLIST_SUB+= VERSION="${VERSION}"
+CPIO?= /usr/bin/cpio
+
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ @${LOCALBASE}/bin/rpm2cpio ${_DISTDIR}${DISTFILES} | (cd ${WRKDIR};${CPIO} -i)
+ @${TAR} xfz ${WRKSRC}.tar.gz -C ${WRKDIR}
+
+.include <bsd.port.mk>