aboutsummaryrefslogtreecommitdiffstats
path: root/devel/newt
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2006-10-09 20:11:00 +0800
committerperky <perky@FreeBSD.org>2006-10-09 20:11:00 +0800
commit07c980f29763406a2ac30a11d7ba825c35456fe3 (patch)
tree523f3c1573a5e67b168055169a6d90bde5fb42cc /devel/newt
parentc633019bc19f7954bc7e446f8a70696d51219b96 (diff)
downloadfreebsd-ports-gnome-07c980f29763406a2ac30a11d7ba825c35456fe3.tar.gz
freebsd-ports-gnome-07c980f29763406a2ac30a11d7ba825c35456fe3.tar.zst
freebsd-ports-gnome-07c980f29763406a2ac30a11d7ba825c35456fe3.zip
Fix build with WITH_PYTHON=yes on amd64
PR: 86283 Submitted by: Tim Middleton <x@vex.net>
Diffstat (limited to 'devel/newt')
-rw-r--r--devel/newt/Makefile1
-rw-r--r--devel/newt/files/setup.py2
2 files changed, 2 insertions, 1 deletions
diff --git a/devel/newt/Makefile b/devel/newt/Makefile
index 2071bca13aca..2ee4badb3856 100644
--- a/devel/newt/Makefile
+++ b/devel/newt/Makefile
@@ -65,6 +65,7 @@ post-patch:
.if defined(WITH_PYTHON)
post-build:
+ @${LN} -sf ${WRKSRC}/libnewt.so.${SOVERSION} ${WRKSRC}/libnewt.so
@cd ${WRKSRC} && ${MAKE_ENV} ${PYTHON_CMD} ${FILESDIR}/setup.py build
post-install:
diff --git a/devel/newt/files/setup.py b/devel/newt/files/setup.py
index 3d08df5e3ec7..6c5e3fe1f5b4 100644
--- a/devel/newt/files/setup.py
+++ b/devel/newt/files/setup.py
@@ -10,7 +10,7 @@ setup ( name = 'newt',
description = 'Python interface to Newt module',
py_modules = ['snack'],
ext_modules = [ Extension(
- name='_snack',
+ name='_snack',
sources=['snackmodule.c'],
include_dirs=['.', LOCALBASE+'/include', PREFIX+'/include'],
library_dirs=['.', LOCALBASE+'/lib', PREFIX+'/lib'],