aboutsummaryrefslogtreecommitdiffstats
path: root/devel/oaf/Makefile
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-06-02 04:16:24 +0800
committerade <ade@FreeBSD.org>2000-06-02 04:16:24 +0800
commitf5e819f9845dc4bdf5a1e5a681d74779a2333a48 (patch)
tree027b701969133dc027bf737dfbe6e4292928a186 /devel/oaf/Makefile
parentf48cc5149d8db0cad7e5c5eea97e43faa33efc9c (diff)
downloadfreebsd-ports-gnome-f5e819f9845dc4bdf5a1e5a681d74779a2333a48.tar.gz
freebsd-ports-gnome-f5e819f9845dc4bdf5a1e5a681d74779a2333a48.tar.zst
freebsd-ports-gnome-f5e819f9845dc4bdf5a1e5a681d74779a2333a48.zip
OAF is the Object Activation Framework, a much more powerful replacement
for gnorba in the GNOME 2.0 development platform.
Diffstat (limited to 'devel/oaf/Makefile')
-rw-r--r--devel/oaf/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/oaf/Makefile b/devel/oaf/Makefile
new file mode 100644
index 000000000000..5cf39398d680
--- /dev/null
+++ b/devel/oaf/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: oaf
+# Date created: 1st June 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oaf
+PORTVERSION= 0.3.0
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/oaf
+
+MAINTAINER= ade@FreeBSD.org
+
+LIB_DEPENDS= glib12.3:${PORTSDIR}/devel/glib12 \
+ ORBit.2:${PORTSDIR}/devel/ORBit \
+ popt.0:${PORTSDIR}/devel/popt
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --enable-static --enable-shared
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>