aboutsummaryrefslogtreecommitdiffstats
path: root/devel/obby
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-10-26 18:55:27 +0800
committergarga <garga@FreeBSD.org>2005-10-26 18:55:27 +0800
commit8fcdec724dd536d2f23872dc4fb77d821f9cb5a5 (patch)
tree6d2f4de0617c64344534fbc7fac05ec3d0ca594d /devel/obby
parentd494e793fd7623d6ce6ed1a1266eb7d12b7eb531 (diff)
downloadfreebsd-ports-gnome-8fcdec724dd536d2f23872dc4fb77d821f9cb5a5.tar.gz
freebsd-ports-gnome-8fcdec724dd536d2f23872dc4fb77d821f9cb5a5.tar.zst
freebsd-ports-gnome-8fcdec724dd536d2f23872dc4fb77d821f9cb5a5.zip
libobby is a library which provides synced document buffers. It supports
multiple documents in one session and is portable to both Windows and Unix-like platforms. WWW: http://gobby.0x539.de PR: ports/87687 Submitted by: Andreas Kohn <andreas@syndrom23.de>
Diffstat (limited to 'devel/obby')
-rw-r--r--devel/obby/Makefile45
-rw-r--r--devel/obby/distinfo2
-rw-r--r--devel/obby/pkg-descr5
-rw-r--r--devel/obby/pkg-plist37
4 files changed, 89 insertions, 0 deletions
diff --git a/devel/obby/Makefile b/devel/obby/Makefile
new file mode 100644
index 000000000000..67a00faf9f5a
--- /dev/null
+++ b/devel/obby/Makefile
@@ -0,0 +1,45 @@
+# Ports collection makefile for: obby
+# Date created: 2005-10-14
+# Whom: Andreas Kohn <andreas@syndrom23.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= obby
+PORTVERSION= 0.2.1
+CATEGORIES= devel
+MASTER_SITES= http://releases.0x539.de/obby/
+
+MAINTAINER= andreas@syndrom23.de
+COMMENT= A library for synced document buffers
+
+LIB_DEPENDS= sigc++-2.0.0:${PORTSDIR}/devel/libsigc++20 \
+ gmp.6:${PORTSDIR}/math/libgmp4 \
+ net6:${PORTSDIR}/net/net6
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libgmp-prefix=${LOCALBASE} --without-howl
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER= 15
+
+.if !defined(WITHOUT_NLS)
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} 's,^pkgconfigdir = .*,pkgconfigdir=$$(prefix)/libdata/pkgconfig,' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= "Some dependencies does not run on FreeBSD \< 5.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/obby/distinfo b/devel/obby/distinfo
new file mode 100644
index 000000000000..52d9baf74042
--- /dev/null
+++ b/devel/obby/distinfo
@@ -0,0 +1,2 @@
+MD5 (obby-0.2.1.tar.gz) = 5e28bfbf6e72b007aa6d055594754810
+SIZE (obby-0.2.1.tar.gz) = 404106
diff --git a/devel/obby/pkg-descr b/devel/obby/pkg-descr
new file mode 100644
index 000000000000..9d6faf5fcc1b
--- /dev/null
+++ b/devel/obby/pkg-descr
@@ -0,0 +1,5 @@
+libobby is a library which provides synced document buffers. It supports
+multiple documents in one session and is portable to both Windows and
+Unix-like platforms.
+
+WWW: http://gobby.0x539.de
diff --git a/devel/obby/pkg-plist b/devel/obby/pkg-plist
new file mode 100644
index 000000000000..26f7f8925eeb
--- /dev/null
+++ b/devel/obby/pkg-plist
@@ -0,0 +1,37 @@
+include/obby/buffer.hpp
+include/obby/client_buffer.hpp
+include/obby/client_document.hpp
+include/obby/client_document_info.hpp
+include/obby/common.hpp
+include/obby/delete_record.hpp
+include/obby/document.hpp
+include/obby/document_info.hpp
+include/obby/duplex_signal.hpp
+include/obby/error.hpp
+include/obby/format_string.hpp
+include/obby/host_buffer.hpp
+include/obby/host_document.hpp
+include/obby/host_document_info.hpp
+include/obby/insert_record.hpp
+include/obby/line.hpp
+include/obby/local_buffer.hpp
+include/obby/local_document.hpp
+include/obby/local_document_info.hpp
+include/obby/position.hpp
+include/obby/ptr_iterator.hpp
+include/obby/record.hpp
+include/obby/rsa.hpp
+include/obby/server_buffer.hpp
+include/obby/server_document.hpp
+include/obby/server_document_info.hpp
+include/obby/sha1.hpp
+include/obby/user.hpp
+include/obby/user_table.hpp
+lib/libobby-0.2.so
+lib/libobby-0.2.so.0
+lib/libobby.a
+lib/libobby.so
+libdata/pkgconfig/obby-0.2.pc
+%%NLS%%share/locale/de/LC_MESSAGES/obby.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/obby.mo
+@dirrm include/obby