aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ode
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-11-25 07:53:00 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-11-25 07:53:00 +0800
commit21d5209d4ac2944ab958142c0e94e17c60e16e04 (patch)
treec74410e0bf58afca650b0c2ee8ee952adffd3b4e /devel/ode
parent67d8ec51c8e190167d218077462e66500b90ef0d (diff)
downloadfreebsd-ports-gnome-21d5209d4ac2944ab958142c0e94e17c60e16e04.tar.gz
freebsd-ports-gnome-21d5209d4ac2944ab958142c0e94e17c60e16e04.tar.zst
freebsd-ports-gnome-21d5209d4ac2944ab958142c0e94e17c60e16e04.zip
- Update devel/ode to 0.13
- Bump dependent ports PR: 193086 Submitted by: pfg Approved by: maintainer timeout (acm, almost 3 months)
Diffstat (limited to 'devel/ode')
-rw-r--r--devel/ode/Makefile15
-rw-r--r--devel/ode/distinfo4
-rw-r--r--devel/ode/pkg-plist4
3 files changed, 12 insertions, 11 deletions
diff --git a/devel/ode/Makefile b/devel/ode/Makefile
index 6e4c7ef494c5..f7e18479509a 100644
--- a/devel/ode/Makefile
+++ b/devel/ode/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ode
-PORTVERSION= 0.11.1
+PORTVERSION= 0.13
PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= devel
@@ -18,17 +18,14 @@ USES= tar:bzip2 gmake libtool
USE_GL= yes
GNU_CONFIGURE= yes
-OPTIONS_DEFINE= GIMPACT GYROSCOPIC DOUBLE OU
-OPTIONS_DEFAULT= GYROSCOPIC
+OPTIONS_DEFINE= GIMPACT DOUBLE OU
GIMPACT_DESC= Enable gimpact instead of opcode support
-GYROSCOPIC_DESC= Configure ODE to work with gyroscopic term
DOUBLE_DESC= Enable double precision (BROKEN with GIMPACT)
OU_DESC= Enable Thread-local storage (Experimental)
GIMPACT_CONFIGURE_ON= --with-trimesh=gimpact
GIMPACT_CONFIGURE_OFF= --with-trimesh=opcode
-GYROSCOPIC_CONFIGURE_ENABLE= gyroscopic
DOUBLE_CONFIGURE_ENABLE= double-precision
OU_CONFIGURE_ENABLE= ou
@@ -49,17 +46,17 @@ post-patch:
-e 's|^\( *CPPFLAGS=\)|#\1|' -e 's|^\( *CXXFLAGS=\)|#\1|' \
-e 's|CPPFLAGS+=" |CPPFLAGS="$$CPPFLAGS |' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|__isnanf||g; s|__isnan||g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e '/^traplib_PROGRAMS / d' ${WRKSRC}/ode/src/Makefile.in
@${FIND} ${WRKSRC} -type f -name Makefile.in -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
-e '/^DEFAULT_INCLUDES/ s|$$| -I$$(top_builddir)/include|' \
-e '/CFLAGS/ s|-O[12]||'
@${FIND} ${WRKSRC} -type f -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
- -i "" -e 's|malloc.h|stdlib.h|g'
+ -i "" -e 's|<malloc.h>|<stdlib.h>|g'
post-install:
${SED} -e '/PACKAGE/ s|^|//|; /VERSION/ s|^|//|' ${WRKSRC}/ode/src/config.h \
> ${STAGEDIR}${PREFIX}/include/ode/config.h
+regression-test: build
+ @(cd ${WRKSRC} && ${MAKE} check)
+
.include <bsd.port.post.mk>
diff --git a/devel/ode/distinfo b/devel/ode/distinfo
index 507fceb7d94a..4679824956d8 100644
--- a/devel/ode/distinfo
+++ b/devel/ode/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ode-0.11.1.tar.bz2) = 877884a86a3d53f3c5f2e35fbd8a3dc23c20249f0636c76f6ef41f6bf57a03a1
-SIZE (ode-0.11.1.tar.bz2) = 1720088
+SHA256 (ode-0.13.tar.bz2) = 34ce3e236e313bf109a0cb5546d2fca462aed99f29a42e62bc1463b803c31ef9
+SIZE (ode-0.13.tar.bz2) = 2008288
diff --git a/devel/ode/pkg-plist b/devel/ode/pkg-plist
index 3d5288580c1b..50cab3525c56 100644
--- a/devel/ode/pkg-plist
+++ b/devel/ode/pkg-plist
@@ -19,7 +19,11 @@ include/ode/odecpp.h
include/ode/odecpp_collision.h
include/ode/odeinit.h
include/ode/odemath.h
+include/ode/odemath_legacy.h
+include/ode/precision.h
include/ode/rotation.h
+include/ode/threading.h
+include/ode/threading_impl.h
include/ode/timer.h
lib/libode.a
libdata/pkgconfig/ode.pc