aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ode
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-12 07:02:23 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-12 07:02:23 +0800
commit71febdd5ae69353c30adae64354cd6b85a2b80d4 (patch)
treeb0d0180e6e7ba6ba967313965e23f1a1fb29ecd8 /devel/ode
parent43f78cd9cd068573aa09818a919dba075b75905a (diff)
downloadfreebsd-ports-gnome-71febdd5ae69353c30adae64354cd6b85a2b80d4.tar.gz
freebsd-ports-gnome-71febdd5ae69353c30adae64354cd6b85a2b80d4.tar.zst
freebsd-ports-gnome-71febdd5ae69353c30adae64354cd6b85a2b80d4.zip
- Support staging
- Convert USE_BZIP2 to USES - Convert USE_GMAKE to USES - Add USES=libtool, drop .la file - Add LICENSE - Use new OPTIONS features - Fix checking for illegal options combination PR: 189438 Submitted by: amdmi3 Approved by: portmgr blanket
Diffstat (limited to 'devel/ode')
-rw-r--r--devel/ode/Makefile45
-rw-r--r--devel/ode/pkg-plist1
2 files changed, 16 insertions, 30 deletions
diff --git a/devel/ode/Makefile b/devel/ode/Makefile
index 298a5353885f..def0e9579986 100644
--- a/devel/ode/Makefile
+++ b/devel/ode/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ode
PORTVERSION= 0.11.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= SF/opende/ODE/${PORTVERSION}
@@ -10,53 +11,39 @@ MASTER_SITES= SF/opende/ODE/${PORTVERSION}
MAINTAINER= acm@FreeBSD.org
COMMENT= Articulated rigid body dynamics library
+LICENSE= LGPL21 BSD3CLAUSE
+LICENSE_COMB= dual
+
CONFLICTS= ode-devel-[0-9].*
-USE_BZIP2= yes
+USES= tar:bzip2 gmake libtool
USE_GL= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-
-OPTIONS_DEFINE= GIMPACT GYROSCOPIC DOUBLE OU
+OPTIONS_DEFINE= GIMPACT GYROSCOPIC DOUBLE OU
OPTIONS_DEFAULT= GYROSCOPIC
+
GIMPACT_DESC= Enable gimpact instead of opcode support
GYROSCOPIC_DESC= Configure ODE to work with gyroscopic term
DOUBLE_DESC= Enable double precision (BROKEN with GIMPACT)
OU_DESC= Enable Thread-local storage (Experimental)
+GIMPACT_CONFIGURE_ON= --with-trimesh=gimpact
+GIMPACT_CONFIGURE_OFF= --with-trimesh=opcode
+GYROSCOPIC_CONFIGURE_ENABLE= gyroscopic
+DOUBLE_CONFIGURE_ENABLE= double-precision
+OU_CONFIGURE_ENABLE= ou
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
CFLAGS+= -fPIC -DPIC
.endif
-.if ${PORT_OPTIONS:MGIMPACT} && defined(WITH_DOUBLE)
-IGNORE= currently double precision is not supported by gimpact
-.endif
-
-.if ! ${PORT_OPTIONS:MGIMPACT}
-CONFIGURE_ARGS+= --with-trimesh=opcode
-.else
-CONFIGURE_ARGS+= --with-trimesh=gimpact
-.endif
-
-.if ! ${PORT_OPTIONS:MGYROSCOPIC}
-CONFIGURE_ARGS+= --disable-gyroscopic
-.endif
-
-.if ${PORT_OPTIONS:MDOUBLE}
-CONFIGURE_ARGS+= --enable-double-precision
-.endif
-
-.if ${PORT_OPTIONS:MOU}
-CONFIGURE_ARGS+= --enable-ou
-.else
-CONFIGURE_ARGS+= --disable-ou
+.if ${PORT_OPTIONS:MGIMPACT} && ${PORT_OPTIONS:MDOUBLE}
+IGNORE= currently double precision is not supported by gimpact
.endif
post-patch:
@@ -75,6 +62,6 @@ post-patch:
post-install:
${SED} -e '/PACKAGE/ s|^|//|; /VERSION/ s|^|//|' ${WRKSRC}/ode/src/config.h \
- > ${PREFIX}/include/ode/config.h
+ > ${STAGEDIR}${PREFIX}/include/ode/config.h
.include <bsd.port.post.mk>
diff --git a/devel/ode/pkg-plist b/devel/ode/pkg-plist
index 11a2b9a48d9c..2617c4f9a3af 100644
--- a/devel/ode/pkg-plist
+++ b/devel/ode/pkg-plist
@@ -22,6 +22,5 @@ include/ode/odemath.h
include/ode/rotation.h
include/ode/timer.h
lib/libode.a
-lib/libode.la
libdata/pkgconfig/ode.pc
@dirrm include/ode