aboutsummaryrefslogtreecommitdiffstats
path: root/devel/oniguruma4/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2003-02-04 17:39:50 +0800
committerknu <knu@FreeBSD.org>2003-02-04 17:39:50 +0800
commit15615499c4ea32931f64e636af3f9c0eb98efd09 (patch)
tree4db43a16e39c7099f5bba1964f116877e1e996fc /devel/oniguruma4/Makefile
parent4e86309855cf0555e8e1ddd8193c1d5d28f9aa0c (diff)
downloadfreebsd-ports-gnome-15615499c4ea32931f64e636af3f9c0eb98efd09.tar.gz
freebsd-ports-gnome-15615499c4ea32931f64e636af3f9c0eb98efd09.tar.zst
freebsd-ports-gnome-15615499c4ea32931f64e636af3f9c0eb98efd09.zip
Update to 1.7 (20030204), with improved performance.
According to the author's post on a mailing list, a simple benchmark shows that Oniguruma is 10-20% faster than PCRE 3.9 under the ASCII (single byte) encoding.
Diffstat (limited to 'devel/oniguruma4/Makefile')
-rw-r--r--devel/oniguruma4/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/devel/oniguruma4/Makefile b/devel/oniguruma4/Makefile
index 8d37fd530b1c..74751a0adf78 100644
--- a/devel/oniguruma4/Makefile
+++ b/devel/oniguruma4/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= oniguruma
-PORTVERSION= 1.6
+PORTVERSION= 1.7
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_RUBY}
MASTER_SITE_SUBDIR= contrib
-DISTNAME= onigd20030121
+DISTNAME= onigd20030204
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
@@ -21,6 +21,8 @@ MAKEFILE= BSDmakefile
MAKE_ARGS= NOPROFILE=true
INSTALLS_SHLIB= yes
+DOCS= README doc/*
+
pre-build:
${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}/
@@ -29,7 +31,9 @@ post-install:
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/sample/* ${EXAMPLESDIR}/
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
.endif
.include <bsd.port.mk>