aboutsummaryrefslogtreecommitdiffstats
path: root/devel/oniguruma4/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2003-01-31 21:03:50 +0800
committerknu <knu@FreeBSD.org>2003-01-31 21:03:50 +0800
commit9672179d445d40ea76c860e80ce7720b64366535 (patch)
treeb3f8fd3caa6106b9336b6c7ebd8fd134495734e5 /devel/oniguruma4/Makefile
parent8edf0609ab06a1afdfffdf207856fad2dcb7a29d (diff)
downloadfreebsd-ports-gnome-9672179d445d40ea76c860e80ce7720b64366535.tar.gz
freebsd-ports-gnome-9672179d445d40ea76c860e80ce7720b64366535.tar.zst
freebsd-ports-gnome-9672179d445d40ea76c860e80ce7720b64366535.zip
Add devel/oniguruma.
Oniguruma is a BSDL Regular Expression library written for ruby-m17n, which implements all of Perl extensions plus more. It has multiple APIs; GNU regex, POSIX regex and its own interface. This library is fundamentally multilingualized and can have one encoding for each object. Currently supported character encodings are ASCII, UTF-8, EUC-JP and Shift_JIS. Author: K.Kosako <kosako@sofnec.co.jp> WWW: http://www.ruby-lang.org/cgi-bin/cvsweb.cgi/oniguruma/
Diffstat (limited to 'devel/oniguruma4/Makefile')
-rw-r--r--devel/oniguruma4/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/oniguruma4/Makefile b/devel/oniguruma4/Makefile
new file mode 100644
index 000000000000..8d37fd530b1c
--- /dev/null
+++ b/devel/oniguruma4/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Oniguruma
+# Date created: 31 January 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oniguruma
+PORTVERSION= 1.6
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_RUBY}
+MASTER_SITE_SUBDIR= contrib
+DISTNAME= onigd20030121
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+GNU_CONFIGURE= yes
+MAKEFILE= BSDmakefile
+MAKE_ARGS= NOPROFILE=true
+INSTALLS_SHLIB= yes
+
+pre-build:
+ ${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}/
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample/* ${EXAMPLESDIR}/
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>