aboutsummaryrefslogtreecommitdiffstats
path: root/devel/openthreads/Makefile
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2006-11-01 06:23:27 +0800
committerlawrance <lawrance@FreeBSD.org>2006-11-01 06:23:27 +0800
commitef9ccaf390e82e658368266507f9d2037a66dfea (patch)
tree0aab1caa8b7cbf81a435a90a456cb8ca5b562e3f /devel/openthreads/Makefile
parent8e0ff99d446f4556934d988e409d09f25b3beac8 (diff)
downloadfreebsd-ports-gnome-ef9ccaf390e82e658368266507f9d2037a66dfea.tar.gz
freebsd-ports-gnome-ef9ccaf390e82e658368266507f9d2037a66dfea.tar.zst
freebsd-ports-gnome-ef9ccaf390e82e658368266507f9d2037a66dfea.zip
Update to 1.4.2.
PR: ports/94998 Submitted by: Matthew May <rrghphar@bigpond.net.au> Approved by: Ying-Chieh Chen <yinjieh@csie.nctu.edu.tw> (maintainer)
Diffstat (limited to 'devel/openthreads/Makefile')
-rw-r--r--devel/openthreads/Makefile36
1 files changed, 18 insertions, 18 deletions
diff --git a/devel/openthreads/Makefile b/devel/openthreads/Makefile
index 2faf60d4290d..d5e85168a8d9 100644
--- a/devel/openthreads/Makefile
+++ b/devel/openthreads/Makefile
@@ -6,31 +6,31 @@
#
PORTNAME= openthreads
-PORTVERSION= 1.2d3
-PORTREVISION= 1
+PORTVERSION= 1.4.2
CATEGORIES= devel
-MASTER_SITES= http://www.csie.nctu.edu.tw/~yinjieh/
-DISTNAME= OpenThreads-v1.2dev3-osg0.9.6
+MASTER_SITES= http://www.openscenegraph.org/downloads/snapshots/
+#
+# the following master distribution contains the version of OpenThreads
+# as described above by PORTVERSION and PORTREVISION.
+DISTNAME= OSG_OP_OT-1.0
MAINTAINER= yinjieh@csie.nctu.edu.tw
COMMENT= A library which provides OO thread interface for C++ programmers
+USE_ZIP= yes
USE_GMAKE= yes
-MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/${DISTNAME}
MAKEFILE= GNUmakefile
-
-# opt = optimized ($OPTF added); debug = debug ($DBGF added); opt is default
+WRKSRC= ${WRKDIR}/${DISTNAME}/OpenThreads
+MAKE_ENV+= FREEBSD_ARCH="${ARCH}" PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+# Optimisation/Debug flags:
+# opt = optimised ($OPTF added)
+# debug = debug ($DBGF added)
+# opt is default
+#
ALL_TARGET= opt
-.include <bsd.port.pre.mk>
-
-post-patch:
- @${REINPLACE_CMD} -e 's,%%CXXFLAGS%%,${CXXFLAGS},g' \
- ${WRKSRC}/Make/makedefs
- @${FIND} ${WRKSRC} -name '*.o' -delete
- @${FIND} ${WRKSRC} -name '*.so' -delete
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>