aboutsummaryrefslogtreecommitdiffstats
path: root/devel/orc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-02-14 20:41:41 +0800
committermiwi <miwi@FreeBSD.org>2014-02-14 20:41:41 +0800
commitf97760ef06cf6f77f0c26325f52b97ac1863e840 (patch)
treebd7eb8b224de673d590721fb81f96481900a66fb /devel/orc
parent90df3a326c749ce578d78f1ac36ff0e32a570ccf (diff)
downloadfreebsd-ports-gnome-f97760ef06cf6f77f0c26325f52b97ac1863e840.tar.gz
freebsd-ports-gnome-f97760ef06cf6f77f0c26325f52b97ac1863e840.tar.zst
freebsd-ports-gnome-f97760ef06cf6f77f0c26325f52b97ac1863e840.zip
- Stage support
With help from: antoine Approved by: kwm
Diffstat (limited to 'devel/orc')
-rw-r--r--devel/orc/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/devel/orc/Makefile b/devel/orc/Makefile
index 29fbd07bfdf3..085fa0dbb0f5 100644
--- a/devel/orc/Makefile
+++ b/devel/orc/Makefile
@@ -27,19 +27,14 @@ EXAMPLES_EXEC= example1 example2 example3 mt19937ar volscale
OPTIONS_DEFINE= DOCS EXAMPLES
DOCS_DESC= Include gtk-doc documentation
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
SUBDIRS+= doc
-.else
-NOPORTDOCS= yes
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
SUBDIRS+= examples
-.else
-NOPORTEXAMPLES= yes
.endif
MAKE_ARGS+= SUBDIRS="${SUBDIRS}"
@@ -51,14 +46,12 @@ post-patch:
${WRKSRC}/configure
post-install:
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for FILE in ${EXAMPLES_DATA}
- @${INSTALL_DATA} ${WRKSRC}/examples/${FILE} ${EXAMPLESDIR}/${FILE}
+ @${INSTALL_DATA} ${WRKSRC}/examples/${FILE} ${STAGEDIR}${EXAMPLESDIR}/${FILE}
.endfor
.for FILE in ${EXAMPLES_EXEC}
- @${INSTALL_SCRIPT} ${WRKSRC}/examples/${FILE} ${EXAMPLESDIR}/${FILE}
+ @${INSTALL_SCRIPT} ${WRKSRC}/examples/${FILE} ${STAGEDIR}${EXAMPLESDIR}/${FILE}
.endfor
-.endif
.include <bsd.port.mk>