aboutsummaryrefslogtreecommitdiffstats
path: root/devel/oskit/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-02-29 00:49:20 +0800
committerpav <pav@FreeBSD.org>2004-02-29 00:49:20 +0800
commit73e9a037f961d7b1307229d75fc0cce7342e8be3 (patch)
treea97daa4480e10003b0a04202d637190e38e95cc3 /devel/oskit/Makefile
parentf70582c92a6532152f8d20cdf601c5643c9b95b3 (diff)
downloadfreebsd-ports-gnome-73e9a037f961d7b1307229d75fc0cce7342e8be3.tar.gz
freebsd-ports-gnome-73e9a037f961d7b1307229d75fc0cce7342e8be3.tar.zst
freebsd-ports-gnome-73e9a037f961d7b1307229d75fc0cce7342e8be3.zip
The OSKit is a framework and a set of component libraries oriented
to operating systems, together with extensive documentation. PR: ports/60431 Submitted by: Jerry <unidevel@yahoo.com.cn>
Diffstat (limited to 'devel/oskit/Makefile')
-rw-r--r--devel/oskit/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/oskit/Makefile b/devel/oskit/Makefile
new file mode 100644
index 000000000000..564b4d6e1293
--- /dev/null
+++ b/devel/oskit/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: oskit
+# Date created: 25 Nov 2003
+# Whom: jerry
+#
+# $FreeBSD$
+#
+
+PORTNAME= oskit
+PORTVERSION= 20020317
+CATEGORIES= devel
+MASTER_SITES= ftp://flux.cs.utah.edu/flux/oskit/
+
+MAINTAINER= unidevel@yahoo.com.cn
+COMMENT= Framework and a set of libraries for developing operating systems
+
+BUILD_DEPENDS= gcc295:${PORTSDIR}/lang/gcc295
+RUN_DEPENDS= gcc295:${PORTSDIR}/lang/gcc295
+
+OSKITDIR= ${PORTNAME}
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS=-O2 LIBS=-lposix
+USE_GMAKE= yes
+USE_GCC= 2.95
+MAKEFILE= GNUmakefile
+STRIP=
+
+.include <bsd.port.mk>