aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p4p/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-06-10 14:22:55 +0800
committerwill <will@FreeBSD.org>2000-06-10 14:22:55 +0800
commit52b321d42477f86b0addd55ff7f141f4fcabab70 (patch)
tree52dd75abda16b062186cdf5ad13ef32d348e9da8 /devel/p4p/Makefile
parentb77b76765a00c983bd933af1305d01faa4bc6e70 (diff)
downloadfreebsd-ports-gnome-52b321d42477f86b0addd55ff7f141f4fcabab70.tar.gz
freebsd-ports-gnome-52b321d42477f86b0addd55ff7f141f4fcabab70.tar.zst
freebsd-ports-gnome-52b321d42477f86b0addd55ff7f141f4fcabab70.zip
Add perforce, a well-done commercial source code control system. The
submitter tried to bundle an elisp script with this port, but I left it out because it could just as well be put in a different port. PR: 18371 Submitted by: Samuel Tardieu <sam@inf.enst.fr>
Diffstat (limited to 'devel/p4p/Makefile')
-rw-r--r--devel/p4p/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/p4p/Makefile b/devel/p4p/Makefile
new file mode 100644
index 000000000000..3580b0038af8
--- /dev/null
+++ b/devel/p4p/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: perforce
+# Date created: 3 Mai 2000
+# Whom: sam@inf.enst.fr
+#
+# $FreeBSD$
+#
+
+PORTNAME= perforce
+PORTVERSION= 99.2
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.perforce.com/pub/perforce/r${PORTVERSION}/bin.freebsd/ \
+ http://www.dsmit.com/p4/ \
+ ftp://ftp.perforce.com/pub/perforce/r${PORTVERSION}/doc/man/
+EXTRACT_SUFX=
+DISTFILES= p4 p4d p4.1 p4d.1
+DIST_SUBDIR= perforce
+
+MAINTAINER= sam@inf.enst.fr
+
+NO_PACKAGE= Restricted distribution
+NO_CDROM= Restricted distribution
+NO_BUILD= yes
+MAN1= p4.1 p4d.1
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+
+do-install:
+ ${INSTALL_PROGRAM} ${DISTDIR}/${DIST_SUBDIR}/p4 ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${DISTDIR}/${DIST_SUBDIR}/p4d ${PREFIX}/sbin
+.for PERFMAN in p4 p4d
+ ${INSTALL_MAN} ${DISTDIR}/${DIST_SUBDIR}/${PERFMAN}.1 ${PREFIX}/man/man1
+.endfor
+
+.include <bsd.port.mk>