aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p4v
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2004-02-15 07:52:59 +0800
committerbms <bms@FreeBSD.org>2004-02-15 07:52:59 +0800
commitd35a37acd4840426927c72dd6e4c4b41f8cc5dc6 (patch)
tree60ebaf30e8e6ad152e7030ed0eec0f49097ccf4e /devel/p4v
parent88922c8210aa3a391255c3a0379ed9a3ddeedb0c (diff)
downloadfreebsd-ports-gnome-d35a37acd4840426927c72dd6e4c4b41f8cc5dc6.tar.gz
freebsd-ports-gnome-d35a37acd4840426927c72dd6e4c4b41f8cc5dc6.tar.zst
freebsd-ports-gnome-d35a37acd4840426927c72dd6e4c4b41f8cc5dc6.zip
Add a FreeBSD native version of the Perforce Visual Client (latest
beta version).
Diffstat (limited to 'devel/p4v')
-rw-r--r--devel/p4v/Makefile80
-rw-r--r--devel/p4v/distinfo.i3862
-rw-r--r--devel/p4v/pkg-descr6
-rw-r--r--devel/p4v/pkg-message9
-rw-r--r--devel/p4v/pkg-plist.i38667
5 files changed, 164 insertions, 0 deletions
diff --git a/devel/p4v/Makefile b/devel/p4v/Makefile
new file mode 100644
index 000000000000..7068a205db92
--- /dev/null
+++ b/devel/p4v/Makefile
@@ -0,0 +1,80 @@
+# New ports collection makefile for: p4v
+# Date created: 14 October 2004
+# Whom: bms@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= p4v
+PORTVERSION= 2003.2
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.perforce.com/pub/perforce/r03.2/bin.freebsd4/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Visual client for Perforce SCM
+
+NO_CDROM= yes
+RESTRICTED= "Binary redistribution restrictions in effect"
+
+ONLY_FOR_ARCHS= i386
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST= ${MASTERDIR}/pkg-plist.${MACHINE_ARCH}
+MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
+
+P4V_DOCS_DIR= P4VResources/p4vhelp
+P4V_DOCS= About_Perforce_products.html About_file_icons.html \
+ Adding_files_to_the_depot.html \
+ Changing_a_file_s_type.html \
+ Configuring_display_preferences.html \
+ Connecting_to_the_Perforce_server.html \
+ Defining_a_client_view.html Deleting_files.html \
+ Displaying_a_file_s_revision_history.html \
+ Displaying_client_specifications.html \
+ Editing_files.html Getting_more_information.html \
+ Getting_started_with_Perforce.html \
+ Integrating_files_into_codelines.html \
+ Managing_branch_specifications.html \
+ Managing_jobs.html Managing_labels.html Managing_users.html \
+ P4V_shortcuts.html Renaming_files.html Resolving_files.html \
+ Retrieving_files_from_the_depot.html The_P4V_windows.html \
+ Working_with_changelists.html ancillary_p4v_files.html \
+ diffing_files.html merging_files.html p4vindex.html
+
+P4V_IMGS_DIR= P4VResources/p4vhelp/p4images
+P4V_IMGS= p4v_file_add.png p4v_file_add_other.png p4v_file_delete.png \
+ p4v_file_delete_notsync.png p4v_file_delete_other.png \
+ p4v_file_delete_resolve.png p4v_file_deleted.png \
+ p4v_file_edit_head.png p4v_file_edit_notsync.png \
+ p4v_file_edit_other.png p4v_file_edit_other_notsyn.png \
+ p4v_file_edit_other_notsync.png p4v_file_edit_resolve.png \
+ p4v_file_edit_resolve_other_delete.png p4v_file_lock.png \
+ p4v_file_lock_other.png p4v_file_needs_resolve.png \
+ p4v_file_notmapped.png p4v_file_notsync.png \
+ p4v_file_rev_add.png p4v_file_rev_branch.png \
+ p4v_file_rev_delete.png p4v_file_rev_edit.png \
+ p4v_file_rev_have_add.png p4v_file_rev_have_branch.png \
+ p4v_file_rev_have_edit.png p4v_file_revision_integrated.png \
+ p4v_pin.png p4v_file_revsynced.png p4v_file_sync.png \
+ p4v_file_txt.png p4v_file_ws.png p4v_filter.png \
+ p4v_merge_screenshot.png p4v_diff_screenshot.png
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/p4v ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/${P4V_DOCS_DIR} ${PREFIX}/share/${P4V_IMGS_DIR}
+.for _DOCFILE in ${P4V_DOCS}
+ ${INSTALL_MAN} ${WRKSRC}/${P4V_DOCS_DIR}/${_DOCFILE} ${PREFIX}/share/${P4V_DOCS_DIR}
+.endfor
+.for _IMGFILE in ${P4V_IMGS}
+ ${INSTALL_MAN} ${WRKSRC}/${P4V_IMGS_DIR}/${_IMGFILE} ${PREFIX}/share/${P4V_IMGS_DIR}
+.endfor
+.endif
+
+post-install:
+ ${SED} -e 's!%%PREFIX%%!${PREFIX}!' ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/devel/p4v/distinfo.i386 b/devel/p4v/distinfo.i386
new file mode 100644
index 000000000000..4a0939ea2087
--- /dev/null
+++ b/devel/p4v/distinfo.i386
@@ -0,0 +1,2 @@
+MD5 (p4v.tgz) = ec305cc7a95c02bf4ce0d058033fd00e
+SIZE (p4v.tgz) = 4787102
diff --git a/devel/p4v/pkg-descr b/devel/p4v/pkg-descr
new file mode 100644
index 000000000000..8df51009ccb7
--- /dev/null
+++ b/devel/p4v/pkg-descr
@@ -0,0 +1,6 @@
+P4V, Perforce Visual Client, is a graphical user interface to
+Perforce on FreeBSD, Mac OS X and Linux. P4V provides quick and
+easy access to Perforce-managed files through a user interface
+that is consistent across OS platforms.
+
+WWW: http://www.perforce.com/perforce/products/p4v.html
diff --git a/devel/p4v/pkg-message b/devel/p4v/pkg-message
new file mode 100644
index 000000000000..860d7a28512f
--- /dev/null
+++ b/devel/p4v/pkg-message
@@ -0,0 +1,9 @@
+
+Before starting the application, set a P4VRES variable to identify the
+location of the p4v resources directory. For example:
+
+ % setenv P4VRES %%PREFIX%%/share/P4VResources
+
+The application is compiled for FreeBSD 4.4, so be sure to have appropriate
+compatibility libraries (and kernel support, if applicable) installed on
+your system.
diff --git a/devel/p4v/pkg-plist.i386 b/devel/p4v/pkg-plist.i386
new file mode 100644
index 000000000000..2267fe6fdc28
--- /dev/null
+++ b/devel/p4v/pkg-plist.i386
@@ -0,0 +1,67 @@
+bin/p4v
+%%PORTDOCS%%share/P4VResources/p4vhelp/About_Perforce_products.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/About_file_icons.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Adding_files_to_the_depot.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Changing_a_file_s_type.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Configuring_display_preferences.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Connecting_to_the_Perforce_server.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Defining_a_client_view.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Deleting_files.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Displaying_a_file_s_revision_history.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Displaying_client_specifications.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Editing_files.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Getting_more_information.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Getting_started_with_Perforce.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Integrating_files_into_codelines.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Managing_branch_specifications.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Managing_jobs.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Managing_labels.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Managing_users.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/P4V_shortcuts.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Renaming_files.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Resolving_files.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Retrieving_files_from_the_depot.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/The_P4V_windows.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/Working_with_changelists.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/ancillary_p4v_files.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/diffing_files.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/merging_files.html
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_add.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_add_other.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_delete.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_delete_notsync.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_delete_other.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_delete_resolve.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_deleted.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_edit_head.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_edit_notsync.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_edit_other.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_edit_other_notsyn.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_edit_other_notsync.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_edit_resolve.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_edit_resolve_other_delete.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_lock.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_lock_other.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_needs_resolve.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_notmapped.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_notsync.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_rev_add.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_rev_branch.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_rev_delete.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_rev_edit.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_rev_have_add.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_rev_have_branch.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_rev_have_edit.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_revision_integrated.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_pin.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_revsynced.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_sync.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_txt.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_ws.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_filter.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_merge_screenshot.png
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_diff_screenshot.png
+%%PORTDOCS%%@dirrm share/P4VResources/p4vhelp/p4images
+%%PORTDOCS%%share/P4VResources/p4vhelp/p4vindex.html
+%%PORTDOCS%%@dirrm share/P4VResources/p4vhelp
+%%PORTDOCS%%@dirrm share/P4VResources