aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-App-Cache
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-10 13:40:28 +0800
committeraaron <aaron@FreeBSD.org>2006-05-10 13:40:28 +0800
commit2d1bf9ce2026892f90be898b710fcb500a05829c (patch)
tree111c8a4f82310a5efb9f3f8f1f0e0257f6a5abd5 /devel/p5-App-Cache
parent0e48aadc5b509333793cfc742e2a2ccb84ce78df (diff)
downloadfreebsd-ports-gnome-2d1bf9ce2026892f90be898b710fcb500a05829c.tar.gz
freebsd-ports-gnome-2d1bf9ce2026892f90be898b710fcb500a05829c.tar.zst
freebsd-ports-gnome-2d1bf9ce2026892f90be898b710fcb500a05829c.zip
Adding port devel/p5-App-Cache, an Easy application-level caching library
approved by: tobez (implicit)
Diffstat (limited to 'devel/p5-App-Cache')
-rw-r--r--devel/p5-App-Cache/Makefile37
-rw-r--r--devel/p5-App-Cache/distinfo3
-rw-r--r--devel/p5-App-Cache/pkg-descr18
-rw-r--r--devel/p5-App-Cache/pkg-plist2
4 files changed, 60 insertions, 0 deletions
diff --git a/devel/p5-App-Cache/Makefile b/devel/p5-App-Cache/Makefile
new file mode 100644
index 000000000000..5d3ec8a9420d
--- /dev/null
+++ b/devel/p5-App-Cache/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-App-Cache
+# Date created: 09 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= App-Cache
+PORTVERSION= 0.31
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= App
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Easy application-level caching
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor/Chained/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor-Chained \
+ ${SITE_PERL}/File/Find/Rule.pm:${PORTSDIR}/devel/p5-File-Find-Rule \
+ ${SITE_PERL}/File/HomeDir.pm:${PORTSDIR}/devel/p5-File-HomeDir \
+ ${SITE_PERL}/HTTP/Cookies.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Path/Class.pm:${PORTSDIR}/devel/p5-Path-Class \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= App::Cache.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl5.6. Please install lang/perl5 or lang/perl5.8
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-App-Cache/distinfo b/devel/p5-App-Cache/distinfo
new file mode 100644
index 000000000000..a3e7e1d197b3
--- /dev/null
+++ b/devel/p5-App-Cache/distinfo
@@ -0,0 +1,3 @@
+MD5 (App-Cache-0.31.tar.gz) = 0f0dc2152c7065ab041ce976685bb7e5
+SHA256 (App-Cache-0.31.tar.gz) = ee2b6484b41f32b2d10a531e9e67ce0f0770491faa6af084da2d9e1a026a58a5
+SIZE (App-Cache-0.31.tar.gz) = 4467
diff --git a/devel/p5-App-Cache/pkg-descr b/devel/p5-App-Cache/pkg-descr
new file mode 100644
index 000000000000..366146f3012e
--- /dev/null
+++ b/devel/p5-App-Cache/pkg-descr
@@ -0,0 +1,18 @@
+The App::Cache module lets an application cache data locally. There are a
+few times an application would need to cache data: when it is retrieving
+information from the network or when it has to complete a large
+calculation.
+
+For example, the Parse::BACKPAN::Packages module downloads a file off the
+net and parses it, creating a data structure. Only then can it actually
+provide any useful information for the programmer.
+Parse::BACKPAN::Packages uses App::Cache to cache both the file download
+and data structures, providing much faster use when the data is cached.
+
+This module stores data in the home directory of the user, in a dot
+directory. For example, the Parse::BACKPAN::Packages cache is actually
+stored underneath "~/.parse_backpan_packages/cache/". This is so that
+permisssions are not a problem - it is a per-user, per-application cache.
+
+WWW: http://search.cpan.org/dist/App-Cache/
+Author: Leon Brocard <acme@astray.com>
diff --git a/devel/p5-App-Cache/pkg-plist b/devel/p5-App-Cache/pkg-plist
new file mode 100644
index 000000000000..affa1cae0b57
--- /dev/null
+++ b/devel/p5-App-Cache/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/App/Cache.pm
+@dirrmtry %%SITE_PERL%%/App