aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Cache-LRU
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2012-05-27 00:26:25 +0800
committerache <ache@FreeBSD.org>2012-05-27 00:26:25 +0800
commit292ffe6aa73420244def411abf3907c8d4a2c162 (patch)
tree13c3da77277f812e72370e9765a2e119c91b757e /devel/p5-Cache-LRU
parentb3c8207566cf8b310e577f5677ed0bb36933b451 (diff)
downloadfreebsd-ports-gnome-292ffe6aa73420244def411abf3907c8d4a2c162.tar.gz
freebsd-ports-gnome-292ffe6aa73420244def411abf3907c8d4a2c162.tar.zst
freebsd-ports-gnome-292ffe6aa73420244def411abf3907c8d4a2c162.zip
A simple, fast implementation of an in-memory LRU cache in pure perl.
Diffstat (limited to 'devel/p5-Cache-LRU')
-rw-r--r--devel/p5-Cache-LRU/Makefile25
-rw-r--r--devel/p5-Cache-LRU/distinfo2
-rw-r--r--devel/p5-Cache-LRU/pkg-descr4
-rw-r--r--devel/p5-Cache-LRU/pkg-plist5
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/p5-Cache-LRU/Makefile b/devel/p5-Cache-LRU/Makefile
new file mode 100644
index 000000000000..623c3f4798ce
--- /dev/null
+++ b/devel/p5-Cache-LRU/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Cache-LRU
+# Date created: 2012-05-26
+# Whom: Andrey Chernov <ache@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Cache-LRU
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:KAZUHO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A simple, fast implementation of an in-memory LRU cache
+
+TEST_DEPENDS= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires
+
+PERL_CONFIGURE= yes
+
+MAN3= Cache::LRU.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Cache-LRU/distinfo b/devel/p5-Cache-LRU/distinfo
new file mode 100644
index 000000000000..19c71e5a6733
--- /dev/null
+++ b/devel/p5-Cache-LRU/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Cache-LRU-0.03.tar.gz) = 7131f08a266274d1c9d3dbac77b610fe69fe1c8589b919833cc0482b1732eae9
+SIZE (Cache-LRU-0.03.tar.gz) = 19865
diff --git a/devel/p5-Cache-LRU/pkg-descr b/devel/p5-Cache-LRU/pkg-descr
new file mode 100644
index 000000000000..e7c05897ed4c
--- /dev/null
+++ b/devel/p5-Cache-LRU/pkg-descr
@@ -0,0 +1,4 @@
+A simple, fast implementation of an in-memory LRU cache in pure perl with
+the maximum number of entries to be stored within the cache object.
+
+WWW: http://search.cpan.org/dist/Cache-LRU/
diff --git a/devel/p5-Cache-LRU/pkg-plist b/devel/p5-Cache-LRU/pkg-plist
new file mode 100644
index 000000000000..6865826227d4
--- /dev/null
+++ b/devel/p5-Cache-LRU/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Cache/LRU.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cache/LRU/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cache/LRU
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cache
+@dirrmtry %%SITE_PERL%%/Cache